MozillaZine

No Chat Session (Solved)

User Help for Mozilla Firefox
John Liebson
 
Posts: 6585
Joined: July 29th, 2003, 1:09 pm

Post Posted April 21st, 2020, 8:39 am

I tried to start a chat session with a software company, and got this quite fascinating message:

HTTP ERROR 405

Problem accessing /content/s/prechatVisitor. Reason:

HTTP method GET is not supported by this URL

When I tried the session with Google Chrome, I was connected immediately. What was Firefox telling me, and why did it tell me whatever that was?
Last edited by John Liebson on April 22nd, 2020, 10:51 am, edited 1 time in total.

therube

User avatar
 
Posts: 20519
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted April 22nd, 2020, 7:35 am

URL to the site, chat link?
Fire 750, bring back 250.
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

John Liebson
 
Posts: 6585
Joined: July 29th, 2003, 1:09 pm

Post Posted April 22nd, 2020, 10:27 am

therube wrote:URL to the site, chat link?


Go to https://web.laplink.com/contact/ , click on "CHAT NOW".

mightyglydd

User avatar
 
Posts: 9908
Joined: November 4th, 2006, 7:07 pm
Location: Hollywood Ca.

Post Posted April 22nd, 2020, 10:39 am

WFM.......
#KeepFightingMichael and Alex.

therube

User avatar
 
Posts: 20519
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted April 22nd, 2020, 10:44 am

It's probably your ad blocker.
Disable uBlock & see if it works.
Then try to figure out what it is in uBlock that is breaking things & report it to them.

The chat "link" rolls over to a different URL, but that is not happening - probably due to uBlock.

Example chat "link" (that ends up not working):
Code: Select all
https://5zmw8.la1-c1-fra.salesforceliveagent.com/content/s/prechatVisitor?endpoint=https%3A%2F%2F5zmw8.la1-c1-fra.salesforceliveagent.com%2Fcontent%2Fs%2Fchat%3Flanguage%3Den_US%26org_id%3D00D200000006AgW%26deployment_id%3D5720O000000bz8X%26sid%3Dc4a66674-f152-4ad5-a02a-cc46b7c0b35a%23deployment_id%3D5720O000000bz8X%26org_id%3D00D200000006AgW%26button_id%3D5733X000000g5dl%26session_id%3Dc4a66674-f152-4ad5-a02a-cc46b7c0b35a

And (an example of) what it rolls over to (which works):
Code: Select all
https://60462.la1-c1-fra.salesforceliveagent.com/content/s/chat?language=en_US&org_id=00D200000006AgW&deployment_id=5720O000000bz8X&sid=2256ff6f-7ceb-43a3-bd76-258be89db2cb#deployment_id=5720O000000bz8X&org_id=00D200000006AgW&button_id=5733X000000g5dl&session_id=2256ff6f-7ceb-43a3-bd76-258be89db2cb
Fire 750, bring back 250.
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

John Liebson
 
Posts: 6585
Joined: July 29th, 2003, 1:09 pm

Post Posted April 22nd, 2020, 10:51 am

I found a way to get it work for me: I had been clicking on the last of four entries from the pop-up; this time, instead, I clicked on allowing pop-ups from the site, and the chat box popped up. Why the rather complex fourth entry did not work shall, to me, remain blissfully unknown.

therube

User avatar
 
Posts: 20519
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted April 22nd, 2020, 11:05 am

I'm wrong about uBlock.


Yeah, something about <SELF>.
I probably have popups blocked here. And did I do the similar in FF?

dom.popup_allowed_events;""

Yep, that's it on the SeaMonkey end.
Resetting the Pref, or allowing the correct popup to pop (in the blocked popup window notification) allows it to work (in SeaMonkey).
And the item that needed to pop was <SELF> (rather then what would appear to be the correct item, dealing with salesforceliveagent.com).

FF had (existing) entries for dom.popup_allowed_events.
(Thinking I had never messed with that - in this particular Profile.)
I cleared them, then reset to default, & with that then FF too could connect (which it was unable to do, initially).
Don't know if doing that made an actual difference or not or if it was just some sort of fluke that cleared itself?
Fire 750, bring back 250.
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

jscher2000

User avatar
 
Posts: 11039
Joined: December 19th, 2004, 12:26 am
Location: Silicon Valley, CA USA

Post Posted April 22nd, 2020, 2:49 pm

John Liebson wrote:I found a way to get it work for me: I had been clicking on the last of four entries from the pop-up; this time, instead, I clicked on allowing pop-ups from the site, and the chat box popped up. Why the rather complex fourth entry did not work shall, to me, remain blissfully unknown.

Is the last item the one saying you only want that specific popup window without setting a site-wide permission? Seems like a bug if Firefox knows how to launch the window (POST) but one of the options launches it the wrong way (GET). You could file here: https://bugzilla.mozilla.org/

That said, the popup isn't blocked for me in my regular profile. I didn't test in a clean profile.

John Liebson
 
Posts: 6585
Joined: July 29th, 2003, 1:09 pm

Post Posted April 23rd, 2020, 5:01 am

jscher2000 wrote:
John Liebson wrote:I found a way to get it work for me: I had been clicking on the last of four entries from the pop-up; this time, instead, I clicked on allowing pop-ups from the site, and the chat box popped up. Why the rather complex fourth entry did not work shall, to me, remain blissfully unknown.

Is the last item the one saying you only want that specific popup window without setting a site-wide permission? Seems like a bug if Firefox knows how to launch the window (POST) but one of the options launches it the wrong way (GET). You could file here: https://bugzilla.mozilla.org/

That said, the popup isn't blocked for me in my regular profile. I didn't test in a clean profile.


That is correct. I will report same.

John Liebson
 
Posts: 6585
Joined: July 29th, 2003, 1:09 pm

Post Posted April 28th, 2020, 10:04 am

I just got a series of Bugzilla email messages, most of which I won't even try to comprehend. After eight days or so, my report was closed as being a duplicate of the bug that the emails referred to. That bug indicates that the problem has been solved for a forthcoming release of Firefox.

therube

User avatar
 
Posts: 20519
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted May 2nd, 2020, 7:50 am

Care to post a link to your bug report?
Fire 750, bring back 250.
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

John Liebson
 
Posts: 6585
Joined: July 29th, 2003, 1:09 pm

Post Posted May 2nd, 2020, 8:14 am

therube wrote:Care to post a link to your bug report?


I had deleted all of the related email, so I went to Bugzilla, and eventually found the bug; that was anything but easy, places that I expected to show the number did not, etc. I eventually found it: #1632550.

therube

User avatar
 
Posts: 20519
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted May 4th, 2020, 12:53 pm

Fire 750, bring back 250.
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

Return to Firefox Support


Who is online

Users browsing this forum: Bing [Bot] and 12 guests