MozillaZine

"Sync" and Firefox versions

User Help for Mozilla Firefox
Ninho
 
Posts: 127
Joined: February 3rd, 2004, 8:53 am

Post Posted July 15th, 2018, 3:10 pm

Hi ! As we found previously, the Firefox "sync" method and servers changed once or more times in the past, but I am unable to find exactly when it did.

Can someone involved, please, tell me what version number was the earliest (oldest) Firefox version designed and intended to connect to and work with the current "Firefox Sync" system ?

TIA
Ninho

the-edmeister

User avatar
 
Posts: 32120
Joined: February 25th, 2003, 12:51 am
Location: Chicago, IL, USA

Post Posted July 18th, 2018, 12:05 pm

I am not "involved" other than as a Sync user since Firefox 3.5 and the original Weave extension, which was used to developer "Sync" on the side.

AFAIK, Firefox 29 is the oldest version of Firefox which will connect to the current Sync 1.5 server scheme; although Sync is currently at 1.62.0 (I think). But the features are limited to the version of Firefox that would be connecting.

Firefox 4 thru Firefox 28 (with Sync 1.1) used a completely different server array, which was kept running for close to a year after the Sync 1.5 was implemented. The old 1,1 server array ran parallel to the new Sync 1.5 server array for that long, but to keep using the old 1,1 version the user needed to create a new Sync account for the 1,5 version array.

The original Weave extension (now known as Sync 1.0, although the Weave name still is in the source code and inside Firefox), as used with Firefox 3.5 and 3.6, just stopped connecting to the Sync server part way into Dec 2010 - the login schema was changed entirely. That left those of us using Weave "up the creek without a paddle" and no way to connect to the Firefox 4.0 version "converted over" 1.1 server. And that happened 4 whole months before Firefox 4.0 was finally released!
A mind is a terrible thing to waste. Mine has wandered off and I'm out looking for it.

Ninho
 
Posts: 127
Joined: February 3rd, 2004, 8:53 am

Post Posted July 20th, 2018, 4:07 am

So, the short answer to the OQ would be : Firefox 29. This is confirming what I also independently thru some more web-digging and searching for the protocol used in Sync ...

Thanks, @the-edmeister, for the enlarged historical point of view !
Ninho

Return to Firefox Support


Who is online

Users browsing this forum: msan21 and 3 guests