MozillaZine

Firefox runs sluggish in windows 7 when using without glass

User Help for Mozilla Firefox
theannexed
 
Posts: 5
Joined: July 2nd, 2018, 5:07 pm

Post Posted July 2nd, 2018, 5:09 pm

Hi,

Whenever I turn off desktop composition in windows 7, my latest version Mozilla Firefox runs extremely sluggish but when I turn it back on it's smooth again. So I can't go without desktop composition when using firefox? This only happens with firefox as chrome works fast without desktop composition.

DanRaisch
Moderator

User avatar
 
Posts: 120282
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted July 2nd, 2018, 6:31 pm

Have you tried starting Firefox in Mozilla Safe Mode? http://kb.mozillazine.org/Safe_mode
If no improvement using Safe Mode, do you have the same problem if you create a new profile and test it with no extensions or non-default themes installed?
http://kb.mozillazine.org/Profile_Manager
and
http://kb.mozillazine.org/Creating_a_ne ... on_Windows

theannexed
 
Posts: 5
Joined: July 2nd, 2018, 5:07 pm

Post Posted July 2nd, 2018, 7:40 pm

DanRaisch,

It did not resolve the problem in safemode nor on a new account with no extension. I only have adblock for extension. I deleted that as well.

Also want to add that this windows 7 is a fresh install.

therube

User avatar
 
Posts: 19109
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted July 3rd, 2018, 12:12 pm

What is "desktop composition"?

(My Win7 looks like XP.
My XP isXP.)

Windows Desktop Composition (DWM) enables visual effects on the desktop as well as various features such as glass window frames, 3-D window transition animations, Windows Flip and Windows Flip3D, and high resolution support.


AFAIK, I have everything turned off for "visual effects" except for drop shadows on desktop icons.

What video card (or onboard) are you using?
Any change if you test while running your computer in Safe Mode with Networking?
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

theannexed
 
Posts: 5
Joined: July 2nd, 2018, 5:07 pm

Post Posted July 3rd, 2018, 2:12 pm

Hi,

My video card is Nvidia GTX 780, it runs fine with everything basically. The "desktop composition" is basically the Windows 7 clear glass theme", I tried going into safemode on firefox. Only way to resolve is leaving desktop composition. It's just strange how Firefox reacts negatively when I turn it off. I've even reached out to people on #freenode windows to help, they couldn't figure it out . But they did give me one good insight. They told me that desktop composition uses the computer's GPU to process things and when it's off, it would use the CPU.

therube

User avatar
 
Posts: 19109
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted July 4th, 2018, 6:18 am

test while running your computer in Safe Mode with Networking
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

theannexed
 
Posts: 5
Joined: July 2nd, 2018, 5:07 pm

Post Posted July 4th, 2018, 10:47 am

Nope, laggy in safe mode with networking, basically everything is laggy in safe mode.

DanRaisch
Moderator

User avatar
 
Posts: 120282
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted July 4th, 2018, 12:05 pm

Just to be sure, you’re speaking of Windows Safe Mode with networking, right?

theannexed
 
Posts: 5
Joined: July 2nd, 2018, 5:07 pm

Post Posted July 4th, 2018, 12:16 pm

DanRaisch,

Yup, I went to msconfig and enabled boot into networking mode. After I restarted, I'm in networking safe mode. So in networking safe mode, moving things around is very sluggish. I'm not sure what safe mode would accomplish. Safe mode has always been sluggish for me.

To also fix this, when I use firefox, I have to set the computer back to aero glass and then switching it off but if i close the browser, i would have to do it again to fix the lag. So I have been doing this every time after I close and re-open the browser.

Return to Firefox Support


Who is online

Users browsing this forum: Google Adsense [Bot] and 7 guests