MozillaZine

Missing Favicons

User Help for Mozilla Firefox
tpaulr
 
Posts: 395
Joined: June 22nd, 2004, 8:01 am

Post Posted June 18th, 2018, 1:27 pm

Afternoon...

Since the upgrade to 60.02 I have lost all of my bookmark favicons, not some, all of them.

I have no clue how to get them back without going to every site - I did do that with about 200 bookmarks after the upgrade - but, they didn't remain after I rebooted the next morning.

Any solution that will restore them en mass?

This gets tiresome after all these versions of Firefox...

Thanks, in advance. :? ](*,)

dickvl

User avatar
 
Posts: 52388
Joined: July 18th, 2005, 3:25 am

Post Posted June 18th, 2018, 4:35 pm

This can happen if there has been a problem with places.sqlite or favicons.sqlite.
The latter stores favicon data.
You will have to revisit each bookmark to make Firefox retrieve its favicon.
http://kb.mozillazine.org/Profile_folder_-_Firefox

tpaulr
 
Posts: 395
Joined: June 22nd, 2004, 8:01 am

Post Posted June 19th, 2018, 6:12 am

Dick,

As always, thanks.

Not likely going to do this, I have almost 4000 bookmarks.

The issue I am most concerned with, as mentioned, is that I did this for about 200 sites just to see, the next morning when I booted up, they were gone again.

RobertJ
Moderator

User avatar
 
Posts: 10597
Joined: October 15th, 2003, 7:40 pm
Location: Chicago IL/Oconomowoc WI

Post Posted June 19th, 2018, 9:43 am

tpaulr wrote: I did do that with about 200 bookmarks after the upgrade - but, they didn't remain after I rebooted the next morning.


Shot in the dark. After changing that many favicons it will likely take FF a bit of time to update favicons.sqlite when shutting down. Make sure FF is completely shut down before you shut down your computer.

You might also try something a little less extensive. Test with 20 bookmarks, shut down FF and when you are sure it is shut down reboot your computer and see what happens.

.
FF 61.0.2 - FF 62b17 - FF 63a - TB 52.9.1 - Mac OSX 10.13.6
Computers I've used: IBM 7094/UNIVAC 1108/IBM 360/DEC PDP11/DEC VAX-11 780/DEC VAXstation 8000/Sun SPARCstation 2/Mac from 1984 to 2018

DanRaisch
Moderator

User avatar
 
Posts: 119900
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted June 19th, 2018, 9:49 am

You're not running any clean up utilities like Ccleaner, are you?
What security software is running on that system?

therube

User avatar
 
Posts: 18912
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted June 19th, 2018, 9:52 am

Since the upgrade to 60.02

What did you upgrade from?
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

tpaulr
 
Posts: 395
Joined: June 22nd, 2004, 8:01 am

Post Posted June 19th, 2018, 10:09 am

Let's take them in order...

Robert J: Will try a smaller control group, will make sure FF is shut down completely.

Dan: No, after being on this forum for 14 years, I absolutely don't use things like CC Cleaner. I use Panda real-time.

Rube: Upgraded from 60.01, been a steady progression of upgrades right along. I had all of my favicons in 60 and 60.01, no issues, in fact, no issues for years, maybe 2005 or so since the last issue with favicons.

Thanks...

therube

User avatar
 
Posts: 18912
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted June 19th, 2018, 11:52 am

(
I had all of my favicons in 60 and 60.0.1

Then mighty strange that they would up & go with 60.0.2.)

I have no clue how to get them back without going to every site - I did do that with about 200 bookmarks after the upgrade - but, they didn't remain after I rebooted the next morning.


If you add, change a bookmark, is that retained after a browser restart?

Check your Profile folder & see if you might have anything odd in there, like incremented file names; places-1.sqlite, places-2.sqlite, places-3.sqlite ...
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

tpaulr
 
Posts: 395
Joined: June 22nd, 2004, 8:01 am

Post Posted June 19th, 2018, 3:09 pm

Rube,

Nothing funky in my profile that I can see.

Not having trouble saving bookmarks. I bookmarked about 15 sites today, but no favicons.

I did change about 25 earlier, favicons were added to some bookmarks, some, no favicons added even after I closed and re-opened.

Geekwire is one of them, can't get the favicon to render, no matter what, same with the Wirecutter, Siemens, Toms Hardware, a number of them.

Any ideas?

Thanks...

The Tinsmith
 
Posts: 833
Joined: December 24th, 2011, 10:29 am

Post Posted June 19th, 2018, 3:22 pm

Any ideas?



Excuse me.

First I do not recall the exact details or exactly when but there was a change in the format of favicons a while back and how Firefox stores them. It had something to do with the size and the quality of the favicon. The 'new ones', if available, provided by the website would replace the 'old ones' else you would get a blank. It was discussed here some time ago.

Perhaps someone with more free time than I have can find this?

dickvl

User avatar
 
Posts: 52388
Joined: July 18th, 2005, 3:25 am

Post Posted June 21st, 2018, 6:42 pm

You can check these browser.chrome preferences on the about:config page.
browser.chrome.favicons
browser.chrome.site_icons

Try to rename or remove favicons.sqlite in case there is a problem with the file.

tpaulr
 
Posts: 395
Joined: June 22nd, 2004, 8:01 am

Post Posted June 21st, 2018, 7:35 pm

Dick,

Thanks.

Already checked the config, they are both true.

Looks like I'm going to have to just bite the bullet and remove the file, visit all 4000+ bookmarks.

Not going to happen anytime soon, unfortunately, got a business to run...

Thanks.

tpaulr
 
Posts: 395
Joined: June 22nd, 2004, 8:01 am

Post Posted June 24th, 2018, 4:43 am

Dick,

As I get around to some of my bookmarks in the normal course of my business over the past few days, I noticed that no favicon shows up even after I go to the site.

They did a few days ago, they were gone after I closed FF, but they were there during that session.

I looked at my profile this morning to see what is going on and I now have 3 favicon files:

favicon.sqlite....5120 KB
favicon.sqlite-shm...32 KB
favicon.sqlite-wal...2050 KB

Have no idea what the other 2 are or where they came from, they were dated as of this morning.

Can I safely get rid of the 2 new files?

Should I get rid of all 3?

Please let me know...

Thanks so much. :)

RobertJ
Moderator

User avatar
 
Posts: 10597
Joined: October 15th, 2003, 7:40 pm
Location: Chicago IL/Oconomowoc WI

Post Posted June 24th, 2018, 8:19 am

.
The files

favicons.sqlite-shm...32 KB
favicons.sqlite-wal...2050 KB

are temporary and only exist when FF is running. They are used to speed FF and update favicons.sqlite during the FF shutdown process.

THEY SHOULD NOT EXIST WHEN FF IS NOT RUNNING.

.
Last edited by RobertJ on June 24th, 2018, 8:40 am, edited 1 time in total.
Reason: Added s's per therube's post
FF 61.0.2 - FF 62b17 - FF 63a - TB 52.9.1 - Mac OSX 10.13.6
Computers I've used: IBM 7094/UNIVAC 1108/IBM 360/DEC PDP11/DEC VAX-11 780/DEC VAXstation 8000/Sun SPARCstation 2/Mac from 1984 to 2018

therube

User avatar
 
Posts: 18912
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted June 24th, 2018, 8:34 am

(The file name is, favicons.sqlite, not favicon.sqlite.
If you actually have favicon.sqlite...)
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

Return to Firefox Support


Who is online

Users browsing this forum: Google [Bot] and 13 guests