MozillaZine

Suppressing initial launch of firefox after installation

User Help for Mozilla Firefox
thisisevilevil
 
Posts: 1
Joined: June 17th, 2018, 8:27 am

Post Posted June 17th, 2018, 8:40 am

Hi

After firefox 60, firefox now launches by default right after installation. I'm installing firefox with silent switches "Firefox Installer.exe -ms". Is there a way to suppress the initial launch of firefox? It's not a biggie, but we are using HideShell=Yes in our MDT Task sequences for a reason; So our users can't mess with anything while the task sequence is running. Currently as a workaround I've simply added a seperate TS Step that launches "taskkill /f /im firefox.exe", but it would be nice with a cmdline switch to suppress it with the actual installer.

Thanks in advance.

Brummelchen
 
Posts: 3656
Joined: March 19th, 2005, 10:51 am

Post Posted June 17th, 2018, 9:08 am

"Firefox Installer.exe -ms"

looks like the online setup, get offline setup instead.
https://www.mozilla.org/firefox/all/

therube

User avatar
 
Posts: 19040
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted June 18th, 2018, 5:56 am

Oh, you're saying the full installer instead of the stub-installer.
I'm sure he is starting with the former.


I don't see where anything is mentioned about browser startup, Full Installer Configuration?


Running sandboxed (Sandboxie), I did not have any Profile automatically open after silent install?

> Firefox Setup 60.0.1esr.exe /S

Installed, & that was the extent of things.

My non-sandboxed Profiles.ini, should that make a difference:
Note that StartWithLastProfile is non-default, so I will be prompted to select a Profile, if it came to that.
Code: Select all
[General]
StartWithLastProfile=0

[Profile0]
Name=FF58
IsRelative=0
Path=C:\Mozilla\USERS\FF58

[Profile1]
Name=FF59
IsRelative=0
Path=C:\Mozilla\USERS\FF59

[Profile2]
Name=FF60
IsRelative=0
Path=C:\Mozilla\USERS\FF60
Default=1



(AFAIK, current FF, run in Sandboxie, will open, but not actually load websites.
And in my testing, FF did not even open after silent install - in Sandboxie.)


Profiles.ini seems to have no bearing.
(Seems an install does not even create a profiles.ini. It is not until firefox.exe is actually run that it is created.)
Silent install seems to install, silently, with the browser not opening on its completion (at least in Sandboxie).
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

Brummelchen
 
Posts: 3656
Joined: March 19th, 2005, 10:51 am

Post Posted June 20th, 2018, 9:42 am

the /S switch is for nsis, but not for the internal setup -> /ms (see above)

my test was with the full setup, not with online loader and passed successfully and did not start firefox.

therube

User avatar
 
Posts: 19040
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted June 20th, 2018, 10:37 am

(Docs, if I'm understanding, state that /S & -ms are synonymous.)
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

Brummelchen
 
Posts: 3656
Joined: March 19th, 2005, 10:51 am

Post Posted June 20th, 2018, 10:55 am

maybe - but nsis dont know -ms
trust me, i write nsis ;)

the complete (?) code
https://dxr.mozilla.org/mozilla-beta/so ... ndows/nsis

Return to Firefox Support


Who is online

Users browsing this forum: Google [Bot] and 8 guests