MozillaZine

How to disable the 'Check for updates' button on FX 52.9 ESR

User Help for Mozilla Firefox
therube

User avatar
 
Posts: 19187
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted June 10th, 2018, 8:40 am

this did NOT work


For whatever reason, pref("app.update.auto", false); does not get set (to 'false').
No idea why not?
The other two do get set as expected.

And that does help, somewhat.

With the two that do get set, I believe that it will at least stop "automatic" updates.
It should also limit 'Help | About', in that that alone will not cause an update.
Where it fails, by not having pref("app.update.auto", false); set, is in Help | About, if you actually click the 'Check For Updates' button, it not only checks, but will actually update you.

If you do have, pref("app.update.auto", false); (which autoconfig.js is not setting, for whatever reason), then Help | About -> Check will report an update is available, but not actually effect the update until you click that button again.

So in one mode it updates, automatically.
In the other, it reports an update is available, but does not automatically do anything.
So it gives you an avenue to see but not act.


And all this aside, as far as why an update may or may not occur, why an update may happen unexpectedly, at unexpected times, have a gander at some of the stuff I wrote, link in the dslreports link.
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

therube

User avatar
 
Posts: 19187
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted June 10th, 2018, 8:44 am

For whatever reason, pref("app.update.auto", false); does not get set (to 'false').
No idea why not?

Thinking that like autoconfig.js, the associated file (named mozilla.cfg in my case) also ignores the first line in the file (or as Mozilla puts it, It should always begin with a commented line:")

So changing mozilla.cfg to:

Code: Select all
#hi there you swine

pref("app.update.auto", false);
pref("app.update.enabled", false);
pref("app.update.service.enabled", false);

does set all three Prefs.
And this works just as well too:
Code: Select all
pref("app.update.auto", false);
pref("app.update.auto", false);
pref("app.update.enabled", false);
pref("app.update.service.enabled", false);

First line is ignored it seems.


And with that, with the Prefs being set as wanted, FF should not "automatically" update.
Help | About -> 56.0.2
'Check for updates' -> shows a button, 'Update to 60.0.2'
Dismiss the dialog, & all is well.
No update is pending, no update is queued or even noted in %APPDATA%\Local\Mozilla\updates.

Now, if you did click the 'Update to 60.0.2' button, then what happens (you're updated), it's on you.
(Now there are ways to thwart that, but we won't go into that here.)
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

therube

User avatar
 
Posts: 19187
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted June 10th, 2018, 9:03 am

And what happens in an existing Profile, or if the Prefs are at their defaults or you set them to true?

Code: Select all
("app.update.auto", true);
("app.update.enabled", true);
("app.update.service.enabled", true);


prefs.js gets the changes from autoconfig.js / mozilla.cfg, affecting those changes before FF is opened, so when opened, regardless of their settings before, they are now set to 'false'.
And that is good.


So the main failing, as I see it, is if the user clicks the update 'button'.
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

c627627

User avatar
 
Posts: 562
Joined: April 3rd, 2005, 12:58 pm
Location: Kansas

Post Posted June 10th, 2018, 7:10 pm

There is a lot of info here - head spinning. Let me try to simplify it. Button was the ONLY update mechanism, I knew how to turn everything else off and am kind of surprised why people have problems other then when THEY press the button.

This thread taught me (thanks to morat) how to hide the button. The End, problem solved.


So things are pretty good -- now we are trying to take the bonus step: Disabling update trigger from other/newly created profiles.
*since button can only be disabled on current - not new profiles*
If only you would copy/paste your method into this thread, that would save a HUGE amount of time.

So far none of us posting here knows how to use autoconfig.js to block updates on newly created profiles, which means your method, whatever it is, is the ONLY method that anyone participating in this thread claims can work.
Open the pod bay doors, Cortana.

c627627

User avatar
 
Posts: 562
Joined: April 3rd, 2005, 12:58 pm
Location: Kansas

Post Posted June 10th, 2018, 7:16 pm

P.S. In case I wasn't clear, there have to be other settings, these set to FALSE do not disable updates:

app.update.auto
app.update.enabled
app.update.service.enabled
Open the pod bay doors, Cortana.

Frank Lion

User avatar
 
Posts: 20102
Joined: April 23rd, 2004, 6:59 pm
Location: ... The Exorcist....United Kingdom

Post Posted June 10th, 2018, 7:52 pm

c627627 wrote:So with that out of the way, a quick question, setting these to FALSE disables updates on all profiles?

app.update.auto
app.update.enabled
app.update.service.enabled

No.

We stopped ESR updating over 6 years ago now. You go into the app folder and find \defaults\pref\channel-prefs.js. That will point to esr and you just change it to anything, like esrr. With this method, you also don't have to bother hiding the update button.

When it checks for updates, it is then checking a non-existent channel, and so can't update. Good job I finally skim read this thread or it would have run forever. People overthink this stuff.

We came up with this as, back in the day, the damn thing would auto update if you so much as opened the About Firefox window - a cheap trick and I think even Mozilla realised it was and stopped doing it.

It's a trick that works with all their stuff, which is why as of today's date it still thinks my beta is up to date -

Image
Metal Lion latest SeaMonkey & Thunderbird Themes - Sea Monkey and Silver Sea Monkey
"The only thing necessary for the triumph of evil, is for good men to do nothing." - Edmund Burke (attrib.)

therube

User avatar
 
Posts: 19187
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted June 11th, 2018, 3:40 am

So far none of us posting here knows how to use autoconfig.js to block updates on newly created profiles

No.
Using autoconfig.js does work - once you get the associated files correct (correct syntax, if you will).
And it works for both new & existing Profiles.

In case I wasn't clear, there have to be other settings, these set to FALSE do not disable updates

There are other situations in which an update can occur.
Like if you have pending updates in your /updates/0/ directories. Possible that depending upon circumstances, they may kick in, updating you - unexpectedly.
Make sure you /updates/0/ is empty (or essentially empty, i.e., at least no .mar files).
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

c627627

User avatar
 
Posts: 562
Joined: April 3rd, 2005, 12:58 pm
Location: Kansas

Post Posted June 11th, 2018, 2:23 pm

Frank Lion wrote:Good job I finally skim read this thread or it would have run forever. People overthink this stuff.


Yes, good thing, we could use everyone's help.
Frank:
1. Close Firefox ESR 52.8.0
2. Rename C:\Program Files (x86)\Mozilla Firefox\defaults\pref\channel-prefs.js
3. Start Firefox.
4. Help > About > Check for Updates
5. Firefox still gets 100% updated to v52.8.1

Conclusion: renaming this file does not work: C:\Program Files (x86)\Mozilla Firefox\defaults\pref\channel-prefs.js

Please post what I did wrong, if you have time. And thank you.


therube What should the contents of mozilla.cfg be if not:
pref("app.update.auto", false);
pref("app.update.enabled", false);
pref("app.update.service.enabled", false);

Those contents DO set all the preferences listed to false on ALL profiles, yet Firefox ESR 52.8.0 still updates to 52.8.1


Once again, partial solution of hiding the button is excellent and works.
But it would be a bonus if a solution could be also found for newly created profiles where of course the button would not be hidden.
therube, what is your solution other than posted above? The one you say others frown upon. Since as of now, there is no global disabling solution posted here.
Open the pod bay doors, Cortana.

Frank Lion

User avatar
 
Posts: 20102
Joined: April 23rd, 2004, 6:59 pm
Location: ... The Exorcist....United Kingdom

Post Posted June 11th, 2018, 2:31 pm

c627627 wrote:Conclusion: renaming this file does not work: C:\Program Files (x86)\Mozilla Firefox\defaults\pref\channel-prefs.js

Please post what I did wrong, if you have time. And thank you..

You don't rename the file, you change what's in the file. Just read the file itself, with Programmer's Notepad or any proper text editor, and then -
That will point to esr and you just change it to anything, like esrr.
Metal Lion latest SeaMonkey & Thunderbird Themes - Sea Monkey and Silver Sea Monkey
"The only thing necessary for the triumph of evil, is for good men to do nothing." - Edmund Burke (attrib.)

c627627

User avatar
 
Posts: 562
Joined: April 3rd, 2005, 12:58 pm
Location: Kansas

Post Posted June 11th, 2018, 2:36 pm

Eureka.

Finally.
Thank you.

Use Notepad to open
C:\Program Files (x86)\Mozilla Firefox\defaults\pref\channel-prefs.js

then simply change


/* This Source Code Form is subject to the terms of the Mozilla Public
* License, v. 2.0. If a copy of the MPL was not distributed with this
* file, You can obtain one at http://mozilla.org/MPL/2.0/. */

pref("app.update.channel", "esr");


to:


/* This Source Code Form is subject to the terms of the Mozilla Public
* License, v. 2.0. If a copy of the MPL was not distributed with this
* file, You can obtain one at http://mozilla.org/MPL/2.0/. */

pref("app.update.channel", "esrDISABLED");
Open the pod bay doors, Cortana.

Frank Lion

User avatar
 
Posts: 20102
Joined: April 23rd, 2004, 6:59 pm
Location: ... The Exorcist....United Kingdom

Post Posted June 11th, 2018, 3:07 pm

c627627 wrote:pref("app.update.channel", "esrDISABLED");

Yep, that's the idea. If you look at my screenshot above, you'll see mine is called betaa. It doesn't matter what you call it, just so long as it doesn't exist.

This technique is one I use a lot on other stuff and takes advantage of the fact that no matter how complex the calls from the app/profile or from the server destination that the 'message' has to go through a very particular pathway. Disrupt the pathway and the message never gets there. You also don't have to worry about hiding that button or newly created profiles.

Here, I'm just letting it do its thing, knowing damn well that its messages are being sent to somewhere that doesn't exist.
Metal Lion latest SeaMonkey & Thunderbird Themes - Sea Monkey and Silver Sea Monkey
"The only thing necessary for the triumph of evil, is for good men to do nothing." - Edmund Burke (attrib.)

c627627

User avatar
 
Posts: 562
Joined: April 3rd, 2005, 12:58 pm
Location: Kansas

Post Posted June 11th, 2018, 7:05 pm

Yes.
And on that topic, it is more elegant to disable updates in regular settings then hide the button because with button hidden, a user does not see the "Firefox is up to date" when the button is pressed, which is incorrect if there is an update.

But since button cannot be hidden in new profiles,... the approach to both hide the button in existing profiles in combo with your method is as perfect of a solution as can be expected!



On a side note, out if curiosity, what did you mean by "We stopped ESR updating over 6 years ago now."
Also, I started a new thread on this important Firefox ESR problem, banking and other sites are labeling the just updated Firefox ESR as outdated, what can we do about that:
viewtopic.php?f=38&t=3040535
Open the pod bay doors, Cortana.

Frank Lion

User avatar
 
Posts: 20102
Joined: April 23rd, 2004, 6:59 pm
Location: ... The Exorcist....United Kingdom

Post Posted June 11th, 2018, 7:39 pm

c627627 wrote:... a user does not see the "Firefox is up to date" when the button is pressed, which is incorrect if there is an update.


It's important to understand that with the method I have outlined that the user will always see the 'Firefox is up to date' message, even if an update is available. as we have deliberately broken the message connection.

The way to understand this is to realise that default position messages are often not true, but are all a browser has to offer in the circumstances. For example. For example, the 'Whoa! your browser is really old and unsupported!' stuff usually means nothing of the sort, merely that the site has not been coded to recognise that particular browser. A good workaround is available for that*. There are many, many other examples.

I'll deal with that workaround and the other points you raised another time, when I have more time. But, suffice to say, all are solvable and you can stay in total control and play this stuff like a fiddle...when you know how.
Metal Lion latest SeaMonkey & Thunderbird Themes - Sea Monkey and Silver Sea Monkey
"The only thing necessary for the triumph of evil, is for good men to do nothing." - Edmund Burke (attrib.)

Return to Firefox Support


Who is online

Users browsing this forum: Google [Bot] and 15 guests