MozillaZine

FF 60: Gecko_IOThread ??

User Help for Mozilla Firefox
Markco
 
Posts: 15
Joined: June 22nd, 2011, 4:07 am

Post Posted May 12th, 2018, 5:55 pm

In English:
-----------

Hello,

Since version 60 there is a Gecko_IOThread which is in memory after closing of firefox what is it?

How to delete it?

Thank you

In French:
-----------

Bonjour,

Depuis la version 60, il y a un Gecko_IOThread qui reste en mémoire après la fermeture de Firefox, qu'est ce que c'est ?

Comment le supprimer

Merci
Sorry, I use an online translator French / English
---
OS: Linux Mint 18.3 - kernel : 4.15.0-23-generic x86_64 /---/ Profil Firefox : 61.0.1 /---/ Profil Waterfox : 56.2.1 /---/Profil TB : 52.9.0

Brummelchen
 
Posts: 3578
Joined: March 19th, 2005, 10:51 am

Post Posted May 12th, 2018, 11:49 pm

user agent is telling us that you are using firefox 52, is that right?
Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0

if that is correct and all your firefox are using same profile you should
1 refresh profile
2 each version its own profile

Markco
 
Posts: 15
Joined: June 22nd, 2011, 4:07 am

Post Posted May 13th, 2018, 2:31 am

No, I'm using FF 60

Image
Sorry, I use an online translator French / English
---
OS: Linux Mint 18.3 - kernel : 4.15.0-23-generic x86_64 /---/ Profil Firefox : 61.0.1 /---/ Profil Waterfox : 56.2.1 /---/Profil TB : 52.9.0

Brummelchen
 
Posts: 3578
Joined: March 19th, 2005, 10:51 am

Post Posted May 13th, 2018, 3:22 am

see 1) or revert all changes. fake user agents dont have advantage. it seems profile caused.

see also
https://github.com/SeleniumHQ/selenium/issues/5303

therube

User avatar
 
Posts: 18912
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted May 13th, 2018, 5:58 am

there is a Gecko_IOThread which is in memory after closing of firefox

How are you determining that?

If you start FF in Safe Mode, then exit, do you still see that "Gecko_IOThread"?
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

James
Moderator

User avatar
 
Posts: 27352
Joined: June 18th, 2003, 3:07 pm
Location: Made in Canada

Post Posted May 13th, 2018, 1:43 pm

Markco wrote:No, I'm using FF 60

You likely toggled the privacy.resistfingerprinting in about:config as one of the things this Preference does is change the useragent to appear as if you have Firefox 52.0 as you can see by bottom right of your posts here.

Markco
 
Posts: 15
Joined: June 22nd, 2011, 4:07 am

Post Posted May 13th, 2018, 2:34 pm

privacy.resistfingerprinting is false

Edit: now 59 !!!!
Sorry, I use an online translator French / English
---
OS: Linux Mint 18.3 - kernel : 4.15.0-23-generic x86_64 /---/ Profil Firefox : 61.0.1 /---/ Profil Waterfox : 56.2.1 /---/Profil TB : 52.9.0

Brummelchen
 
Posts: 3578
Joined: March 19th, 2005, 10:51 am

Post Posted May 14th, 2018, 5:56 am

this is pointless - you ran into next trouble.

create a new profile
http://kb.mozillazine.org/Creating_a_ne ... on_Windows
or
http://kb.mozillazine.org/Profile_Manager

This article explains how to selectively transfer Firefox user data and settings to a new Firefox profile
http://kb.mozillazine.org/Transferring_ ... _-_Firefox

Markco
 
Posts: 15
Joined: June 22nd, 2011, 4:07 am

Post Posted May 17th, 2018, 4:42 am

New profile and transfer user data and seetings, Gecko_IOThread always appears at times.
Sorry, I use an online translator French / English
---
OS: Linux Mint 18.3 - kernel : 4.15.0-23-generic x86_64 /---/ Profil Firefox : 61.0.1 /---/ Profil Waterfox : 56.2.1 /---/Profil TB : 52.9.0

Markco
 
Posts: 15
Joined: June 22nd, 2011, 4:07 am

Post Posted June 15th, 2018, 1:40 am

I come back on the problem of Gecko_IOThread, I just made a long test with version 59.03 and it works fine. The problem is specific to version 60 and higher (beta and nigthly)
Sorry, I use an online translator French / English
---
OS: Linux Mint 18.3 - kernel : 4.15.0-23-generic x86_64 /---/ Profil Firefox : 61.0.1 /---/ Profil Waterfox : 56.2.1 /---/Profil TB : 52.9.0

Markco
 
Posts: 15
Joined: June 22nd, 2011, 4:07 am

Post Posted July 10th, 2018, 12:34 am

I come back to my problem of this famous Gecko_IOThread, I just passed this: browser.tabs.remote.autostart to false. And Gecko_IOThread does not seem to be a problem anymore. On the other hand what I really do not understand is the reason, because with the versions 56,57,58 and 59 it was on true and it worked very fine, it is frankly weird this story!
Sorry, I use an online translator French / English
---
OS: Linux Mint 18.3 - kernel : 4.15.0-23-generic x86_64 /---/ Profil Firefox : 61.0.1 /---/ Profil Waterfox : 56.2.1 /---/Profil TB : 52.9.0

Return to Firefox Support


Who is online

Users browsing this forum: Google [Bot] and 8 guests