MozillaZine

Unable to connect to gofarrewards.wf.com

User Help for Mozilla Firefox
Dick Guertin
 
Posts: 127
Joined: December 30th, 2004, 3:23 pm

Post Posted February 13th, 2018, 4:54 pm

I'm reporting a problem with Firefox 56.0.2 (and beyond). I tried to redeem my Wells Fargo Rewards using two different https addresses: 1) https://www.wellsfargorewards.com and 2) https://connect.secure.wellsfargo.com/a ... in/rewards

Unfortunately, as I tried to "Sign In' with either address, I got this response from Firefox:
==========
Your connection is not secure

The owner of gofarrewards.wf.com has configured their website improperly. To protect your information from being stolen, Firefox has not connected to this website.
==========

This does NOT happen with Safari or Chrome on my MacOS Yosemite or Sierra systems.

FYI, this isn't the first bug I've found this month. Here's another on the Support Forum:

Why does FF 56.0.2 'jump' to the bottom of a page upon loading?
https://support.mozilla.org/en-US/questions/1203875
Dick.Guertin; Firefox 56.0.2;
Mac OSX 10.10.6; 2.5 Ghz Intel Core I5

DanRaisch
Moderator

User avatar
 
Posts: 119922
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted February 13th, 2018, 5:29 pm

Moving to Firefox Support where this will be seen by more members. It will be difficult for anyone to check the functionality of the Wells Fargo site because it would require a user ID and password.

Dick Guertin
 
Posts: 127
Joined: December 30th, 2004, 3:23 pm

Post Posted February 13th, 2018, 10:25 pm

DanRalach, under who's name was it posted on Firefox Support? I can't find it.

Note, I tried some of the tips given at this Firefox Support item:

https://support.mozilla.org/en-US/kb/fi ... n-settings

I tried altering the Proxy setting, and the dns.IPv6 setting (false -> true). Neither made any difference.
Dick.Guertin; Firefox 56.0.2;
Mac OSX 10.10.6; 2.5 Ghz Intel Core I5

DanRaisch
Moderator

User avatar
 
Posts: 119922
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted February 14th, 2018, 5:51 am

Um, it's under your name in Firefox Support, you just posted to it.
Did you clear the cache and any cookies associated with WF?
Do you have Firefox set to permit cookies from Wells Fargo?

atlanto
 
Posts: 47
Joined: March 7th, 2015, 4:19 pm
Location: Japan

Post Posted February 14th, 2018, 7:00 am

>Unable to connect to gofarrewards.wf.com
If I accessed https://gofarrewards.wf.com/, it leads Insecure Connection page having 'Advanced' button. (on Windows and Linux, with Firefox 58.0.2 and 60.0a1(nightly build). No such problem with Vivaldi)
If you clicked 'Advanced' button, you could see more details and 'Add Exception...' button.
You're able to add exception for gofarrewards.wf.com.
(@see How to troubleshoot the error code "SEC_ERROR_UNKNOWN_ISSUER" on secure websites | Firefox Help)

However, since you can access the site by using other browser, you might be able to export certificate 'Wells Fargo Public Trust Certification Authority 01 G2' (issued by 'DigiCert Global Root G2', *not* other certificate) on the browser and import it to Firefox.
(I wouldn't explain how to export, since it depends on environment(OS, browser))
I cannot say it will solve your problem though.

therube

User avatar
 
Posts: 18923
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted February 14th, 2018, 10:21 am

I'd call Wells Fargo "tech support" & complain/ask.
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

TheVisitor
 
Posts: 4655
Joined: May 13th, 2012, 10:43 am

Post Posted February 14th, 2018, 10:30 am

Doesn't Wells Fargo use IBM's Trusteer Rapport security for login ? I seem to recall there have been issues with 'Trusteer' & Firefox in the past.

Check you addons/extensions/plugins see if you have anything named that as its a download you have to do before you can login. Likely that Trusteer just hasn't caught up with Latest Firefox.

EDIT: If indeed they use 'Trusteer' there an update for Firefox 58, see here: https://www.trusteer.com/en/support/rap ... tion-links

therube

User avatar
 
Posts: 18923
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted February 14th, 2018, 10:48 am

You don't need to log in or anything like that.
Simply load, https://gofarrewards.wf.com/.
ERROR.
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

Dick Guertin
 
Posts: 127
Joined: December 30th, 2004, 3:23 pm

Post Posted February 14th, 2018, 11:48 am

To all who've responded since the Moderator, 1) I'm unwilling to update Firefox beyond 56.0.2 because I'd loose all my Extensions and Plug-Ins. I use "Saved Password Editor", "Cookies Manager+", and "Clear Site Cache" frequently, and I'd loose capabilities without them. 2) I've contacted WF, and they are perplexed by this situation; i.e. their only advice is to stop using Firefox. 3) I have "Accept cookies from websites" checked; "Accept 3rd party cookies" Always; "Keep until" they expire. I'm in a bind, because 'other' browsers' may not have the Extensions I'm using.
Dick.Guertin; Firefox 56.0.2;
Mac OSX 10.10.6; 2.5 Ghz Intel Core I5

TheVisitor
 
Posts: 4655
Joined: May 13th, 2012, 10:43 am

Post Posted February 14th, 2018, 1:09 pm

therube wrote:You don't need to log in or anything like that.
Simply load, https://gofarrewards.wf.com/.
ERROR.


That URL does not seem to be valid one for the rewards site, as the one the OP used WFM, no errors.

EDIT: However ... that URL works in Edge,Chrome,IE11

I would file a bug, it could be something in Firefox, or maybe it will turn out to be a tech evangelism bug and Mozilla will work with WF on the problem.

Dick Guertin
 
Posts: 127
Joined: December 30th, 2004, 3:23 pm

Post Posted February 14th, 2018, 2:08 pm

TheVisitoe, I don't know what you mean by "the OP used WFM". As I said in my original post, there are TWO web addresses to get to Wells Fargo Rewards, and NEITHER work on Firefox (56.02 and above). They BOTH work in other browsers. I tried to file a bug report on "Firefox Bugs", but was told to file it on this forum. It was 'moved' here by the Moderator of "Firefox Bugs".
Dick.Guertin; Firefox 56.0.2;
Mac OSX 10.10.6; 2.5 Ghz Intel Core I5

TheVisitor
 
Posts: 4655
Joined: May 13th, 2012, 10:43 am

Post Posted February 14th, 2018, 2:19 pm

Dick Guertin wrote:TheVisitoe, I don't know what you mean by "the OP used WFM". As I said in my original post, there are TWO web addresses to get to Wells Fargo Rewards, and NEITHER work on Firefox (56.02 and above). They BOTH work in other browsers. I tried to file a bug report on "Firefox Bugs", but was told to file it on this forum. It was 'moved' here by the Moderator of "Firefox Bugs".


OP = Original Poster
WFM = Works for Me

Bugs are filed here: https://bugzilla.mozilla.org/

I'm fighting flu and don't feel like doing it, maybe someone can file it for you.

therube

User avatar
 
Posts: 18923
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted February 15th, 2018, 9:35 am

Note the site names; wf.com, wellsfargorewards.com, wellsfargo.com.

You would expect wellsfargo.com to be "wells fargo".
The others might or might not be.

connect.secure.wellsfargo.com, you would think to be a good starting point, but is it?

IOW, might you be using an outdated link?

If you start from here, https://www.wellsfargo.com/, logging in, working your way from that starting point, are you able to end up at a rewards page that works?

If not, if you try the same but starting in a Private Window, does that work?
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

therube

User avatar
 
Posts: 18923
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted February 15th, 2018, 9:37 am

Hey, guess what?
https://gofarrewards.wf.com/ is working today.
(Must have been the ghost of Valentines Day past.)

their only advice is to stop using Firefox

Bah! Humbug!
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

Dick Guertin
 
Posts: 127
Joined: December 30th, 2004, 3:23 pm

Post Posted February 15th, 2018, 10:11 am

therube, OR WF fixed something that was causing their page to fail. I reported this to WF at the start of this adventure. It only took a week to get fixed. I've tried it, and it works for me too, even on 56.0.2 Firefox.






therube,
Dick.Guertin; Firefox 56.0.2;
Mac OSX 10.10.6; 2.5 Ghz Intel Core I5

Return to Firefox Support


Who is online

Users browsing this forum: aborix and 14 guests