"connection not secure" error persists

User Help for Mozilla Firefox
Posts: 2
Joined: February 11th, 2018, 8:56 am

Post Posted February 11th, 2018, 5:40 pm

Since the moment I upgraded to 58.0.1 about ten days ago I have been unable to use Firefox to reach any websiste at all. I getr that connection unsecure error regarding improper certificates on sites I was using just hours before that upgrade, and even on the mozilla site.

I have tried the advanceed/exception work-around but it only works on some sites, and then does not last more than 2 or 3 visits to the sitie.
I tried renaming the cert.db files in the profile, as recommended in a Mozilla support article.
I tried turning off virus protection temporarily.
I tried on both administrator user and standard user.
I tried rebootring the computer.
So I thought the next upgrade would fix things, but 58.0.2 gives me exactly the same problem.
I'm now thinking I should remove the program entirely and download a new one. Is that likely to fix things? And if I do that can I still preserve my bookmarks and history and encrypted passwords?
I'm running Windows 7 on a Gateway desktop with plenty of hard disk room. And I'm use Chrome to come here now and for all my browsing, but I would like to go back to Firefox if I can get it to work.
TIA for any suggestions or help


User avatar
Posts: 43425
Joined: December 7th, 2002, 4:34 am
Location: Australia

Post Posted February 11th, 2018, 11:20 pm

What AV are you using ?
What sort of man would put a known criminal in charge of a major branch of government? Apart from, say, the average voter.
"Terry Pratchett"


User avatar
Posts: 27236
Joined: June 18th, 2003, 3:07 pm
Location: Made in Canada

Post Posted February 12th, 2018, 1:24 am

SEC_ERROR_UNKNOWN_ISSUER has been a common secure connection error of late.

Posts: 2
Joined: February 11th, 2018, 8:56 am

Post Posted February 12th, 2018, 11:20 am

In answer to 2 posts, Thanks
I'm using Kaspersky. And I have already seen that article you sent the link for. That's where I got the idea to disable the cert.db files and to turn off AV.
What about removing the program, preserving my profile, and downloading fresh. Can anyone give me any suggestions about that?


User avatar
Posts: 209
Joined: September 25th, 2003, 3:40 pm

Post Posted February 12th, 2018, 2:05 pm

This is a known issue with Kaspersky and Firefox 58.x with a Master Password. See this thread for a workaround until a fix is released: ... skts-2018/. The working temporary solution is also listed in this Mozilla support thread which is referenced in the KIS forum:

Return to Firefox Support

Who is online

Users browsing this forum: Google Adsense [Bot] and 12 guests