MozillaZine

YouTube page is black. No videos, nothing.

User Help for Mozilla Firefox
brinkeguthrie
 
Posts: 5
Joined: September 8th, 2017, 8:05 pm

Post Posted September 8th, 2017, 8:08 pm

Shows a goofy little switch at the top. Would could be the cause? An extension?

Image
Last edited by James on September 8th, 2017, 11:58 pm, edited 1 time in total.
Reason: made as a large thumbnail link to full size as it was far too big for img tags at 1,907px by 939px

MarkRH

User avatar
 
Posts: 1176
Joined: September 12th, 2007, 2:30 am
Location: Oklahoma City, OK

Post Posted September 9th, 2017, 3:43 am

YouTube is fine here. Try safe-mode (Help -> Restart with Add-ons Disabled).

Reflective

User avatar
 
Posts: 2193
Joined: February 15th, 2007, 11:13 am

Post Posted September 9th, 2017, 7:56 am

Does this link do the same thing? https://www.youtube.com/new

eisneun
 
Posts: 654
Joined: January 17th, 2005, 12:10 am
Location: socal

Post Posted September 9th, 2017, 10:40 am

the blank page and black box are what you get when using flash at youtube. google has dropped flash support in youtube in favor of html5. to enable html5 in firefox, copy and paste this about:config setting in the address bar, click the "I'll be careful" warning. double click on the mediasource entry to change it from false to true.
Code: Select all
about:config?filter=media.mediasource.enabled

if you have trouble following my instructions, see another explanation here:
http://winaero.com/blog/how-to-enable-y ... a-firefox/
How can ace be one and eleven? Huh?
What kind of god would allow that?

Reflective

User avatar
 
Posts: 2193
Joined: February 15th, 2007, 11:13 am

Post Posted September 9th, 2017, 12:03 pm

eisneun wrote:the blank page and black box are what you get when using flash at youtube. google has dropped flash support in youtube in favor of html5. to enable html5 in firefox, copy and paste this about:config setting in the address bar, click the "I'll be careful" warning. double click on the mediasource entry to change it from false to true.
Code: Select all
about:config?filter=media.mediasource.enabled

if you have trouble following my instructions, see another explanation here:
http://winaero.com/blog/how-to-enable-y ... a-firefox/

"True" is the default setting so unless the OP has changed it previously to "False", that's unlikely to be the cause.

Also, I changed it to False in FF myself, but I can still play YT videos.

Reflective

User avatar
 
Posts: 2193
Joined: February 15th, 2007, 11:13 am

Post Posted September 9th, 2017, 12:06 pm

@ brinkeguthrie, try disabling Hardware Acceleration. See instructions with screenshot here: http://techdows.com/2017/08/firefox-55- ... ation.html

Sugoi
 
Posts: 17
Joined: June 21st, 2015, 7:28 pm

Post Posted September 10th, 2017, 2:52 am

@brinkeguthrie

I guess you use the "Magic Actions for Youtube" add-on. Disable or remove that and everything will work fine again. I recommend using "Enhancer for YouTube" instead. It's more up to date and has more nice features than "Magic Actions" IMHO.

Reflective

User avatar
 
Posts: 2193
Joined: February 15th, 2007, 11:13 am

Post Posted September 11th, 2017, 4:50 am

I came across a similar problem this morning which was on the http://www.securitytracker.com/ site. That's black as well, but easily overcome by launching NoSquint Plus which I already have installed.

When you click the extension button you'll see an option on the menu panel which opens to change the background colour to white, or to remove a background image.

Return to Firefox Support


Who is online

Users browsing this forum: charscot and 12 guests