MozillaZine

geo.enabled = false doesn't work

User Help for Mozilla Firefox
dkw
 
Posts: 34
Joined: July 18th, 2004, 3:09 pm

Post Posted August 8th, 2017, 6:19 pm

Setting geo.enabled = false in about:config for Firefox 54.0 does not work. I am still always prompted for the annoying share location nag when tripped by a web site. This setting worked fine on earlier versions.

What gives?
How is the Location Aware Browsing disabled in Firefox 54.0 and later?

MarkRH

User avatar
 
Posts: 1125
Joined: September 12th, 2007, 2:30 am
Location: Oklahoma City, OK

Post Posted August 8th, 2017, 10:21 pm

What's the website doing this? When I go to https://html5demos.com/geo/ it says it's not supported for me.

dkw
 
Posts: 34
Joined: July 18th, 2004, 3:09 pm

Post Posted August 9th, 2017, 2:55 pm

Re Mark RH: What's the website doing this? Many. Evidently every site that has the location script.
Re Mark RH link: Irrelevant but interesting. Thanks.

Problem solved, sort of. I went back to Firefox 49.0.2 where geo.enabled = false actually does what it is supposed to do. Still, if anyone has an answer as to how to disable Location Aware Browsing in Firefox 54.0 and later, I would like to have that information.

Note: Please don't anyone bother to advise me that not using the latest version of Firefox is a security risk. You are wasting your time.

MarkRH

User avatar
 
Posts: 1125
Joined: September 12th, 2007, 2:30 am
Location: Oklahoma City, OK

Post Posted August 9th, 2017, 5:02 pm

I just used that link cause I knew it was one that looks for the Geo Location. I've never come across a site that asks about it since I disabled it many versions ago so I didn't know what sites asked about it. So, it's working fine for me with geo.enabled set to false. Unless some extension is over-riding it, I don't know more than doing that to disable it. All I have to do is toggle that setting to make it work or not.

dkw
 
Posts: 34
Joined: July 18th, 2004, 3:09 pm

Post Posted August 9th, 2017, 6:31 pm

Re Mark RH: So, it's working fine for me with geo.enabled set to false.

In Firefox 54.0 or later? If that is so, I must have some other problem. Before reverting to Firefox 49.0.2 I reinstalled Firefox 54.0 to see if it had been corrupted. I then created a new profile to check and see the old profile had been corrupted. In both cases I still had the same result. Setting geo.enabled = false dose not stop the share location (yes/no) drop down nag.

If you are using Firefox 54.0 or later and setting geo.enabled = false stops the share location drop down nag then I must have some other problem I haven't been able to identify.

********
Additional info see https://www.mozilla.org/en-US/firefox/geolocation/ and scroll down to -- How do I turn off Location-Aware Browsing permanently?

It just occurred to me that I may misunderstand what setting geo.enabled = false means. I thought it meant that location is never shared. It may mean that your location is always shared and so the drop down nag does not appear.

I would greatly appreciate it if anyone could clarify this for me.
********

8-bit

User avatar
 
Posts: 809
Joined: October 19th, 2007, 5:19 pm

Post Posted August 9th, 2017, 7:57 pm

dkw wrote:If you are using Firefox 54.0 or later and setting geo.enabled = false stops the share location drop down nag then I must have some other problem I haven't been able to identify.


I have geo.enabled set to false and I never get the nag. Can you give me a site to try?

No, geo.enabled set to false does NOT share your location...

dkw
 
Posts: 34
Joined: July 18th, 2004, 3:09 pm

Post Posted August 10th, 2017, 5:16 am

Re 8-bit: "I have geo.enabled set to false and I never get the nag. Can you give me a site to try?"

No. There were many and I do not remember them. (The sites from various and sundry Google searches.) I have since reverted to Firefox 49.0.2 and the problem has gone away.


***EVERYONE READING THIS THREAD PLEASE NOTE***

Thanks for your help but I am going to stick with Firefox 49.0.2 for now where all my favorite extensions work properly and I have no problems with geo.enabled = false
Several folks now have told me here and elsewhere they have no problems with geo.enabled set to false in Firefox 54.0 and 55.0.
My problem may have been some sort of fluke or some corrupted file when I upgraded to Firefox 54.0.
I will upgrade to 54.0 again at a later date (and then 55.0 or later down the road) and see if the problem returns.

Again, thanks for your help, but I am dropping this issue for now. If I have problems with setting geo.enabled = false in 54.0 and later versions in the future, I'll revisit it.

mightyglydd

User avatar
 
Posts: 8877
Joined: November 4th, 2006, 7:07 pm
Location: Hollywood Ca.

Post Posted August 10th, 2017, 5:40 am

dkw wrote:***EVERYONE READING THIS THREAD PLEASE NOTE***

http://www.mozilla.org/en-US/firefox/or ... s/all.html
#KeepFightingMichael

gloryhog
 
Posts: 1
Joined: September 12th, 2017, 10:17 am

Post Posted September 12th, 2017, 10:29 am

About 2 weeks ago a new version of Firefox was automatically downloaded to my Mac (I don't know which version, maybe it was 54.0). It was bad from the start. Slow. The exceedingly annoying multi-colored spinning wheel appeared every time I opened Firefox, a wheel which almost never appeared before on my Mac.

Then, 2 days ago I went to weather.com while on my VPN, connected to a server in California. The first page on weather.com gave my location as California, but seconds later my real location appeared!

Dumbfounded, I went to "geo-enabled" to make sure it was set to "false." It was. I also have WebRCT disabled. But my IP was still leaking out!

That tore it.

I reinstalled Firefox 53.0, unchecked automatic downloads, and the problem is fixed. No more IP leak.

For what's it's worth.

Return to Firefox Support


Who is online

Users browsing this forum: No registered users and 19 guests