MozillaZine

No apparent way to retain selective cookies

User Help for Mozilla Firefox
beeskeptical
 
Posts: 15
Joined: April 3rd, 2017, 12:20 pm

Post Posted April 5th, 2017, 2:56 pm

No matter how I configure Firefox's privacy settings, it will not keep individual cookies as exceptions.

First, the settings are completely confusing and internally contradictory. For instance, accept cookies/keep until they expire contradicts clear history (including cookies).

Second, no matter how many times I add an exception and fiddle with different settings, Firefox deletes the exception upon starting a new browsing session.

DanRaisch
Moderator

User avatar
 
Posts: 115798
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted April 5th, 2017, 3:00 pm

Moving from Thunderbird Bugs to Firefox Support.
See if this article is relevant to your issue -- http://kb.mozillazine.org/Preferences_not_saved

Mo_D

User avatar
 
Posts: 731
Joined: January 4th, 2006, 6:34 pm

Post Posted April 6th, 2017, 7:00 am

http://i.imgur.com/ITV7SX1.png

http://i.imgur.com/NO0qKRt.png

http://i.imgur.com/ixSI51a.png

You have to copy/paste or manually type in the addresses of the sites that you want to protect cookies from.

The interface/wording is confusing. Trust me, this works. I didn't believe it when I was first told how to do it.
Last edited by Daifne on April 7th, 2017, 8:34 am, edited 1 time in total.
Reason: removed img tags. Size of images breaking forum format.

RobertJ
Moderator

User avatar
 
Posts: 9929
Joined: October 15th, 2003, 7:40 pm
Location: Chicago IL/Oconomowoc WI

Post Posted April 6th, 2017, 7:09 am

SeaMonkey 2.46 - FF 53.0.2 - TB 52.0.1 - Mac OSX 10.12.4 Quad-Core Intel Xeon 5500
Computers I've used: IBM 7094/UNIVAC 1108/IBM 360/DEC PDP11/DEC VAX-11 780/DEC VAXstation 8000/Sun SPARCstation 2/Mac from 1984 to 2017

kreemoweet
 
Posts: 686
Joined: December 30th, 2009, 11:25 pm

Post Posted April 6th, 2017, 8:26 am

One can also specify a website that's allowed to set cookies contra your general rule by navigating to the site, selecting View Page Info > Permissions from
the context menu, and adjusting cookie permissions that appear in the list. You can also access the permission list from the site info icon in the address bar.

I dunno why people have problems with this FF cookie management stuff, it all makes perfect sense to me, and I've never had anything disappear from the
cookie permission exception list.

beeskeptical
 
Posts: 15
Joined: April 3rd, 2017, 12:20 pm

Post Posted April 7th, 2017, 4:40 pm

Unfortunately, none of the foregoing responses shed any light or solve the issue.

My Firefox privacy settings | history are set to:
- use custom settings
- not remember any history
- not accept cookies
- clear history when Firefox closes (all except cookies)

The logical inference -- the only logical inference -- is that if I then manually create an exception and allow a specific website to accept cookies, then close and restart, that exception will remain.

It doesn't. Firefox erases the allowed exception and apparently does not retain the cookie.

Therefore, I conclude that this system is buggy. Unless someone has a solution. Thanks.

DanRaisch
Moderator

User avatar
 
Posts: 115798
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted April 7th, 2017, 4:47 pm

Did you check out the link above regarding preferences that are not being saved?

beeskeptical
 
Posts: 15
Joined: April 3rd, 2017, 12:20 pm

Post Posted April 7th, 2017, 5:09 pm

I did read http://kb.mozillazine.org/Preferences_not_saved, but I'm stymied because it doesn't say where to find prefs.js on a mac, and when I do a spotlight search for it, it doesn't come up.

beeskeptical
 
Posts: 15
Joined: April 3rd, 2017, 12:20 pm

Post Posted April 7th, 2017, 5:12 pm

Regardless, that doesn't seem to be the issue. Firefox does save my preferences when I change them, close, and restart. Except for the cookies exceptions. It always deletes those. So it still looks like a bug to me.

Mo_D

User avatar
 
Posts: 731
Joined: January 4th, 2006, 6:34 pm

Post Posted April 7th, 2017, 5:20 pm

Enter
Code: Select all
about:profiles
in the URL bar, then click on
Code: Select all
Show in Finder
prefs.js is in that folder.

But I don't think that is your issue.

beeskeptical wrote:Unfortunately, none of the foregoing responses shed any light or solve the issue.
My Firefox privacy settings | history are set to:
- not accept cookies


You've got to allow Firefox to accept cookies if you want it to save individual cookies. I understand your logic for forcing it to allow once manually and then setting it to not allow, but I've never tested that personally, so I couldn't say if that will work.

Setting your preferences as I have shown in the pics above will work, but it's going to allow all sites to set cookies during your session, deleting "non-allowed" cookies on close.

beeskeptical
 
Posts: 15
Joined: April 3rd, 2017, 12:20 pm

Post Posted April 7th, 2017, 5:26 pm

Mo_D, thank you. But unfortunately, right after I described my settings, I also set it to allow cookies. It makes no difference. It deletes the exception I set as soon as I close.

Also, seems to me that it should work with the settings I described above. That's what the language used on the settings page leads one to expect, anyway: No cookies allowed except for these exceptions. Simple. Logical. Intuitive. Actions conforming to their linguistic descriptions.

Regardless, it won't save cookie exceptions even if I allow cookies.

Mo_D

User avatar
 
Posts: 731
Joined: January 4th, 2006, 6:34 pm

Post Posted April 7th, 2017, 5:51 pm

beeskeptical wrote:Mo_D, thank you. But unfortunately, right after I described my settings, I also set it to allow cookies. It makes no difference. It deletes the exception I set as soon as I close.

Also, seems to me that it should work with the settings I described above. That's what the language used on the settings page leads one to expect, anyway: No cookies allowed except for these exceptions. Simple. Logical. Intuitive. Actions conforming to their linguistic descriptions.

Regardless, it won't save cookie exceptions even if I allow cookies.


I see the problem now - your "Settings" for clearing history. You've also got to keep/uncheck "Active logins" and "Site Preferences". Those are somehow tied to cookies.

I just played around with a new test profile, and I suspect your theory might be right. Unfortunately I don't have time to play around with it and figure out exactly how to do it. It has something to do with making sure you have those cookies saved before you ever change a certain preference, but I'm not certain which preference it is. And then you manually delete any other cookies. Thereafter, only the "allowed" cookie will be saved.

I'm out for the evening, but I'll check back tomorrow...

kreemoweet
 
Posts: 686
Joined: December 30th, 2009, 11:25 pm

Post Posted April 8th, 2017, 12:54 am

Any entry in the cookie Exceptions list is a Site Preference. And not just with regard to cookies: all the exceptions for saving passwords, allowing offline storage, opening popup windows, etc, etc,
are all Site Preferences and will be deleted unless that item is not included in the Clear History When FF Closes options.

So the OP is getting exactly what he/she has asked for. Simple. Logical. Intuitive.

Mo_D

User avatar
 
Posts: 731
Joined: January 4th, 2006, 6:34 pm

Post Posted April 8th, 2017, 4:38 am

I experimented a little further, and it appears you are correct. You can have protected cookies and choose to not accept cookies. Here’s how I did it:

Using the preference settings exactly as shown in the pictures above, save the cookies you want, and set the exceptions. Then change the setting “Keep until I close Firefox” to “Keep until they expire”. Close Firefox. This will "force" the saving of the cookies.

Open Firefox. At this point, any cookies you had, whether protected or not, should still be shown. Change the setting “Keep until they expire” back to “Keep until I close Firefox”. Manually delete any cookies you do not want to keep. Uncheck “Accept cookies from sites”.

From that point on, I think it will function as you desire. It did for me in the test. What I can not attest to is whether you will experience any issues with outdated cookies due to having it set to not accept cookies.

beeskeptical
 
Posts: 15
Joined: April 3rd, 2017, 12:20 pm

Post Posted April 8th, 2017, 7:49 pm

Mo_D and kreemoweet, thank you. Good sleuthing.

I hope someone from Mozilla is paying attention. This really underscores just how defective their system is.

Return to Firefox Support


Who is online

Users browsing this forum: Google [Bot] and 6 guests