MozillaZine

Firefox 52. Problem with avito.ru

User Help for Mozilla Firefox
t10raz
 
Posts: 3
Joined: March 19th, 2017, 2:54 pm

Post Posted March 19th, 2017, 3:04 pm

Hello and sorry for my bad English.
On Firefox 52 some people in Russia have problem with site https://www.avito.ru/ This site is very popular in Russia. And since Firefox 52 was realeased, he works very slow in Firefox, but perfectly fine in other browsers. It's not only my problem.
You can check it on this video:
https://www.youtube.com/watch?v=YuC_39m ... freload=10
It's not problem with my system. Many people have this problem. One man even reinstall his OS, and this doesn't work.
Could you help with this problem?

dfoulkes

User avatar
 
Posts: 22034
Joined: June 28th, 2008, 10:31 pm
Location: Mesquite, Nevada

Post Posted March 20th, 2017, 9:51 am

I checked that site out in this loaded profile (lots of extensions) , my Test profile (1 extension) and in IE .... As far as I can tell the load-time in all tests came out pretty much the same... though my Test profile was the quickest because I use an ad-blocker...also, I disabled my ad-blocker in my Test profile and it did take longer and was loading and waiting on lots of 3rd party data injections.

you can see if this helps...

From a prior post from Dan Raisch (with minor changes) ...

(If using a version below Firefox 3.5.) Clear the browser cache (Tools->Clear Recent History->select cache->click on "Clear Now" button).

Else... use menu path Tools->Options->Advanced->Network tab->click on "Clear Now" button.)

Delete any cookies relating to the site(s) involved (Tools->Options->Privacy->Show Cookies button).


Note: The above is for Windows so if you're using a different OS refer to this...
http://kb.mozillazine.org/Menu_differen ... x,_and_Mac

Also... my ad blocker is...
uBlock Origin :: Add-ons for Firefox

Plus... your English is fine =D>
As you can see she's (The CAT) always alert and on the prowl for Meoware !!

therube

User avatar
 
Posts: 17194
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted March 20th, 2017, 9:55 am

Not an answer, but if you disable JavaScript you'll see a world of difference.

about:config, javascript.enabled, set it to 'false'.
(Then set it back to 'true' after testing.)
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

therube

User avatar
 
Posts: 17194
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted March 20th, 2017, 10:00 am

Seems to run much better in an ancient version (38.0) of Chrome, so why it runs so poorly in FF is a good question.
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

GHM113

User avatar
 
Posts: 439
Joined: December 16th, 2015, 3:59 am
Location: Moscow, Russia

Post Posted March 20th, 2017, 10:41 am

Judging by your video, you have AdBlock Plus installed. What other addons are you using? Did you tweak any about:config settings? Avito works fine in Nightly with uBlock and NoScript, I don't see any slowdowns.
I am an idiot. Sorry for my poor English.

therube

User avatar
 
Posts: 17194
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted March 20th, 2017, 11:32 am

Avito works fine ... with uBlock and NoScript

As it does with JavaScript disabled.

(I can't run Nightly, but) restart in Safe Mode & see if you don't see very poor performance.

Now very possible that it is simply all the tracking/ad nonsense that might go on there, but if it were that alone, why does (ancient) Chrome (with no extensions) run acceptably?
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

Lnwdz
 
Posts: 146
Joined: June 12th, 2012, 7:59 am

Post Posted March 20th, 2017, 5:23 pm

After clicking on a city, such as https://www.avito.ru/sankt-peterburg
I see the extreme slowness with Firefox 52 ESR on Win XP.

The problem goes away with
network.http.spdy.enabled.http2 set to false (in about:config).

Maybe avito.ru should disable http2 for Firefox for now.

t10raz
 
Posts: 3
Joined: March 19th, 2017, 2:54 pm

Post Posted March 21st, 2017, 1:52 am

GHM113 wrote:Judging by your video, you have AdBlock Plus installed. What other addons are you using? Did you tweak any about:config settings? Avito works fine in Nightly with uBlock and NoScript, I don't see any slowdowns.

It's not my video. I don't have Adblock. I use temporary solution and downgrade Firefox to version 51 and Avito works very good.
This is very strange. Mozilla added in Firefox 52 something Incompatible with this site (which is popular in Russia).
Last edited by t10raz on March 21st, 2017, 2:05 am, edited 1 time in total.

t10raz
 
Posts: 3
Joined: March 19th, 2017, 2:54 pm

Post Posted March 21st, 2017, 1:55 am

Lnwdz wrote:After clicking on a city, such as https://www.avito.ru/sankt-peterburg
I see the extreme slowness with Firefox 52 ESR on Win XP.

The problem goes away with
network.http.spdy.enabled.http2 set to false (in about:config).

Maybe avito.ru should disable http2 for Firefox for now.

Thank you, this is works! Is this option fully secure?

Lnwdz
 
Posts: 146
Joined: June 12th, 2012, 7:59 am

Post Posted March 21st, 2017, 2:30 am

Yes, security is the same. The reason for http2 is to make pages load faster!

Update 2017-03-24: Avito.ru has disabled HTTP/2 for Firefox 52. Speed looks normal.

Return to Firefox Support


Who is online

Users browsing this forum: No registered users and 7 guests