MozillaZine

Problems getting/compiling Spider Monkey JavaScript-C engine

Composer, ChatZilla and other Mozilla applications, along with Netscape, Galeon, K-Meleon and other products.
strictlymike
 
Posts: 2
Joined: March 17th, 2011, 1:55 pm

Post Posted March 17th, 2011, 2:20 pm

Hello,

I downloaded Spider Monkey and found that autoconf-2.13 can't find a configure.in file. I read about Spider Monkey in Brian Hook's book, "Write Portable Code" and was excited to visit http://www.mozilla.org/js/spidermonkey/ and try it out. I didn't see any support channel for Spider Monkey, and I didn't find my issue in a quick search for the terms "configure.in" or "Spider Monkey" (omitted quotes in both cases). I hope someone here can help me out.

Here is what I tried, according to the build directions at https://developer.mozilla.org/en/Spider ... umentation:

Code: Select all
$ wget http://ftp.mozilla.org/pub/mozilla.org/js/js-1.7.0.tar.gz
...
$ tar -xf js-1.7.0.tar.gz
$ cd js/src
$ sudo yum install nspr nspr-devel autoconf213
...
$ autoconf-2.13
autoconf: configure.in: No such file or directory
$ file $(which autoconf-2.13) # In case CentOS simply symlinks to another version?
/usr/bin/autoconf-2.13: Bourne shell script text executable
$ find .. -type f -name configure.in
$


I couldn't find any configure.in file for autoconf to use. I tried this with 1.8.0-rc1 and had the same issue. Can someone tell me if I am doing something wrong, or am missing something from the Linux prerequisites that might help autoconf-2.13 somehow synthesize a configure.in on the fly? https://developer.mozilla.org/En/Develo ... requisites

Lastly, I noticed that most mirrors (at least anl.gov, ac.jp, voxcdn.com, etc) seem to be out of date, and don't have the js/ subdirectory. Not a big issue since I just downloaded it from the main site, but it might be a little confusing to other newcomers.

Any suggestions for fixing the autoconf-2.13 / configure.in issue would be welcome. I look forward to hopefully trying out Spider Monkey this week.

Thanks in advance,
M.

strictlymike
 
Posts: 2
Joined: March 17th, 2011, 1:55 pm

Post Posted March 18th, 2011, 2:06 pm

Resolved. Three pages down are directions for building 1.8.0 or earlier. If I had only realized that there were multiple directions for multiple versions on the same page, and that the 1.8.1 features referred to in the caption are in fact the build system itself, maybe I would have known to look for this.

Cheers.
-M.

zoro73
 
Posts: 1
Joined: April 26th, 2011, 5:34 pm

Post Posted April 26th, 2011, 5:43 pm

So how's it coming now? Have you built it? Learning some deep stuff about JavaScript yet?
I was trying to build myself and was stumbling upon the same problem. One of these days I'm about to try for the second time.
You didn't point out though how exactly you solved the problem. Is building the 1.8.0 version easy and intuitive to build and try?

Any info is appreciated thanks!
zoro73

Return to Other Applications and Distributions


Who is online

Users browsing this forum: No registered users and 2 guests