MozillaZine


The exceptions in "Remote content" settings aren't permanent

Discussion of bugs in Mozilla Thunderbird
durumdara
 
Posts: 33
Joined: March 29th, 2006, 7:08 am

Post Posted July 8th, 2021, 12:44 am

Hello!

Maybe this is only my problem.
78.11.0 (64 bit).

When I got mails, the remote content (like images) are blocked. It's ok.
I want to set an exception permanently.
I go to the Settings, Remote Content, Exceptions.
I allow one site.
Ok, it works.

Then I restart the TDB, and the mails from this site are also blocked.
When I check the settings - the exceptions are empty.

So maybe TDB don't save these settings well.

Do you also have this problem?

Thanks!

Best regards
dd

morat
 
Posts: 4836
Joined: February 3rd, 2009, 6:29 pm

Post Posted July 11th, 2021, 10:56 am

I can't reproduce the issue.

Menu Bar > Tools > Options > Privacy & Security > Mail Content > Exceptions

My exceptions are still saved after restarting.

e.g.

Site -> https://cowabunga.com
Status -> Allow

Did you forget to click the "Save Changes" button in the dialog?

The data is stored in the permissions.sqlite file in the profile directory. Maybe the database is corrupted.

durumdara
 
Posts: 33
Joined: March 29th, 2006, 7:08 am

Post Posted July 26th, 2021, 3:45 am

morat wrote:I can't reproduce the issue. The data is stored in the permissions.sqlite file in the profile directory. Maybe the database is corrupted.


Hello!

The file was corrupt. I deleted it, and after that the settings are permanent for me too.

Thank you!!!

Best wishes

dd

Return to Thunderbird Bugs


Who is online

Users browsing this forum: No registered users and 1 guest