MozillaZine

Random crashes in Windows 5-30 build

Discussion of bugs in Mozilla Thunderbird
GordMcFee
 
Posts: 13001
Joined: May 3rd, 2003, 4:18 pm
Location: Ottawa, Canada

Post Posted June 1st, 2003, 11:59 am

I am getting a few random crashes; no pattern that I can see that causes them. I get the "Thunderbird.exe has generated errors and will be closed", and then Dr. Watson goes into gear. Thus, no really useful error message and no real way to describe what is causing the problem.

Anyone else seen this?
Gord McFee

RAF
Moderator

User avatar
 
Posts: 12606
Joined: November 5th, 2002, 2:19 pm
Location: .nl

Post Posted June 1st, 2003, 3:24 pm

Yes. I see the same. Also, the write window (for a new mail) is not rendered properly. The drop down 'box' where you can choose To or cc or bcc isn't rendered properly and there is no line between it and the actual address field.

mscott

User avatar
 
Posts: 2516
Joined: April 2nd, 2003, 4:10 pm
Location: Thunderbird Research Center, CA

Post Posted June 1st, 2003, 4:56 pm

RAF wrote:Yes. I see the same. Also, the write window (for a new mail) is not rendered properly. The drop down 'box' where you can choose To or cc or bcc isn't rendered properly and there is no line between it and the actual address field.


are you using a non standard theme? Please see my comments in the release notes posting for this build. Non default themes are broken until they update a couple files. YOu would see issues like what your are seeing if you were running a theme that is no longer compatible.
Thunderbirds are Go!

GordMcFee
 
Posts: 13001
Joined: May 3rd, 2003, 4:18 pm
Location: Ottawa, Canada

Post Posted June 1st, 2003, 6:06 pm

RAF wrote:Yes. I see the same. Also, the write window (for a new mail) is not rendered properly. The drop down 'box' where you can choose To or cc or bcc isn't rendered properly and there is no line between it and the actual address field.


Haven't seen that one here, the box renders fine. On the crashes, they have stopped. Actually, I have reinstalled the build several times to test, and the crash, when it happens, is only on the first "send". Weird. All in all, a very good build. I am able to use Thunderbird as my default for email and newsgroup activity and it works well.
Gord McFee

F J Walter
 
Posts: 235
Joined: May 26th, 2003, 2:50 am

Post Posted June 2nd, 2003, 4:16 am

I am getting problems with the 20030530 win32 build.

When deleting or moving an email message or mail folder, sometimes Thunderbird crashes and exits. When going back into Thunderbird to try again, it continues to occur on the same email or folder. Some emails, it appears, just can't be moved.

RAF
Moderator

User avatar
 
Posts: 12606
Joined: November 5th, 2002, 2:19 pm
Location: .nl

Post Posted June 2nd, 2003, 5:28 am

mscott wrote:are you using a non standard theme? Please see my comments in the release notes posting for this build. Non default themes are broken until they update a couple files. YOu would see issues like what your are seeing if you were running a theme that is no longer compatible.

You're right. I 'installed' Pinball (via renaming qute.jar). It worked perfectly in the May 27 build. Now I still see the Qute icons except in the View-Toolbars-Customise window. There Tb shows the pinball icons.

I also have the same crash-behaviour as Gord McFee. Tb only crashed on the first send (I confirmed this when reinstalling Tb).

LuZu
 
Posts: 4
Joined: May 30th, 2003, 10:47 pm

Post Posted June 2nd, 2003, 10:04 am

F J Walter wrote:I am getting problems with the 20030530 win32 build.

When deleting or moving an email message or mail folder, sometimes Thunderbird crashes and exits. When going back into Thunderbird to try again, it continues to occur on the same email or folder. Some emails, it appears, just can't be moved.


I did encounter the exactly same problem with the win32 2003-05-21-trunk.
Tb crashes and exits when I tried to delete a bunch of emails at once or after I delete several single emails!
Win98, 192MB

LuZu
 
Posts: 4
Joined: May 30th, 2003, 10:47 pm

Post Posted June 2nd, 2003, 10:08 am

LuZu wrote:
F J Walter wrote:I am getting problems with the 20030530 win32 build.

When deleting or moving an email message or mail folder, sometimes Thunderbird crashes and exits. When going back into Thunderbird to try again, it continues to occur on the same email or folder. Some emails, it appears, just can't be moved.


I did encounter the exactly same problem with the win32 2003-05-21-trunk.
Tb crashes and exits when I tried to delete a bunch of emails at once or after I delete several single emails!


Sorry, I meant win32 2003-05-30-trunk and not win32 2003-05-21-trunk! win32 2003-05-21-trunk runs fine!
Win98, 192MB

Homer
 
Posts: 95
Joined: May 9th, 2003, 8:57 pm

Post Posted June 2nd, 2003, 11:00 am

Luzu and F J Walter's problems confirmed here too. Regressed to 05-27 so I could, ahem, destroy some incriminating evidence before my wife found it. :D

GordMcFee
 
Posts: 13001
Joined: May 3rd, 2003, 4:18 pm
Location: Ottawa, Canada

Post Posted June 2nd, 2003, 11:12 am

RAF wrote:
mscott wrote:are you using a non standard theme? Please see my comments in the release notes posting for this build. Non default themes are broken until they update a couple files. YOu would see issues like what your are seeing if you were running a theme that is no longer compatible.

You're right. I 'installed' Pinball (via renaming qute.jar). It worked perfectly in the May 27 build. Now I still see the Qute icons except in the View-Toolbars-Customise window. There Tb shows the pinball icons.

I also have the same crash-behaviour as Gord McFee. Tb only crashed on the first send (I confirmed this when reinstalling Tb).


And now I am getting more crashes, usually when moving or deleting mail. Two copies of the same email will show up in different folders and if I try to delete either, it crashes. I have backed out to the 5-27 build.
Gord McFee

RAF
Moderator

User avatar
 
Posts: 12606
Joined: November 5th, 2002, 2:19 pm
Location: .nl

Post Posted June 2nd, 2003, 2:35 pm

GordMcFee wrote:And now I am getting more crashes, usually when moving or deleting mail. Two copies of the same email will show up in different folders and if I try to delete either, it crashes. I have backed out to the 5-27 build.


Exactly the same problem in my case. Double e-mails, Dr. Watson on deleting an e-mail..

EDIT: Gord, could it be that deleting mail only crashes Tb if the mail was received today?

mscott

User avatar
 
Posts: 2516
Joined: April 2nd, 2003, 4:10 pm
Location: Thunderbird Research Center, CA

Post Posted June 2nd, 2003, 4:32 pm

Looks like something went into the trunk on the 30th that is causing this. The crashes are in Mozilla Mail too. Folks are looking into it now.
Thunderbirds are Go!

mscott

User avatar
 
Posts: 2516
Joined: April 2nd, 2003, 4:10 pm
Location: Thunderbird Research Center, CA

Post Posted June 2nd, 2003, 4:40 pm

Looks like this was:

http://bugzilla.mozilla.org/show_bug.cgi?id=207798

which was fixed on June 1st.

So the next windows build should have this fix in it.
Thunderbirds are Go!

F J Walter
 
Posts: 235
Joined: May 26th, 2003, 2:50 am

Post Posted June 2nd, 2003, 5:27 pm

GordMcFee wrote:And now I am getting more crashes, usually when moving or deleting mail. Two copies of the same email will show up in different folders and if I try to delete either, it crashes. I have backed out to the 5-27 build.

I have also gone back to the 5-27 build, and the problem with deleting or moving email has now gone.

F J Walter
 
Posts: 235
Joined: May 26th, 2003, 2:50 am

Post Posted June 2nd, 2003, 5:30 pm

mscott wrote:Looks like this was:

http://bugzilla.mozilla.org/show_bug.cgi?id=207798

which was fixed on June 1st.

So the next windows build should have this fix in it.


That bug seems to be for Linux, not Windows.

Return to Thunderbird Bugs


Who is online

Users browsing this forum: No registered users and 2 guests