MozillaZine


Filters don't run until folder is manually opened

Discussion of bugs in Mozilla Thunderbird
Synthezoid
 
Posts: 9
Joined: July 24th, 2013, 6:18 pm

Post Posted July 19th, 2021, 4:43 pm

I have a couple of filters on the Sent folder and a few other folders. They never run until I open those folders manually, then they suddenly run all at once.

On the Sent folder, in particular, the filters are checked off to run after sending. Instead, they run when the Sent folder is opened.

How do I get filters to run when mail comes in, instead of waiting for me to manually open each folder to trigger the filter? This seems like an unnecessary extra step and thing to remember. I've never before seen an email app that insisted on me remembering to manually trigger filters to run.

DanRaisch
Moderator

User avatar
 
Posts: 125494
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted July 19th, 2021, 7:11 pm

How is the account set up in Thunderbird? As POP or IMAP?

Synthezoid
 
Posts: 9
Joined: July 24th, 2013, 6:18 pm

Post Posted July 20th, 2021, 12:11 am

DanRaisch wrote:How is the account set up in Thunderbird? As POP or IMAP?


It's IMAP, off Goggle Apps accounts.

I know the filters are completely set up correctly, preferences set to sort on all subfolders, etc., because I've discovered that after I open the folder and the filter manually triggers, for a while after that, it works automatically, as expected. The folders I had to manually open earlier today to get them to filter are all filtering automatically right now. But then, at some point later it stops working, and only after days go by and I realize, "HMMMM, you know, I haven't been seeing any sent emails in this folder for a while, I'd better check the sent mail folder and see if they're in there." And I open the Sent folder, and suddenly the past few days' sent emails all filter out into the folders I want them in, and then for the next few hours or days, they filter automatically again without me having to open the folder, for a while. And the process repeats.

Synthezoid
 
Posts: 9
Joined: July 24th, 2013, 6:18 pm

Post Posted August 5th, 2021, 1:39 pm

Synthezoid wrote:
DanRaisch wrote:How is the account set up in Thunderbird? As POP or IMAP?


It's IMAP, off Goggle Apps accounts.


This issue is becoming more of a headache for me. My accounts are set up as IMAP, is there a solution to this that anyone is aware of? Thanks.

Is there some better place to seek Thunderbird support? I really would like for this to work right.

brian.r.hamilton
 
Posts: 3
Joined: August 23rd, 2017, 2:51 pm

Post Posted October 22nd, 2021, 9:11 am

I'm having all sorts of trouble with the version 94 betas (64-bit) with IMAP folders and filters. Thunderbird has become unusable at this point so I'm trying to figure out how to get off the beta channel. Did you ever solve the issue you were having with filters?

Synthezoid
 
Posts: 9
Joined: July 24th, 2013, 6:18 pm

Post Posted December 5th, 2021, 8:06 pm

brian.r.hamilton wrote:I'm having all sorts of trouble with the version 94 betas (64-bit) with IMAP folders and filters. Thunderbird has become unusable at this point so I'm trying to figure out how to get off the beta channel. Did you ever solve the issue you were having with filters?


Hi there. No, the issue is as bad as ever and it's really tripping me up, in fact I'm back here looking for answers yet again, months later. I'm not clear why someone asked me above to tell them what kind of account I'm using if they didn't plan on offering further help based on the answer. Not that it should matter, a filter is a filter and it should work the same on a POP account and an IMAP account, shouldn't it?

It's really frustrating that nobody seems to know how to get Thunderbird working properly and there's no documentation other than the code itself. I'm a developer, actively working on my own js filters and things, and most of the time when I have a problem or a question there just isn't any answer, anywhere. I've even gotten on the dev team's discord chat and it seemed like they don't really understand the things I need to know about how it works. I don't understand how the dev team even works on programming this if there's no documentation.

Return to Thunderbird Bugs


Who is online

Users browsing this forum: No registered users and 2 guests