MozillaZine

Font sizes / Where to set / Relations

Discussion of features in Mozilla Thunderbird
sludge7071-g
 
Posts: 84
Joined: May 9th, 2016, 10:18 am

Post Posted June 17th, 2020, 6:18 am

I finally figured out where the settings are, what they do, and their relations.
There should be a page that provides this as a tutorial.
It's a commonly asked question / I think TFSC no longer works / It has a lot to do with use-ability of the program:

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Tools / Options / Advanced / General / Config Editor / font.size

Sort by Status
Right-click, and Reset each value to Default
Sort by Value. The smallest font size is 13?

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Tools / Options / Advanced / Config Editor / layout.css.devPixelsPerPx
. . . Use this setting, to make TB bigger, instead of the Add-on, TFSC
. . . The change is real-time
. . . These settings determine what you see, when you RECEIVE an email

- - - - - - - - - - - - - - - - - - - - - -

06/17/20

. . . default = -1.0
. . . Set it to 1.3 I've had it here for a while, a little small on a 27" monitor
. . . Set it to 1.4 a little big - but use this, shrink using Zoom, if desired
. . . Set it to 1.5 a little big
. . . Set it to 2 too big

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Tools / Options / Display / Formatting / Fonts & Colors
Default font . . . leave this "as is", you set it in:

Tools / Options / Display / Formatting / Fonts & Colors / Advanced /
. . . These settings determine what you see, when you COMPOSE an email

Fonts for Latin
Proportional Sans Serif . . . Size: 26, on a 27" monitor
Serif Default (Times New Roman)
Sans-serif Default (Arial) . . . previous: Consolas, Calibri, Microsoft Sans Serif
Monospace Consolas . . . 26, on a 27" monitor

Minimum font size . . . None
[un-check] Allow messages to use other fonts

Sizes are in pixels, not points; 12pt is about 18 pixels

- - - - - - - - - - - - - - - - - - - - - -

Tools / Options / Composition / General
Font: Variable width . . . Font Size: Medium

Reason: It is advisable that you do not send emails with hard coded font and font size.

This means you can use the settings in "Display" to choose your own prefered view of emails, both received and sent, and so can your recipients.

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

There's a big explanation about this, but the bottom line is:

Tools / Options / Composition
[check] Use Paragraph format instead of Body Text by default
. . . when I press Enter, the cursor behavior is not as expected, it goes down two lines
. . . the work-around for this is to use "Shift + Enter"

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

DanRaisch
Moderator

User avatar
 
Posts: 123893
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted June 17th, 2020, 8:37 am

If you just uncheck that option the double line space will disappear.

sludge7071-g
 
Posts: 84
Joined: May 9th, 2016, 10:18 am

Post Posted June 18th, 2020, 7:53 am

Yes, but then I found that it if you select Body Text, it auto-does something with the first row
. . . Type something on the first row, hit enter, and font size on the second row is slightly bigger
. . . It has to do with Paragraph Format vs Body Text
. . . The Body Text setting automatically puts in html code for you . . . which you can't see, and can't control
. . . So, the fix is to use Paragraph Format, and Shift+Enter

DanRaisch
Moderator

User avatar
 
Posts: 123893
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted June 18th, 2020, 1:15 pm

Any particular reason that you are seeking out those options in composition? By default, Thunderbird does not change font sizes as you add text and the setting for paragraph format is retained between sessions so once you switch it off you will have single spacing in all new messages composed.

sludge7071-g
 
Posts: 84
Joined: May 9th, 2016, 10:18 am

Post Posted June 19th, 2020, 7:07 am

Ok, I'll try it back on Body Text.
Maybe the other changes I made, will make it work as expected now.
Who knows.
This is the problem I'm running into.
Thx.

Return to Thunderbird Features


Who is online

Users browsing this forum: No registered users and 3 guests