MozillaZine

A great ad blocker...

Discussion of general topics about Seamonkey
Redbugdave
 
Posts: 82
Joined: January 31st, 2012, 8:29 am

Post Posted May 4th, 2020, 4:05 am

Listed in the release notes...Ublock Origin. Thanks guys for mentioning it in the release notes. This add-on works great. Ver 2.53.1

4td8s
 
Posts: 710
Joined: June 24th, 2009, 1:07 pm

Post Posted May 5th, 2020, 6:04 pm

you need the "legacy" version of Ublock Origin for SM 2.53.x, not the webExtension version:
https://github.com/gorhill/uBlock-for-firefox-legacy/releases

James
Moderator

User avatar
 
Posts: 27734
Joined: June 18th, 2003, 3:07 pm
Location: Made in Canada

Post Posted May 5th, 2020, 8:16 pm

Which is mentioned in the Release Notes as mentioned by OP.

http://www.seamonkey-project.org/releases/seamonkey2.53.2/
The latest 1.16.x working version of uBlock can be found here. Please install the latest legacy version

seedy
 
Posts: 62
Joined: February 18th, 2006, 6:12 pm
Location: USA

Post Posted June 4th, 2020, 2:24 pm

Dropped by to see what's new, grabbed that newer version of UBO than I had (1.13.x), Add-Ons Manager in 2.53.2 didn't update it or show an available update when prompted.

Is there a place that lists the dev directories for Extensions? I'd like to catch up in AOM isn't updated itself to find them.

Thank you for keeping SM going.

therube

User avatar
 
Posts: 20571
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted June 12th, 2020, 4:40 am

You'll basically have to check the extension author's website (or similar) - if such a thing exists.
AMO no longer hosts "legacy" extensions, so no update checks that had pointed there would ever update (any longer).
Extensions that are now "self hosted", where the extension author now checks their own site (rather then AMO) should (now) update (once you've installed a later version that knows where to look).
Fire 750, bring back 250.
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

Buzzrr

User avatar
 
Posts: 188
Joined: January 24th, 2004, 3:34 pm

Post Posted July 20th, 2020, 10:05 am

4td8s wrote:you need the "legacy" version of Ublock Origin for SM 2.53.x, not the webExtension version:
https://github.com/gorhill/uBlock-for-firefox-legacy/releases

I could never get uBlock to work with SeaMonkey. #-o
Does uBlock work better than ABP?
I've noticed how other browsers are susceptible to adware however SeaMonkey is not. Probably because it's off the radar. :?:

ElTxolo

User avatar
 
Posts: 2564
Joined: July 30th, 2007, 9:35 am
Location: Localhost

Post Posted July 22nd, 2020, 9:52 am

Buzzrr wrote:
4td8s wrote:you need the "legacy" version of Ublock Origin for SM 2.53.x, not the webExtension version:
https://github.com/gorhill/uBlock-for-firefox-legacy/releases

I could never get uBlock to work with SeaMonkey. #-o


    Image uBlock Origin (legacy versions) works perfectly with SeaMonkey 2.53.*



    Image



    Buzzrr wrote:.... Does uBlock work better than ABP?


    It's much better, you have a detailed explanation in this old thread :wink:











    Cheers!! Image
How to Ask Questions The Smart Way - How to Report Bugs Effectively ;)
Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20201115 SeaMonkey/2.53.5.1
Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20201201 SeaMonkey/2.53.6

Buzzrr

User avatar
 
Posts: 188
Joined: January 24th, 2004, 3:34 pm

Post Posted July 23rd, 2020, 8:32 pm

I'm still using version 2.49.5. I have many extensions which I'm afraid wouldn't be compatible with the newer 2.53.3.
Would you happen to know if uBlock Origin would then work with the older SeaMonkey browsers?

ElTxolo

User avatar
 
Posts: 2564
Joined: July 30th, 2007, 9:35 am
Location: Localhost

Post Posted July 24th, 2020, 7:22 am

Buzzrr wrote:I'm still using version 2.49.5. I have many extensions which I'm afraid wouldn't be compatible with the newer 2.53.3.
Would you happen to know if uBlock Origin would then work with the older SeaMonkey browsers?


Image uBlock Origin (legacy versions) works fine with SeaMonkey 2.49.* (at least when I was using that version)

On the other hand, version 2.49.5 is totally obsolete, and has serious security problems (some are even critical). #-o

So, using an unsupported OS (EOL), and an older version of SeaMonkey, with critical security issues is NOT a good option. [-(










Cheers!! 8-)
How to Ask Questions The Smart Way - How to Report Bugs Effectively ;)
Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20201115 SeaMonkey/2.53.5.1
Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20201201 SeaMonkey/2.53.6

ndebord

User avatar
 
Posts: 899
Joined: December 7th, 2002, 9:53 am

Post Posted July 24th, 2020, 4:38 pm

Buzzrr wrote:I'm still using version 2.49.5. I have many extensions which I'm afraid wouldn't be compatible with the newer 2.53.3.
Would you happen to know if uBlock Origin would then work with the older SeaMonkey browsers?


Buzzrr,

I had the same concerns when I decided to move to 2.53xxx... it took me a great deal of effort and mucking around, but eventually I managed to find substitutes or versions of extensions that worked with the newer SeaMonkey. So good luck if you are interested in mucking around too!

Nick
-N- Quis custodiet ipsos custodes
SeaMonkey(32bit), Acer Spin, Windows 10 Pro (X64 v1909), WinPatrol, MalwarebytesPremium & Avira

Return to SeaMonkey General


Who is online

Users browsing this forum: No registered users and 2 guests