MozillaZine

Future Of Java Runtime on SM

Discussion of general topics about Seamonkey
Rich-M
 
Posts: 9
Joined: September 9th, 2016, 8:21 am

Post Posted September 9th, 2016, 8:30 am

Many of the websites I use that are extremely important to me use Java and I cannot do without it.
I have not used Sea Monkey in a long time but have come back in my search for a decent browser that
still supports Java runtime but I cannot find an article anywhere about the so called end in 2016 for the other Mozilla browsers other than Firefox. And unlike others I have no issues with SM running on Windows 10 Anniversary UPdate.
Anyone know exactly what the story is on the end of java and if any of these Mozilla browsers will
stay in support of Java?

rsx11m
Moderator
 
Posts: 14415
Joined: May 3rd, 2007, 7:40 am
Location: US

Post Posted September 9th, 2016, 8:42 am

The Java plugin depends on support of the NPAPI interface, which goes all the way back to Netscape and is strictly speaking Mozilla Core code. Thus, when Firefox pulls the plug, options for SeaMonkey are either to follow or to pick up the abandoned code and create a new home for it in SeaMonkey itself (which, for example, was just done for the old Error Console and the Help viewer, which both have been removed from the core code).

There is a fuzzy statement that Flash will still be supported, I'm wondering how this would be accomplished with NPAPI removed. If remnants of that code remain for that purpose, it may be possible to also activate it for other plugins, I don't know any of those details though.

Rich-M
 
Posts: 9
Joined: September 9th, 2016, 8:21 am

Post Posted September 9th, 2016, 9:01 am

Thanks for that " a fuzzy statement" is better than no news. I had read where Opera had java embedded into core but it no longer works with it.
For the life of me I think this is really stupid because the safety issue is easily overcome and there are so many sites dependent on Java and we cannot even depend on IE which Microsoft seems to want to end as well so a move there, hateful as that feels would only be short lived anyway.

rsx11m
Moderator
 
Posts: 14415
Joined: May 3rd, 2007, 7:40 am
Location: US

Post Posted September 9th, 2016, 9:14 am

The most important argument for supporting Java is its wide-spread use in professional web applications used by companies and organizations. Converting all of those into stand-alone Java Web Start applications (the recommended fallback) may not be possible, depending on the extent the Java part is integrated into the website and has to interact with its pages. Anyway, let's see where this goes.

rsx11m
Moderator
 
Posts: 14415
Joined: May 3rd, 2007, 7:40 am
Location: US

Post Posted September 9th, 2016, 9:49 am

Well, there is a bug report open already to remove NPAPI support for most plugins with Firefox 52 (thus may affect SeaMonkey 2.49 and later):
cpeterson wrote:ESR 52 will support all NPAPI plug-ins, including Silverlight and Java. The non-ESR release of Firefox 52 will only support Flash. Here is a recent blog post outlining the schedule:

https://blog.mozilla.org/futurereleases/2016/07/20/reducing-adobe-flash-usage-in-firefox/

"ESR" refers to the Extended Support Releases which are branched off the regular releases every 7th cycle for enterprise users. So, at least for a while there seems to be a switch to enable or disable NPAPI support for all plugins. I've left a respective question in the bug report, hopefully someone will provide some specifics (assuming that they've thought about the implementation already to a sufficient level).

barbaz
 
Posts: 1667
Joined: October 1st, 2014, 3:25 pm

Post Posted September 9th, 2016, 10:39 am

Does the Java content in question work with appletviewer?
*Always* check the changelogs BEFORE updating that important software!

Rich-M
 
Posts: 9
Joined: September 9th, 2016, 8:21 am

Post Posted September 9th, 2016, 10:49 am

Great rsx11 I would love to see the response to that and am sure a lot of others are in on this as well.

James
Moderator

User avatar
 
Posts: 27013
Joined: June 18th, 2003, 3:07 pm
Location: Made in Canada

Post Posted September 9th, 2016, 1:31 pm


rsx11m
Moderator
 
Posts: 14415
Joined: May 3rd, 2007, 7:40 am
Location: US

Post Posted September 10th, 2016, 7:39 am

I've got a response in the bug report which is not very encouraging either for Java-plugin users:
cpeterson wrote:The code to support other plugins will be removed, including removing hacks to work around known bugs in those plugins.
[...]
There will be a run-time check to block plugins other than Flash. Any NPAPI code that is not needed to support Flash will be removed over time.

There is a precedent with bug 1165981 which restricted plugin use to Flash and Silverlight only for x64 platforms. It introduced a function nsPluginHost::ShouldAddPlugin() which hardwires that check into the core code (that's kind of the worst practice, but that's what they did). So, my assumption is that they will simply remove the check for platforms and make that a general rule for non-ESR builds. We will have to see how those rules are going to be exactly phrased.

Also, there are various Java-specific pieces in the plugin code. Once removed (no time line given in his response), Java probably won't function correctly any more. Along with Oracle phasing out support, its days are clearly numbered.

Rich-M
 
Posts: 9
Joined: September 9th, 2016, 8:21 am

Post Posted September 10th, 2016, 1:03 pm

Damn shame then there should be a lot of people working to find workarounds as there won't be a gaming site or financial site that anyone can use, not to mention porn sites....(of course who uses those?)

barbaz
 
Posts: 1667
Joined: October 1st, 2014, 3:25 pm

Post Posted September 10th, 2016, 2:14 pm

Rich-M wrote:Damn shame then there should be a lot of people working to find workarounds

You mean, such as the one I mentioned in my previous post in this thread?

appletviewer is usually part of JDK although I've seen it included in a couple JRE's.
*Always* check the changelogs BEFORE updating that important software!

Rich-M
 
Posts: 9
Joined: September 9th, 2016, 8:21 am

Post Posted September 10th, 2016, 6:04 pm

barbaz wrote:Does the Java content in question work with appletviewer?

Sorry I never saw this response......but no.

WaltS48

User avatar
 
Posts: 3402
Joined: May 7th, 2010, 9:38 am
Location: Pennsylvania, USA

Post Posted September 11th, 2016, 5:58 am

So ESR 52 will support all NPAPI plugins.

Sounds like good reason to base SeaMonkey on the ESR build to me.

Currently Gecko 45, which would have been the platform for SeaMonkey 2.42. That could be released as 2.45.0 or caught up to Firefox and be SM 2.45.3.0, or wait a couple weeks, work on it and release a SM 2.45.4.0 to incorporate the security and stability fixes of the next Fx 45.4.0 release.

@Rich-M
I haven't had a java plugin installed for years and haven't come across the need for one. All of my financial, health care, gaming and government sites work just fine.

It isn't like this is new news and those sites where you need a java plugin should be working on improvements to do away with it.

Mozilla intends to remove support for most NPAPI plugins in Firefox by the end of 2016. Firefox began this process several years ago with manual plugin activation, allowing users to activate plugins only when they were necessary.


REF: NPAPI Plugins in Firefox | Future Releases

It's nice to see them continuing to allow them in the ESR version.

Several years ago was 2013.

Plugins are now a legacy technology, and not available on most mobile devices. Mozilla encourages website developers to avoid using plugins wherever possible


REF: Plugin Activation in Firefox | Future Releases
Linux Desktop - AMD Athlon(tm) II X3 455 3.3GHz | 8.0GB RAM | GeForce GT 630
Windows Notebook - AMD A8 7410 2.2GHz | 6.0GB RAM | AMD Radeon R5

rsx11m
Moderator
 
Posts: 14415
Joined: May 3rd, 2007, 7:40 am
Location: US

Post Posted September 11th, 2016, 8:38 am

The only use of Java applets I've recently encountered are on websites I use professionally, thus retaining Java (and other NPAPI plugins) in the ESR branch for another round certainly makes sense. Those are usually features which are tightly integrated with the website (i.e., need authentication and the browsing context), thus can't easily be run as a stand-alone applet. The banking websites I use work without Java, but occasionally don't work properly with SeaMonkey due to bad browser sniffing on their end (which is a whole different story).

Whether or not SeaMonkey releases will come from an ESR branch in the future will certainly also depend on various other aspects and not just plugin support, but 52.0 would be a better train than going back to 45.0 for sure. It will all depend on the level of backend feature cannibalism Mozilla will be imposing at which pace in the future. For the time being, SeaMonkey could back out the disabling patch from its release branches if it stays on mozilla-release or fork the code, depending on the level of interest and effort necessary to maintain those. The easiest would be for the Mozilla core developers to introduce a build-time switch around the disabling code, but so far no willingness to do so has been shown.

The ultimate workaround is of course to access the websites in question with Firefox 52 ESR or any other (preferably current) browser which still supports plugins.

Rich-M
 
Posts: 9
Joined: September 9th, 2016, 8:21 am

Post Posted September 11th, 2016, 10:36 am

Aha so if I use the ESR version of Firefox or Sea Monkey then I can continue to have Java! That is too kewl.
WLS don't use Charles Schwab for a Brokerage company as all the meaningful software there won't work.
I don't use Pogo game site but I would say about a third of my clients do and it won't run without java...
and I would have to change banks as well....so it is meaningful to me and many of my clients.

Return to SeaMonkey General


Who is online

Users browsing this forum: No registered users and 1 guest