MozillaZine

SeaMonkey and Facebook Chat

Discussion of general topics about Seamonkey
mamaconnie

User avatar
 
Posts: 5
Joined: November 17th, 2004, 6:49 pm
Location: Port Moody, BC

Post Posted February 10th, 2016, 12:06 pm

When using SeaMonkey to access Facebook, I cannot get access to the webcam and microphone. If I try to start a chat, I get a new window that says "Click the camera and Choose 'Share Selected Devices'." But there is no camera icon to click on, or any other icons. The same window appears if someone tries to call me on FB chat. My camera and microphone work fine when I am using Skype, and FB chat works if I use Chrome. So I am pretty sure this is a SeaMonkey bug.
Sending text chats from Facebook works just fine while using SeaMonkey.
I love SeaMonkey and don't want to give it up. If anyone has any advice about this problem, I would be very grateful to hear it! Thanks.

barbaz
 
Posts: 1680
Joined: October 1st, 2014, 3:25 pm

Post Posted February 15th, 2016, 10:35 pm

I don't think SeaMonkey enables getUserMedia support in the build. IOW it doesn't have the backend to access camera or mic.
(Which IMO is better that way, I don't ever trust my web browser accessing webcam or mic :shock: ! YMMV.)


EDIT The way to enable getUserMedia aka webcam/mic access backend in SeaMonkey build is to add this line to the .mozconfig
Code: Select all
ac_add_options --enable-media-navigator
*Always* check the changelogs BEFORE updating that important software!

mamaconnie

User avatar
 
Posts: 5
Joined: November 17th, 2004, 6:49 pm
Location: Port Moody, BC

Post Posted February 16th, 2016, 12:15 am

Thanks for letting me know. If I wanted to (foolishly) add that code to the .mozconfig file, do you know where I find the file in Mac OS X (10.6)? I can do this stuff on my PC at work, but I can never find anything on my Mac at home. I feel silly asking this, but I am grateful for your help. I'm not a developer! (No joke, Sherlock!) Thanks again.
Last edited by LIMPET235 on February 16th, 2016, 5:12 am, edited 1 time in total.
Reason: Slight rephrasing of the terminology.

barbaz
 
Posts: 1680
Joined: October 1st, 2014, 3:25 pm

Post Posted February 16th, 2016, 5:21 am

mamaconnie wrote:Thanks for letting me know. If I wanted to (foolishly) add that code to the .mozconfig file, do you know where I find the file in Mac OS X (10.6)? I can do this stuff on my PC at work, but I can never find anything on my Mac at home. I feel silly asking this, but I am grateful for your help. I'm not a developer! (No ****, Sherlock!) Thanks again.

It's not a silly question. You don't have that file. It's one you have to create if you self-build SeaMonkey, and Mac OS X 10.6 is too old to self-build SeaMonkey (it required Mac OS X 10.7 and up when I last did a Mac build, and even at that building with 10.7 was tricky).

To save you some time if you choose to try to go that route, this was my last Mac OS X build mozconfig: viewtopic.php?f=42&t=2935217 (second post). You'll need to adjust the paths for your system (you likely want to build out of somewhere in your home folder, and not /srv/seamonkey - my reasons for doing that are somewhat specialized).
Double-check the Mac-specific options against the official mozconfig(s) first though, as the last SeaMonkey version I built for Mac OS X was 2.36pre2, things have likely changed since then.


Note that it is possible that getUserMedia may not work even if enabled in the build... :-k
And I should also add, you would want to build comm-release, not comm-central like those build guides say.
*Always* check the changelogs BEFORE updating that important software!

Return to SeaMonkey General


Who is online

Users browsing this forum: No registered users and 1 guest