MozillaZine

TotalMessage- experimental html5 rewrite of Tb message pane

Discussion about official Mozilla Thunderbird builds
alta88
 
Posts: 1003
Joined: January 28th, 2006, 3:08 pm

Post Posted March 12th, 2011, 11:18 am

JoeS wrote:So, with the above config, I'm seeing no remote content detection for pop3 inbox, local folders, or newsgroups.


i've uploaded a new same version rc1 to exclude feed messages (as Tb does), please download the new one. but with that pref = false, you should have seen images.

alta88
 
Posts: 1003
Joined: January 28th, 2006, 3:08 pm

Post Posted March 12th, 2011, 11:42 am

mad.engineer wrote:...


1. the count is likely correct, and you should be able to scroll past the 3 line wrap height to see the 6th. now the problem is there should also be a very small scrollbar indicating this, on the far right. are you doing something with scrollbar styling?

2. you likely need an xul namespace for that style; everything else is html except for the toolbars. they are different toolbars than the ones without the extension. and you can't style scrollbars in .css but must use Stylish.

mad.engineer
 
Posts: 314
Joined: August 8th, 2006, 4:08 pm

Post Posted March 12th, 2011, 2:11 pm

Checked again and there is no such scroll bar that you've mentioned above. However, found out that with multiple email address in a row with wrap enabled, if I move my mouse cursor over the header name itself, say Cc:, the icon turn into a hand. Clicking on the header cause the field Cc: to toggle which makes all the email addresses show. This is pretty much a toggle between wrap/un-wrap of the headers. So that solves this mystery.

Some more issues:

1) Without your add-on installed, the normal behavior of the mails with attachments is as follows:
For the emails that has attachments, single or multiple files, you can do a right-mouse click in the attachment window and it pops-up a menu with the options "Save All, Delete All, Detach All" etc.

Now with your add-on installed, for mails which has attachments in it (single or multiple files), when you do a right-mouse click in the attachment window to save them, there is no option for Save, Save All etc?. I can click on the individual file names to save them which is similar to clicking on a html link in a browser. My question is, how to do a Save All etc?. If the user have to click on every attachment file to save them, then this is not practical. Is there a way to add the option of Save, Save All back for attachments?

2) In the Attachment Window, what is the purpose of the "Toggle Select All" button?. Clicking on it don't seem to do anything?. Also the "Options" button listed next to it which when clicked takes the user to the Tools->Options->Attachments window, does not seem to be very useful here. From an end user's perspective, the attachment window do not have much real estate space available and by adding these buttons don't seem to provide any usefulness, rather take way valuable real estate space there.

3) The buttons in the Attachment window: "Pin Attachments", "Toggle Attachment Layout", "Toggle Select All" and "Options" are way too big compared to the window itself and takes away valuable real estate space and look ugly. Please see this screen shot: http://img691.imageshack.us/img691/5028/tb1c.png
I can't seem to find a way to change them into Icons only like I can do with other menu items. Is there any way to make them show up just as Icons only?. I can hide them using css, but then I'd loose the toggle functionality. Therefore, I'd rather display them, but as icons only.

4) Without your add-on, the splitter between the message header box and the message body automatically adjusts depending upon the size of the message header box (number of lines in it). But with your add-on installed, the splitter do not auto-adjust. Please see: http://img20.imageshack.us/img20/9264/tb2q.png Notice in this screen shot that there is quite a bit of space between from the Subject to the end of header box. The downside is that, I've to manually select and drag the splitter to see the headers for every single mail. Again, not very practical. Is there a way to fix this?. Thanks

alta88
 
Posts: 1003
Joined: January 28th, 2006, 3:08 pm

Post Posted March 22nd, 2011, 10:38 am

TotalMessage v1.0rc2 released.

several fixes, please see the first page for more.

alta88
 
Posts: 1003
Joined: January 28th, 2006, 3:08 pm

Post Posted March 22nd, 2011, 10:47 am

mad.engineer wrote:Some more issues:


1, 2: the Select All button was not working. now, when selecting individual attachments, or all of them, the correct buttons for save and detach and download will appear, as appropriate (to feed enclosure, or if an item hasn't already been detached/deleted).

3: this doesn't work right in Tb without TM either. you must customize on a header/attachment button and make sure the icon menuitem is selected. it doesn't reflect the global non header toolbar customize setting properly when customizing headers toolbar.

4. the header and attachment splitters are persisted, for each header mode and attachment pane position, with exactly the height/width they are dragged to.

mad.engineer
 
Posts: 314
Joined: August 8th, 2006, 4:08 pm

Post Posted March 22nd, 2011, 1:35 pm

Thanks for the clarification. Some more observations and comments. For testing out your add-on, I create a fresh/new TB Profile with each new version to keep it simple without any additional add-ons installed.

1) The attachments menu is still not working for me as I would expect. Refer to: http://img153.imageshack.us/img153/220/tb1x.png
As you can see, there is only one attachment file in this case. When I right-mouse click on the file name, you can see the menu that pops-up is not the standard TB "Save/Save All, ..." etc menu.

On the other hand, refer to: http://img841.imageshack.us/img841/807/tb2.png
Here when I click inside the attachment window itself, not on the file name, you can see that the menu that pops-up is again not the "Save/Save All, ..." TB menu that one would expect to see. So either something is not working right or I'm doing something wrong here. I'd appreciate your advise on this.

2) I figured out the icons issue with the Attachments window menu. Apparently I did not changed to show Icons only via the window customize option. That mystery is solved.

3) The header splitter seem to persist, but only when you drag it for one email. then for subsequent message it would stay. Probably something that would need to be listed in the add-on details so that the end user would understand better.

4) For the Cc:, To:, fields, the very first time I went to the headers box and checked the Wrap box while setting up the headers. I then opened a new message, the Cc: field was not wrapped and I saw truncated addresses. But then clicking on either the Cc:, To: field wrapped them and subsequent messages were wrapped as expected. Not sure if this is by design or else.

Overall it looks great, except that the attachments menu is still an issue. Thanks again.

alta88
 
Posts: 1003
Joined: January 28th, 2006, 3:08 pm

Post Posted March 22nd, 2011, 3:53 pm

1. neither of those contextmenus should be visible in attachments pane and that will be fixed. but there won't be any other context there either (perhaps text copy). that's what the buttons are for.

3. perhaps; this is the design.

4. setting autowrap on a header and clicking Apply should reflect it immediately if the message and header being viewed are the same type as the header being mapped in customize. thanks for catching a bug whereby it doesn't work for the first item in the first row (special handling reqd)..

mad.engineer
 
Posts: 314
Joined: August 8th, 2006, 4:08 pm

Post Posted March 22nd, 2011, 4:06 pm

- I'm assuming that the Attachment menu, Save/Save All issue is something on your to do list/to be fixed in the next version?
- After setting up the headers, I ensured that I click on Apply so that the changes would stick.

Again, thanks for coming up with this much needed add-on :-)

JoeS

User avatar
 
Posts: 2337
Joined: June 8th, 2003, 9:15 am

Post Posted March 22nd, 2011, 6:05 pm

I'm having trouble getting the "remote content toggle" to persist after customizing in.
After it goes away, I just see the text component is the customize panel, even after "restore defaults"

I'm mostly using "open message in a new window"
JoeS Testing current Thunderbird trunk builds WinXP SP2+
news://news.mozilla.org.mozilla.test.multimedia How to Post

alta88
 
Posts: 1003
Joined: January 28th, 2006, 3:08 pm

Post Posted March 22nd, 2011, 9:35 pm

JoeS wrote:I'm having trouble getting the "remote content toggle" to persist after customizing in.
After it goes away, I just see the text component is the customize panel, even after "restore defaults"

I'm mostly using "open message in a new window"


that button is only shown if you get a 'blocked remote content' notify (and have added it to a toolbar). it doesn't apply otherwise.. i may do the same for the js button, though it's slightly less easy than the remote content notify.

note also, that the toolbar customization state for 3pane and a standalone message window are different, each is persisted independently.

mad.engineer
 
Posts: 314
Joined: August 8th, 2006, 4:08 pm

Post Posted March 22nd, 2011, 10:13 pm

In the features, it lists "extensive keyboard only support for all functionality". Can you clarify what this is specifically referring to?.

alta88
 
Posts: 1003
Joined: January 28th, 2006, 3:08 pm

Post Posted March 23rd, 2011, 2:28 pm

mad.engineer wrote:In the features, it lists "extensive keyboard only support for all functionality". Can you clarify what this is specifically referring to?.


things like tabbing to the 'page curl' indicator, enter, and it's like a mouse hover. in customize, in the headers tree, one can use keys d, f, w, e to edit/toggle those columns. buttons have tab stops and respond to enter. the only non keyboard action is clicking on a header to toggle wrap.

mad.engineer
 
Posts: 314
Joined: August 8th, 2006, 4:08 pm

Post Posted March 23rd, 2011, 4:02 pm

"1. neither of those contextmenus should be visible in attachments pane and that will be fixed. but there won't be any other context there either (perhaps text copy). that's what the buttons are for"

==> So does this mean that the Save/Save All, ... etc menu options not showing up currently in the Attachments Window is an issue with rc2 that you plan to fix?. Thanks

alta88
 
Posts: 1003
Joined: January 28th, 2006, 3:08 pm

Post Posted March 23rd, 2011, 4:06 pm

but there won't be any other context there either (perhaps text copy). that's what the buttons are for.

mad.engineer
 
Posts: 314
Joined: August 8th, 2006, 4:08 pm

Post Posted March 23rd, 2011, 4:39 pm

"that's what the buttons are for."

==> OK, now I'm getting lost here a bit. Could you may be post a screen shot of what buttons are you referring to above?. I don't see any buttons in the Attachments window with the add-on installed that I can click to do a Save/Save All. Thanks

Return to Thunderbird Builds


Who is online

Users browsing this forum: No registered users and 2 guests