MozillaZine

*Experimental* 2003-05-21 Windows Build

Discussion about official Mozilla Thunderbird builds
buckminster
 
Posts: 99
Joined: March 13th, 2003, 11:17 am

Post Posted May 22nd, 2003, 5:37 am

Haven't noticed any major hiccups (just the font prefs draw delay, 1-2 secs for me).

Good to see major advances that are still stable and no major regressions! 8)

tve
Moderator
 
Posts: 3275
Joined: November 6th, 2002, 12:07 pm
Location: Federal Republic of Germany

Post Posted May 22nd, 2003, 6:47 am

hehe, one step ahead of Firebird with the new "Advanced" options panel ;)

thanks, looks nice and works fine so far.
<i>Latest Firefox Trunk & Thunderbird 1.0</i>

Gena01
 
Posts: 138
Joined: November 5th, 2002, 6:12 pm

Post Posted May 22nd, 2003, 7:24 am

I have installed and glanced at the test version here at work. Will probably do more extensive testing at home.

First of all the current build is rather impressive and it's nice to see the windows being cleaned up.

But here are a couple of things/ideas on possible improvements:
- I am getting the following error in Javascript console when I start thunderbird. (I created a new profile/account for thunderbird on Win2k)
Error: redeclaration of const MSG_FOLDER_FLAG_TRASH
Source File: chrome://messenger/content/commandglue.js
Line: 1

- Toolbars:
- you can't right click to cusomize it.
- changing the 'Icons/Text" combo box to any value doesn't really change anything in the toolbar. (in View->Toolbar->Customize)
- New Options:
- Connection should probably be a separate thing from "Advanced". (esp. when comparing to firebird)
- In Privacy i had "cookies" enabled. Not sure if this is the default setting or it got copied from something I had before.
- Fonts panel does take a bit loner and you can actually see the comboboxes showing up. I guess they are being recreated and populated with fonts or something.
- Any posibility to do the same thing with the Accounts window that is being done with Options?

Gena01

mscott

User avatar
 
Posts: 2516
Joined: April 2nd, 2003, 4:10 pm
Location: Thunderbird Research Center, CA

Post Posted May 22nd, 2003, 9:20 am

sgbouwhu wrote:
superstu75 wrote:The autocomplete worked fine for me in the default theme - but then I changed the theme to another one and the autocomplete stopped working. Changing back to the original theme put it right.

Stuart.


I completely forgot to mention that I was indeed using the Phoenity theme with Thunderbird too. I always unzip every file but the qute.jar, which I replaced, so I didn't think of it..

So your theory may still be right :).


That expalins it then. I have some special CSS in messengercompose.css which is part of the skin to make autocomplete work. Obviously those lines won't be there using a different theme. I'll try to move it somewhere else.
Thunderbirds are Go!

mscott

User avatar
 
Posts: 2516
Joined: April 2nd, 2003, 4:10 pm
Location: Thunderbird Research Center, CA

Post Posted May 22nd, 2003, 9:22 am

Gena01 wrote:
- Any posibility to do the same thing with the Accounts window that is being done with Options?

Gena01


I doubt it. You can have any number of accounts and each account has a set of categories underneath it. It isn't static like a pref's category list. I don't think you can use the same representation for the account manager.
Thunderbirds are Go!

RIV@NVX

User avatar
 
Posts: 467
Joined: December 24th, 2002, 7:32 am

Post Posted May 22nd, 2003, 9:33 am

http://www.mozillazine.org/forums/viewtopic.php?t=9824

Message mimetype detection bug is not fixed... :(
Unfortunately, it makes Thunderbird completely unusable for non-english people :(
Why would you even consider to use the OS that is older and more obsolete than your computer?
See, that's just one of the reasons why I pick Linux.

Sailfish
 
Posts: 5681
Joined: November 5th, 2002, 4:58 pm

Post Posted May 22nd, 2003, 9:46 am

Confirming the Options font display lag problem. Also, autocomplete seems to work well.

Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4b) Gecko/20030521 Mozilla Firebird/0.6

Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4b) Gecko/20030521 Thunderbird/0.1a

1 hour of testing...

tve
Moderator
 
Posts: 3275
Joined: November 6th, 2002, 12:07 pm
Location: Federal Republic of Germany

Post Posted May 22nd, 2003, 9:46 am

Advanced panel should get a scrollbar when expanding the various settings.
RIV@NVX wrote:Unfortunately, it makes Thunderbird completely unusable for non-english people :(

doesnt make it unusable for me.. most of the time German emails are displayed correctly, and if not, I just change it via View > Char. Coding..

TB is still pre-pre-pre-pre-pre-0.1, I dont think fixing such bugs is high on the priority list yet? and isnt it a Mozilla specific bug anyway?
<i>Latest Firefox Trunk & Thunderbird 1.0</i>

zengiman

User avatar
 
Posts: 145
Joined: January 8th, 2003, 5:28 am
Location: Amsterdam

Post Posted May 22nd, 2003, 9:51 am

PLZ somebody help me. I asked this in another tread about the previous build but nobody answered.

So here it is again: when I upgraded from one build to the next I could not open links that were in mails. So when I get a mail that somebody has answered my post in this forum, it gives me a link of the tread involved. When I click on it nothing happens anymore...BTW I use Firebird for browser.
How do I change this?

RIV@NVX

User avatar
 
Posts: 467
Joined: December 24th, 2002, 7:32 am

Post Posted May 22nd, 2003, 10:02 am

tve wrote:
RIV@NVX wrote:Unfortunately, it makes Thunderbird completely unusable for non-english people :(

doesnt make it unusable for me.. most of the time German emails are displayed correctly, and if not, I just change it via View > Char. Coding..

TB is still pre-pre-pre-pre-pre-0.1, I dont think fixing such bugs is high on the priority list yet? and isnt it a Mozilla specific bug anyway?


No, it's Thunderbird specific, and a regression. I would really like to use Thunderbird, but this blocks :(
And changing the mimetype doesn't help - it helps only if you force a mimetype, and this breaks some other mails.
I believe, since it's a regression, that it can be easily fixed.

I can confirm the Options font display lag problem, but it's not the thing that really blocks me from using Thunderbird.
Anyway, once the mimetype detection gets fixed, it will be great :)
Why would you even consider to use the OS that is older and more obsolete than your computer?
See, that's just one of the reasons why I pick Linux.

rockstiff

User avatar
 
Posts: 342
Joined: April 24th, 2003, 1:38 pm
Location: Lund, Sweden

Post Posted May 22nd, 2003, 10:03 am

zengiman wrote:PLZ somebody help me. I asked this in another tread about the previous build but nobody answered.

So here it is again: when I upgraded from one build to the next I could not open links that were in mails. So when I get a mail that somebody has answered my post in this forum, it gives me a link of the tread involved. When I click on it nothing happens anymore...BTW I use Firebird for browser.
How do I change this?

Have you set it as your default browser? Have you tried with a new profile?
Mozilla Firefox 0.9 20040817
Windows XP Professional SP1

zengiman

User avatar
 
Posts: 145
Joined: January 8th, 2003, 5:28 am
Location: Amsterdam

Post Posted May 22nd, 2003, 10:13 am

rockstiff wrote:Have you set it as your default browser?


Sorry, I knew I was stupid. :oops:

Sailfish
 
Posts: 5681
Joined: November 5th, 2002, 4:58 pm

Post Posted May 22nd, 2003, 10:23 am

zengiman wrote:
rockstiff wrote:Have you set it as your default browser? Have you tried with a new profile?


Sorry, I knew I was stupid. :oops:

Nah, I call it, "taking the initiative to ask the question"...

mscott

User avatar
 
Posts: 2516
Joined: April 2nd, 2003, 4:10 pm
Location: Thunderbird Research Center, CA

Post Posted May 22nd, 2003, 11:51 am

edmz wrote:IN the options menu, when selecting fonts, the redrawing of the controls that allow to specify a font is SO slow you can watch as each control is redrawing itself. Takes about 3-4 seconds for that "tab" to draw completely.


I see this too and it is really horrible. I *think* it's a regression in Mozilla caused by:
http://bugzilla.mozilla.org/show_bug.cgi?id=142511
Thunderbirds are Go!

RIV@NVX

User avatar
 
Posts: 467
Joined: December 24th, 2002, 7:32 am

Post Posted May 22nd, 2003, 11:57 am

mscott wrote:
edmz wrote:IN the options menu, when selecting fonts, the redrawing of the controls that allow to specify a font is SO slow you can watch as each control is redrawing itself. Takes about 3-4 seconds for that "tab" to draw completely.


I see this too and it is really horrible. I *think* it's a regression in Mozilla caused by:
http://bugzilla.mozilla.org/show_bug.cgi?id=142511


Yep, it happens in SeaMonkey too.
Why would you even consider to use the OS that is older and more obsolete than your computer?
See, that's just one of the reasons why I pick Linux.

Return to Thunderbird Builds


Who is online

Users browsing this forum: No registered users and 2 guests