MozillaZine

Thunderbird 60?

Discussion about official Mozilla Thunderbird builds
wsmwk
 
Posts: 2508
Joined: December 7th, 2004, 6:52 am

Post Posted July 25th, 2018, 8:16 am

WaltS48 wrote:Build 3 is available for testing.

We might be redoing it.

RobertJ
Moderator

User avatar
 
Posts: 10637
Joined: October 15th, 2003, 7:40 pm
Location: Chicago IL/Oconomowoc WI

Post Posted July 25th, 2018, 8:21 am

WaltS48 wrote:Build 3 is available for testing.

Thanks

.
FF 62.0 - FF 63b6 - FF 64a - TB 60.0 - Mac OSX 10.13.6
Computers I've used: IBM 7094/UNIVAC 1108/IBM 360/DEC PDP11/DEC VAX-11 780/DEC VAXstation 8000/Sun SPARCstation 2/Mac from 1984 to 2018

RobertJ
Moderator

User avatar
 
Posts: 10637
Joined: October 15th, 2003, 7:40 pm
Location: Chicago IL/Oconomowoc WI

Post Posted August 6th, 2018, 10:54 am

.
Tried TB60 today to find out that none of my 6 simple add-ons are compatible. Back to 52.9.1 Probably for ever.

.
FF 62.0 - FF 63b6 - FF 64a - TB 60.0 - Mac OSX 10.13.6
Computers I've used: IBM 7094/UNIVAC 1108/IBM 360/DEC PDP11/DEC VAX-11 780/DEC VAXstation 8000/Sun SPARCstation 2/Mac from 1984 to 2018

WaltS48

User avatar
 
Posts: 3726
Joined: May 7th, 2010, 9:38 am
Location: Pennsylvania, USA

Post Posted August 6th, 2018, 12:13 pm

RobertJ wrote:.
Tried TB60 today to find out that none of my 6 simple add-ons are compatible. Back to 52.9.1 Probably for ever.

.


Did you read the Release Notes and make the Config Editor change to disable strict compatibility?

IMPORTANT: Add-ons not marked as compatible with Thunderbird 60 by their authors will be disabled (this can be reverted via preference extensions.strictCompatibility)


REF: https://www.thunderbird.net/en-US/thund ... easenotes/

Then contact the extensions authors and request they update the extensions.
Linux Desktop - AMD Athlon(tm) II X3 455 3.3GHz | 8.0GB RAM | GeForce GT 630
Windows Notebook - AMD A8 7410 2.2GHz | 6.0GB RAM | AMD Radeon R5

RobertJ
Moderator

User avatar
 
Posts: 10637
Joined: October 15th, 2003, 7:40 pm
Location: Chicago IL/Oconomowoc WI

Post Posted August 6th, 2018, 12:34 pm

WaltS48 wrote:Did you read the Release Notes and make the Config Editor change to disable strict compatibility?


Yes but it seems to me that is a temporary solution; and, still have two that don't work.

WaltS48 wrote:Then contact the extensions authors and request they update the extensions.


Authors no longer around. Will watch for a while and see where this goes. I can live with TB52.9.1 since TB advances VERY slowly.

.
FF 62.0 - FF 63b6 - FF 64a - TB 60.0 - Mac OSX 10.13.6
Computers I've used: IBM 7094/UNIVAC 1108/IBM 360/DEC PDP11/DEC VAX-11 780/DEC VAXstation 8000/Sun SPARCstation 2/Mac from 1984 to 2018

Mouse4
 
Posts: 210
Joined: December 27th, 2017, 4:03 am
Location: Australia

Post Posted August 6th, 2018, 6:04 pm

Robert

You better keep those addons locally on your pc. Coz eventually mozilla will flush xul based extensions down the toilet once 52 goes EOL

Bob Baumeister
 
Posts: 1
Joined: August 7th, 2018, 1:09 am

Post Posted August 7th, 2018, 1:17 am

@WaltS48

Thank you for the hint "extensions.strictCompatibility" after changing to false S.3 present again

frg
 
Posts: 613
Joined: December 15th, 2015, 1:20 pm

Post Posted August 7th, 2018, 1:32 am

> Coz eventually mozilla will flush xul based extensions down the toilet once 52 goes EOL

SeaMonkey and Thunderbird add-ons are now hosted on thunderbird.net. I doubt there are any plans to flush classic add-ons there. But always a good idea to have a local backup in case the author withdraws them.

RobertJ
Moderator

User avatar
 
Posts: 10637
Joined: October 15th, 2003, 7:40 pm
Location: Chicago IL/Oconomowoc WI

Post Posted August 7th, 2018, 8:04 am

.
I have all my add-ons stored locally.

The two which do not work on TB60 are "Deselect on Delete" and "Deselect on Click". TB automatically jumping to the next email when you delete one is VERY ANNOYING and not being able to deselect an email is EQUALLY ANNOYING. I haven't checked to see if TB60 has fixed this design disaster but I'm assuming if it wasn't fixed in 52.9.1 it is still not fixed.

.
FF 62.0 - FF 63b6 - FF 64a - TB 60.0 - Mac OSX 10.13.6
Computers I've used: IBM 7094/UNIVAC 1108/IBM 360/DEC PDP11/DEC VAX-11 780/DEC VAXstation 8000/Sun SPARCstation 2/Mac from 1984 to 2018

WaltS48

User avatar
 
Posts: 3726
Joined: May 7th, 2010, 9:38 am
Location: Pennsylvania, USA

Post Posted August 7th, 2018, 7:08 pm

RobertJ wrote:.
I have all my add-ons stored locally.

The two which do not work on TB60 are "Deselect on Delete" and "Deselect on Click". TB automatically jumping to the next email when you delete one is VERY ANNOYING and not being able to deselect an email is EQUALLY ANNOYING. I haven't checked to see if TB60 has fixed this design disaster but I'm assuming if it wasn't fixed in 52.9.1 it is still not fixed.

.


What's the bug number?
Linux Desktop - AMD Athlon(tm) II X3 455 3.3GHz | 8.0GB RAM | GeForce GT 630
Windows Notebook - AMD A8 7410 2.2GHz | 6.0GB RAM | AMD Radeon R5

RobertJ
Moderator

User avatar
 
Posts: 10637
Joined: October 15th, 2003, 7:40 pm
Location: Chicago IL/Oconomowoc WI

Post Posted August 8th, 2018, 6:25 am

.
Not sure they view as bug. Been like that as long as I can remember. I have been using those two add-ons since 2012.

.
FF 62.0 - FF 63b6 - FF 64a - TB 60.0 - Mac OSX 10.13.6
Computers I've used: IBM 7094/UNIVAC 1108/IBM 360/DEC PDP11/DEC VAX-11 780/DEC VAXstation 8000/Sun SPARCstation 2/Mac from 1984 to 2018

Eckard

User avatar
 
Posts: 1307
Joined: September 5th, 2011, 8:17 am
Location: Paris (not TX)

Post Posted August 8th, 2018, 7:45 am

Hi Bob,
RobertJ wrote:.
The two which do not work on TB60 are "Deselect on Delete" and "Deselect on Click".
"Deselect on Delete 2.0" does work for me on TB 60.
Did you compare disabling "deselect-on-click"?

RobertJ
Moderator

User avatar
 
Posts: 10637
Joined: October 15th, 2003, 7:40 pm
Location: Chicago IL/Oconomowoc WI

Post Posted August 8th, 2018, 9:29 am

.
Hello Eckard,

When I have some time will give it a try but, unlike a browser, doing testing of an email client with different combinations is more of a hassle since my profile has five accounts and I don't want to pull down email while testing. I also have a major issue with disabling "strict compatibility checking" since my guess that this workaround will eventually go away.

.
FF 62.0 - FF 63b6 - FF 64a - TB 60.0 - Mac OSX 10.13.6
Computers I've used: IBM 7094/UNIVAC 1108/IBM 360/DEC PDP11/DEC VAX-11 780/DEC VAXstation 8000/Sun SPARCstation 2/Mac from 1984 to 2018

Frank Lion

User avatar
 
Posts: 20059
Joined: April 23rd, 2004, 6:59 pm
Location: ... The Exorcist....United Kingdom

Post Posted August 14th, 2018, 8:54 am

There is a bug in Thunderbird 60 (at the moment anyway) that means that a Complete Theme has to be installed and then re-installed three times before it finally shows up as it should. When it does finally deign to install these themes, then they are working fine, exactly as they should.
Metal Lion latest SeaMonkey & Thunderbird Themes - Sea Monkey and Silver Sea Monkey
"The only thing necessary for the triumph of evil, is for good men to do nothing." - Edmund Burke (attrib.)

RobertJ
Moderator

User avatar
 
Posts: 10637
Joined: October 15th, 2003, 7:40 pm
Location: Chicago IL/Oconomowoc WI

Post Posted August 15th, 2018, 10:36 am

.
Latest update.

All my add-ons (except Deselect on Click) work with TB60 if you disable extensions.strictCompatibility as noted in the release notes of TB60.

After some hacking around I found that this will also work by editing the install.rdf file in the xpi for each add-on to set

<em:maxVersion>60.*</em:maxVersion> for the target application.

Fairly simple change. Seems like TB doesn't use the VERY STRICT way of controlling the add-on's that can be installed like FF.

.
FF 62.0 - FF 63b6 - FF 64a - TB 60.0 - Mac OSX 10.13.6
Computers I've used: IBM 7094/UNIVAC 1108/IBM 360/DEC PDP11/DEC VAX-11 780/DEC VAXstation 8000/Sun SPARCstation 2/Mac from 1984 to 2018

Return to Thunderbird Builds


Who is online

Users browsing this forum: No registered users and 1 guest