MozillaZine

Build 2003-04-07 is up

Discussion about official Mozilla Firefox builds
sensemann

User avatar
 
Posts: 755
Joined: February 6th, 2003, 12:29 pm
Location: Dresden, Germany

Post Posted April 7th, 2003, 12:01 pm

[quote="Tom Sommer"]Why am I beginning to think nobody is fixing ANY phoenix specific bugs?[/quote]

that must be because there have been 25 bugs blocking 0.6 release for more than a month now... :(

zengiman

User avatar
 
Posts: 145
Joined: January 8th, 2003, 5:28 am
Location: Amsterdam

Post Posted April 7th, 2003, 12:10 pm

Allenz wrote:
Bacon wrote:Can anyone tell me how to install flash on the nightly builds of Phoenix?


Download and execute the installer from Macromedia. When if gives you the choice, select "Other Browser" and browse to the Phoenix Plugin folder.





Even better, try this: ftp://ftp.netscape.com/pub/netscape7/en ... /flash.xpi

Ewokuk
 
Posts: 416
Joined: January 31st, 2003, 7:26 am

Post Posted April 7th, 2003, 12:18 pm

gerbig wrote:Judging from my task manager, current Windows builds have a memory leak. Maybe that explains the slowdown/every new build seems fast issue.


a memory leak wouldnt cause it since itll simply go back to normal every time you restart the browser, all a memory leak MIGHT do is cause a temporary slowdown if the browsers been open a long time.

it may not even exist but a few people seem to have noticed it.

thesolo
 
Posts: 48
Joined: April 3rd, 2003, 7:33 am

Post Posted April 7th, 2003, 12:58 pm

Tom Sommer wrote:Why am I beginning to think nobody is fixing ANY phoenix specific bugs?


Well, it seems to me that since Phoenix will be "merging" with Mozilla in a few months, there may be some down time while the Moz team hammers out 1.4 final, then begins to gut Mozilla and make Phoenix the primary browser.

Just be patient is what I would say, phoenix will get a ton of development soon enough.

In the mean time, if you want something fixed right now, how about writing a patch? :)

cca93014

User avatar
 
Posts: 82
Joined: December 29th, 2002, 2:25 pm
Location: London, England

Post Posted April 7th, 2003, 4:34 pm

Just installed it. Seems like a great build. I think the smooth scrolling feels a lot smoother, although I'm not sure if that's just me! Could it be possible?
"All our beliefs are being challenged now, and rightfully so, they're stupid." - Bill Hicks

wheerdam

User avatar
 
Posts: 2771
Joined: March 30th, 2003, 7:12 pm
Location: OK, U.S.

Post Posted April 7th, 2003, 9:27 pm

Does exporting bookmark work?
Mine don't, I have to copy the bookmarks.html from my profile folder...

04072003
I'm weird, damn

zengiman

User avatar
 
Posts: 145
Joined: January 8th, 2003, 5:28 am
Location: Amsterdam

Post Posted April 7th, 2003, 11:10 pm

cca93014 wrote: I think the smooth scrolling feels a lot smoother, although I'm not sure if that's just me! Could it be possible?



Same here.

Dunderklumpen
 
Posts: 16224
Joined: March 9th, 2003, 8:12 am

Post Posted April 7th, 2003, 11:19 pm

You can now save new bookmarks but as far as I can see the export does not work.

HW71
 
Posts: 146
Joined: December 12th, 2002, 3:08 am
Location: Germany

Post Posted April 8th, 2003, 12:11 am

monofonik wrote:hate to be a bother, but they REALLY need to fix the bookmarks toolbar problem.

Of course it would be nice, if some really annoying bugs would get fixed soon (Bug 184202 is another candidate of annoying bugs) - but remember that this is an open source project and you get this all for free! So as long as nobody else is able to fix that problem and to write a patch we will have to be patient until one of the devs have the time to get this fixed! :)

Relativity_17
 
Posts: 420
Joined: March 19th, 2003, 12:47 am
Location: Sometime in 2008

Post Posted April 8th, 2003, 1:18 am

Hmm, this is the weirdest thing... I downloaded 20030407, and installed it the standard way I do, which is to delete my entire Px directory and folder, and then paste the new Px folder in. Its nice and fresh, but every time, I gotta go grab the extensions and stuff. First thing I noticed was that the custom icons for bookmarks were gone, and there was no way to assign them. I could right click on the bookmark link, select Properties, and the usual window pops up, but it was missing all except the first tab. Weird.

I shrugged it off, hoping that this build would be more stable than 20030331, which was still a bit wobbly when dealing with web forums/large images. I grabbed all the extensions I usually have; autoscroll, digger, optimoz, image nuker, themer, TBE, leech, UA switcher... Notes: nothing worked. No autoscroll (new version), on install, Px wouldn't recognize digger as a valid xpi file. Image nuker/Leech didn't add their context menus, TBE (new version from the 5th) wouldn't work, no optimoz either. Everything was fubared. Lived with it for about an hour before I gave up and reinstalled 20030331. Oops, same situation. No extension functionality at all. So I deleted everything and started over. Again, with 20030407. Clean install, just transferred the bookmark file from my old profile, along with pref.js, and my old theme. Then grabbed all the extensions again. Digger still not recognized, but optimoz, autoscroll, image nuker, leech, themer, UA switcher worked. TBE didn't add its context menu to the right click on the tabbar. Still no custom bookmark icons. Closed browser, opened browser. No change. I gave up.

Now, an hour later, everything is working. TBE, all extensions. Doesn't seem like anything is wrong with this. Except for the bumpy start, everything is smooth. Yes, the smoothscrolling seems smoother. Also, it works great on the Px Help page, where it used to be very slow. Now, its a breeze.

Here's another vote to fix the damn drag/drop bug. Creating a bookmark at this point is a bit more troublesome than it should be.

Note: Digger's site is down, that's probably why Px didn't find the xpi to be acceptable...it was a 404 error. 20030407 = peachy.

old Neil Parks
Moderator
 
Posts: 0
Joined: December 31st, 1969, 5:00 pm

Post Posted April 8th, 2003, 6:27 am

I'm using April 7 (Win ME) right now, and it seems to purr along nicely.

I had to create a new profile when upgrading from Mar 31. Before I did that, several extensions would not install properly. After creating a new profile, Preferential installed but doesn't work.

Gena01
 
Posts: 138
Joined: November 5th, 2002, 6:12 pm

Post Posted April 8th, 2003, 8:13 am

Well.. when I do an update I empty the "Cache" directory and the delete XUL.mfl file before I run new phoenix nightly. This should fix any XUL or other changes that might have been done between the builds. It should also fix a bunch of other things, like corrupted XUL.mfl file.

Gena01

Return to Firefox Builds


Who is online

Users browsing this forum: No registered users and 4 guests