MozillaZine


So Firefox 87 Beta completely broke html5 video

Discussion about official Mozilla Firefox builds
whatisthemoztricks
 
Posts: 7
Joined: January 20th, 2016, 8:57 am

Post Posted February 28th, 2021, 11:32 pm

Don't suppose anybody knows of a workaround?

Snake4
 
Posts: 1313
Joined: December 27th, 2017, 4:03 am
Location: Australia

Post Posted March 1st, 2021, 1:11 am

yeah, try a New Profile, or tell us what other troubleshooting you have done, if any

whatisthemoztricks
 
Posts: 7
Joined: January 20th, 2016, 8:57 am

Post Posted March 1st, 2021, 1:45 am

Well there's not really any troubleshooting to do. I already tried a new profile, and going back to firefox86 restores the functionality. The bug is already listed on the bugzilla. I was just wondering if anyone who is aware of the bug knew if there is anything I could do to fix it. For elements that are handled better, like on Youtube or most video sites, it works fine. The major point of failure is adult material. Some of the most popular adult material sites use the bad way. It makes it very difficult to consume my daily 80TB of videogame parody adult material.

Go here

https://www.quirksmode.org/html5/tests/video.html

For me the video elements fail. Do they work for you on 87+?

malliz
Folder@Home

User avatar
 
Posts: 44294
Joined: December 7th, 2002, 4:34 am
Location: Australia

Post Posted March 1st, 2021, 2:05 am

Works for me on this test page
https://tekeye.uk/html/html5-video-test-page
What sort of man would put a known criminal in charge of a major branch of government? Apart from, say, the average voter.
"Terry Pratchett"

whatisthemoztricks
 
Posts: 7
Joined: January 20th, 2016, 8:57 am

Post Posted March 1st, 2021, 3:16 am

malliz wrote:Works for me on this test page
https://tekeye.uk/html/html5-video-test-page


Yep, that one works for me too.

Fanolian
 
Posts: 909
Joined: February 21st, 2011, 10:14 am

Post Posted March 1st, 2021, 9:43 am

whatisthemoztricks wrote:https://www.quirksmode.org/html5/tests/video.html
For me the video elements fail. Do they work for you on 87+?

The videos linked in the page are not present in the server (404 not found).
It does not work on any browsers, at all.

The bug is already listed on the bugzilla.

Care to share the bug number?

whatisthemoztricks
 
Posts: 7
Joined: January 20th, 2016, 8:57 am

Post Posted March 2nd, 2021, 3:14 pm

Fanolian wrote:
whatisthemoztricks wrote:https://www.quirksmode.org/html5/tests/video.html
For me the video elements fail. Do they work for you on 87+?

The videos linked in the page are not present in the server (404 not found).
It does not work on any browsers, at all.

The bug is already listed on the bugzilla.

Care to share the bug number?


The players for them load on browsers which aren't broken. I'd share better links, but I can't. :-"

https://bugzilla.mozilla.org/show_bug.cgi?id=1693379

Snake4
 
Posts: 1313
Joined: December 27th, 2017, 4:03 am
Location: Australia

Post Posted March 2nd, 2021, 5:44 pm

porn sites?

Fanolian
 
Posts: 909
Joined: February 21st, 2011, 10:14 am

Post Posted March 3rd, 2021, 4:45 am

whatisthemoztricks wrote:The players for them load on browsers which aren't broken. I'd share better links, but I can't. :-"
https://bugzilla.mozilla.org/show_bug.cgi?id=1693379

The bug you quoted is about valid videos not showing in a flash fallback. If the sites you visit use flash, you may add them to the bug report to raise awareness.
https://www.quirksmode.org/html5/tests/video.html shows some cases where the controls are not shown when native videos are missing, which is a different issue.

Do you want something like the 2nd video in this pic? (4th is a valid video for comparison.)
Image

whatisthemoztricks
 
Posts: 7
Joined: January 20th, 2016, 8:57 am

Post Posted March 3rd, 2021, 10:37 am

Fanolian wrote:
whatisthemoztricks wrote:The players for them load on browsers which aren't broken. I'd share better links, but I can't. :-"
https://bugzilla.mozilla.org/show_bug.cgi?id=1693379

The bug you quoted is about valid videos not showing in a flash fallback. If the sites you visit use flash, you may add them to the bug report to raise awareness.
https://www.quirksmode.org/html5/tests/video.html shows some cases where the controls are not shown when native videos are missing, which is a different issue.

Do you want something like the 2nd video in this pic? (4th is a valid video for comparison.)


Yes it does seem to have something to do with specific fallback scenarios in the context of the Flash schemes of previous years. I guess that's why it breaks on some sites but doesn't break on more.

But to your examples though, yes, the 2nd example is closer to what I see on other browsers, but without the text and icon. However it seems like that's just what a broken video link looks like in Firefox. So, sorry for that. I tested that page in Edge and Falkon and the player controls will load just without a video. So I thought the page was triggering the Firefox bug and the broken link was not related. But in response to your post, I checked out the page in Firefox 86 (which doesn't have the family friendly bug), and it looks the exact same as 87. So that's just what that looks like in Firefox. Again, sorry for the confusion.

But in this case that's still just a broken link then. In the actual valid case, the videos are not broken links, but they still look exactly like your examples 1 and 3. It still works if you can put it in Reader mode in Firefox 87, but otherwise doesn't.

whatisthemoztricks
 
Posts: 7
Joined: January 20th, 2016, 8:57 am

Post Posted March 23rd, 2021, 5:05 am

So an update, they (or the webmasters) have done some work on this because only one of the sites that didn't work still remains non-functional.

I consider this thread something of an eyesore so if a mod wants to get rid of it you have no arguments from me.

Return to Firefox Builds


Who is online

Users browsing this forum: No registered users and 5 guests