MozillaZine

Buils that works with Legacy Ext's

Discussion about official Mozilla Firefox builds
keithy397

User avatar
 
Posts: 2345
Joined: August 29th, 2004, 6:49 pm
Location: North Wales, UK.

Post Posted May 22nd, 2019, 7:22 am

Hi.

Can you tell me which of the old builds works with all/most of the legacy ext's and where I can find them please?

I accidentally updated to the latest ESR build and I have forgotten what build I had...?! I think it was 57 maybe??
Cheers,
Keith

kerft
 
Posts: 395
Joined: January 30th, 2019, 9:38 am

Post Posted May 22nd, 2019, 7:36 am

57 is the first quantum, so no legacy extensions. 56 is the last non-quantum. 52.9.0 ESR was patched/built about a year after 56 was not. It was possible to use many modified legacy extensions with nightly builds of versions a lot higher.
This is about using nightly as high as 66. maybe even current to run downthemall: https://www.reddit.com/r/firefox/commen ... ll_way_to/

All old Firefox releases are on the "ftp" site that is actually served by html. https://ftp.mozilla.org/pub/firefox/releases/

Mark12547

User avatar
 
Posts: 288
Joined: May 13th, 2017, 11:36 am
Location: Oregon, United States, Earth

Post Posted May 22nd, 2019, 10:40 am

My recollection was that it was when Nightly was 57, not long into 57 (was in August 2017), that we had about a week of no ad blockers and setting extensions.legacy.enabled to true in about:config didn't help because the code needed for both AdBlock Plus and uBlock Origin was no longer present. Fortunately, Raymond Hill had a test version of uBlock Origin working in about a week. There were still many legacy extensions that still worked for a while, but I recall that there were reports of various extensions stopping to work or starting to cause adverse reactions spread out over a number of months. Sorry, I don't recall just how long that went on, whether it went to 58 or 59.

So, if you are going to try a Nightly or a Beta in or after 57 and set extensions.legacy.enabled to true, you will have to do some testing to verify the extensions you are interested in using are indeed working.

keithy397

User avatar
 
Posts: 2345
Joined: August 29th, 2004, 6:49 pm
Location: North Wales, UK.

Post Posted May 23rd, 2019, 4:24 am

I thought it would be easy to set up Firefox again but I've had nothing but problems, especially with the extensions and themes (aka personas) I once used. I started with build 52 and about half of my 50 or more ext's wouldn't work, so I plodded on re-installing them with some success but after 2 hours I just gave up on Firefox once and for all after years and years, well, since build 0.80!!

The past year I've been using Basilisk, which is a relation to Pale Moon and basically Firefox in different clothes but it has been working very well, just as Firefox once did. Afaik, Basilisk have no plans to follow the Firefox route so I'm going to stick with it until either there are no legacy extensions left that still work or I'm too old, or dead!!!

Thanks for your help guys.
Cheers,
Keith

kerft
 
Posts: 395
Joined: January 30th, 2019, 9:38 am

Post Posted May 23rd, 2019, 5:03 am

I expect you had heard about the add-on signing problem that Firefox recently had. All versions of Firefox needed either an update, or an added extension to make extensions work again. A 66.0.5 was released. For version 52 or 56 you needed the extension linked at the last post here: viewtopic.php?f=38&t=3049980
Although, it is true that not all extensions that work in 56 work in 52 and vice versa, and for some you need a different version number of the extension.

therube

User avatar
 
Posts: 19951
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted May 24th, 2019, 10:12 am

I have forgotten what build I had

about:support -> Show Update History may provide a clue?
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

Return to Firefox Builds


Who is online

Users browsing this forum: No registered users and 1 guest