MozillaZine

The first official 20190508 builds are out

Discussion about official Mozilla Firefox builds
Josa
 
Posts: 3905
Joined: July 28th, 2009, 4:52 pm

Post Posted May 7th, 2019, 1:14 pm

Previous Nightly Builds thread 20190507

The first official 20190508 NIGHTLY builds are out
.The Official Firefox 67 RC 1 builds are not yet out

Previous NIGHTLY: 20190507 (Fx 68.0a1)
Previous BETA: 20190507 (Fx 67.0b18)

Mozilla Inbound Builds
Treeherder
Release Notes: NIGHTLY | BETA
Changelogs: NIGHTLY | BETA


Fixed:
    NIGHTLY +55
  1. #1546544
  2. #1547016
  3. #1548816
  4. #1548959 [Core:Audio/Video: Playback]-Media_codec_used should be available in release [Uns][]
  5. #1532391 [Core:Audio/Video: Recording]-Extend lifetime of MEDIA_RECORDER_RECORDING_DURATION, MEDIA_RECORDER_TRACK_ENCODER_INIT_TIMEOUT_TYPE, and SCALARS_MEDIARECORDER.RECORDING_COUNT telemetry probes [Uns][]
  6. #1549596 [Core:CSS Parsing and Computation]-Minor servo_arc cleanups. [Uns][]
  7. #1548939 [Core:DOM: Content Processes]-Devirtualize IPDL calls to BrowserChild and organize methods a bit [Uns][]
  8. #1548358 [Core:DOM: Core & HTML]-Consider to finish forget skippable phase sooner if there is idle time to use [Uns][]
  9. #1362272 [Core:DOM: Core & HTML]-Implement notifying of rejected promises (PromiseRejectionEvent) [Uns][]
  10. #1547898 [Core:Editor]-Assertion failure: mChild || mParent->Length() == mOffset.value(), at /builds/worker/workspace/build/src/obj-firefox/dist/include/mozilla/EditorDOMPoint.h:121 [Uns][]
  11. #1548751 [Core:Editor]-Make TextEditRules::WillSetText() use fast path even with <textarea> [All][]
  12. #1549155 [Core:Editor]-Mark EditorBase::DeleteNodeWithTransaction() as MOZ_CAN_RUN_SCRIPT [All][]
  13. #1549148 [Core:Editor]-Mark EditorBase::InsertTextIntoTextNodeWithTransaction() as MOZ_CAN_RUN_SCRIPT [All][]
  14. #1549268 [Core:Editor]-Mark EditorBase::JoinNodesWithTransaction() as MOZ_CAN_RUN_SCRIPT [All][]
  15. #1549264 [Core:Editor]-Mark EditorBase::SplitNodeWithTransaction() as MOZ_CAN_RUN_SCRIPT [All][]
  16. #1549270 [Core:Editor]-Mark methods change attribute with transaction as MOZ_CAN_RUN_SCRIPT [All][]
  17. #1549746 [Core:Graphics: WebRender]-Allow WebRender for Intel devices with a battery, but running at low resolutions on nightly [Win][]
  18. #1549271 [Core:Graphics: WebRender]-Create render task graph earlier during frame building. [Uns][]
  19. #1545768 [Core:Graphics: WebRender]-Fix the bounds of text items for webrender [Uns][]
  20. #1544632 [Core:Internationalization]-Intermittent /encoding/api-invalid-label.any.html | application crashed [@ xpc::XrayTraits::resolveOwnProperty(JSContext* JS::Handle<JSObject*> JS::Handle<JSObject* JS::Handle<JSObject*> JS::Handle<JS::PropertyKey> JS::MutableHandle<JS::PropertyDescriptor [Uns][]
  21. #1549329 [Core:Internationalization]-Introduce localizable strings for unified Japanese encoding menu item and unified Cyrillic encoding menu item [Uns][]
  22. #1546383 [Core:JavaScript Engine: JIT]-Add CacheIR support for calling getters on primitive values [Uns][]
  23. #1549340 [Core:JavaScript Engine]-2.28 - 10.26% compiler_metrics num_static_constructors (android, linux, osx, windows2012) regression on push bc11fcee57413b33a88ae49a9e89d0e842a09099 (Fri Apr 26 2019) [All][]
  24. #1548075 [Core:JavaScript Engine]-AbstractGeneratorObject "closing" state is unused [Uns][[debugger-mvp]]
  25. #1548793 [Core:JavaScript Engine]-Add some more assertions around creating ProxyObjects [Uns][]
  26. #1501666 [Core:JavaScript Engine]-Assertion failure: stepperCount == trappingScript->stepModeCount(), at js/src/vm/Debugger.cpp:2382 [Lin][[jsbugmon:testComment=13,origRev=8ec327de0ba7]]
  27. #1547039 [Core:JavaScript Engine]-Crash [@ js::InterpreterActivation::resumeGeneratorFrame] or Crash [@ JSContext::runtime] or Assertion failure: !asyncGenObj->isClosed() (closed generator when resuming async generator), at vm/AsyncIteration.cpp:358 with Debugger [Lin][[jsbugmon:update]]
  28. #1545755 [Core:Javascript: WebAssembly]-WasmTextToBinary: Allow the `result` operator when specifying block/if return type [Uns][]
  29. #1548118 [Core:Layout: Columns]-Fix nested column balancing after enabling column-span [Uns][]
  30. #1507744 [Core:Layout: Text and Fonts]-word-break: break-all on an inline doesn't cause breaks [Uns][[webcompat]]
  31. #1549691 [Core:Layout]-nsLayoutUtils::GetRealPrimaryFrameFor makes no sense [Uns][]
  32. #1548133 [Core:MFBT]-mozilla::Variant::addTagToHash should be const-this [Uns][]
  33. #1549699 [Core:WebRTC: Audio/Video]-Restore previous behaviour for audio devices on Windows and Android [Uns][]
  34. #1548097 [Core:WebRTC]-getContributingSources and getSynchronizationSources should return results sorted by playout time in descending order [Uns][]
  35. #1545991 [Core:WebVR]-Intermittent Last test finished | application crashed [@ mozilla::gfx::VRManagerChild::RunFrameRequestCallbacks()] [Uns][]
  36. #1539471 [Core:Widget: Gtk]-[wayland] Track active popup windows on Wayland [Uns][]
  37. #1548634 [Core:Window Management]-Update the default letterboxing behavior to use stepped ranges [Uns][]
  38. #1545355 [Core:mozglue]-Authenticode GetBinaryOrgName not returning results from some Windows 7 builds [Win][inj+]
  39. #1546546 [Core:mozglue]-WindowsDLLInterceptor and VMSharingPolicyUnique must be destroyed in the proper order [Win][]
  40. #1545270 [DevTools:Responsive Design Mode]-Text in Settings input fields should be body color instead of grayed out [Uns][[lang=css]]
  41. #1541175 [DevTools:Responsive Design Mode]-When entering Responsive Design Mode, UI should be fixed at 100% zoom [Uns][[rdm-mvp]]
  42. #1548762 [DevTools:about:debugging]-[remote-dbg-next] Message "No devices discovered" should have color set to grey 50 [Uns][]
  43. #1542286 [DevTools:about:debugging]-[remote-dbg-next] Show Fenix logo in about:debugging and about:devtools-toolbox when connected to Fenix [Uns][[remote-debugging-reserve]]
  44. #1401324 [DevTools:about:debugging]-when loading a temporary add-on the last folder should be remembered [Uns][[remote-debugging-reserve]]
  45. #1549359 [Firefox:Activity Streams: Newtab]-Add RTL support for FxA Bookmark Panel message [Uns][]
  46. #1549906 [Firefox:Activity Streams: Newtab]-Use brandings.ftl to allow OnboardingMessageProvider.jsm to use new strings [Uns][]
  47. #1549863 [Firefox:Activity Streams: Newtab]-[Export] Add 3-card layout, card adjustments and bug fixes to Activity Stream [Uns][[export]]
  48. #1534939 [Firefox:Address Bar]-Quantumbar: the first item in the URL dropdown list should be LTR when typing a URL [Uns][]
  49. #1549543 [Firefox:Search]-Make search initialization failure more obvious [Uns][]
  50. #1548640 [Firefox:Search]-Remove `experimental-hidden` sections from Search's list.json [Uns][]
  51. #1549761 [Firefox:Site Identity and Permission Panels]-Require user interaction for push notification permission prompts in Beta [Uns][]
  52. #1547635 [Firefox:Toolbars and Customization]-PanelMultiView: Arrow keys don't navigate context menus [Uns][]
  53. #1541317 [Toolkit:Add-ons Manager]-Adding chrome_settings_overrides keys in manifest file of extension during update of version, makes the extension unusable [Uns][]
  54. #1521427 [Toolkit:Application Update]-Display the doorhanger notification for unsupported type update notifications [Uns][]
  55. #1545296 [Toolkit:Video/Audio Controls]-Clicking on the Picture-in-Picture toggle should not dispatch pointer / mouse events in content [Uns][]

    Partial Landings/Diagnostic Patches:
  1. #1546892 [Core:DOM: IndexedDB]-Consider removing the temporary fix for bug 1528690 [Uns][]
  2. #1532174 [Core:Graphics: WebRender]-Fix inconsistent transform flattening logic [Uns][[wr-q2][wr-may]]

    Beta 18 -> RC 1 Changelog +0
    None

Nightly 68 fixes since 20190318 (Gecko 67) ~2320
Beta 67 fixes since 20190128 (Gecko 66) ~2434

Nightly Blog
Release Calendar
Release Tracking
MozRegression Guide
Last edited by Josa on May 8th, 2019, 12:11 pm, edited 1 time in total.

bjherbison
 
Posts: 836
Joined: October 6th, 2003, 5:40 am
Location: Bolton, MA, US

Post Posted May 7th, 2019, 3:44 pm

If you run Release (I do occasionally) and use a Master Password (always) then you want today's 66.0.5 release
https://www.mozilla.org/en-US/firefox/6 ... easenotes/

https://bugzilla.mozilla.org/show_bug.cgi?id=1549249
66.0.4 isn't applying the intermediate certificate for some users (throwing with SEC_ERROR_TOKEN_NOT_LOGGED_IN, possibly antivirus or master password related)

dsmith
 
Posts: 228
Joined: November 5th, 2002, 1:00 pm

Post Posted May 7th, 2019, 6:32 pm

Anyone encountering significant glitches in video playback when using AV1? I've been using YouTube's test pref to always prefer AV1 (set on https://www.youtube.com/testtube ), and I've been encountering a lot of videos where there's lots of strangely-colored blocking when played as AV1, but if I change the pref so that VP9 is served, such glitches go away.

I'm not sure if this is an issue with YouTube's encoding, or Firefox's playback, or just the encoder getting out of sync with the decoder. I do know that I can view the video on Chrome without artifacts, and that I still see the artifacts in Firefox even with a fresh profile.

Sample video: https://www.youtube.com/watch?v=NL2jL_ZMuqU at 1:22 in (red gloves, yellow background and shirt). Screenshot of what I'm seeing: https://imgur.com/a/Zr8uFW8

Omega X

User avatar
 
Posts: 8122
Joined: October 18th, 2007, 2:38 pm
Location: A Parallel Dimension...

Post Posted May 7th, 2019, 6:51 pm

dsmith wrote:Anyone encountering significant glitches in video playback when using AV1? I've been using YouTube's test pref to always prefer AV1 (set on https://www.youtube.com/testtube ), and I've been encountering a lot of videos where there's lots of strangely-colored blocking when played as AV1, but if I change the pref so that VP9 is served, such glitches go away.

I'm not sure if this is an issue with YouTube's encoding, or Firefox's playback, or just the encoder getting out of sync with the decoder. I do know that I can view the video on Chrome without artifacts, and that I still see the artifacts in Firefox even with a fresh profile.

Sample video: https://www.youtube.com/watch?v=NL2jL_ZMuqU at 1:22 in (red gloves, yellow background and shirt). Screenshot of what I'm seeing: https://imgur.com/a/Zr8uFW8


I see the same thing with VP9. I'm not sure its an AV1 problem.
Latest: Firefox/68.0 *ESR/68.0 - Mobile/68.0 - Thunderbird/60.8
Nightly: Nightly/70.0a1 - Mobile/70.0a1 - Daily/70.0a1

Mark12547

User avatar
 
Posts: 279
Joined: May 13th, 2017, 11:36 am
Location: Oregon, United States, Earth

Post Posted May 7th, 2019, 10:38 pm

bjherbison wrote:If you run Release (I do occasionally) and use a Master Password (always) then you want today's 66.0.5 release
https://www.mozilla.org/en-US/firefox/6 ... easenotes/

https://bugzilla.mozilla.org/show_bug.cgi?id=1549249
66.0.4 isn't applying the intermediate certificate for some users (throwing with SEC_ERROR_TOKEN_NOT_LOGGED_IN, possibly antivirus or master password related)


Likewise for Beta/Dev, to upgrade to 67.0b18.

Alice0775

User avatar
 
Posts: 2709
Joined: October 26th, 2007, 11:25 pm
Location: OSAKA JPN

Post Posted May 7th, 2019, 11:07 pm

dsmith wrote:Anyone encountering significant glitches in video playback when using AV1? I've been using YouTube's test pref to always prefer AV1 (set on https://www.youtube.com/testtube ), and I've been encountering a lot of videos where there's lots of strangely-colored blocking when played as AV1, but if I change the pref so that VP9 is served, such glitches go away.

I'm not sure if this is an issue with YouTube's encoding, or Firefox's playback, or just the encoder getting out of sync with the decoder. I do know that I can view the video on Chrome without artifacts, and that I still see the artifacts in Firefox even with a fresh profile.

Sample video: https://www.youtube.com/watch?v=NL2jL_ZMuqU at 1:22 in (red gloves, yellow background and shirt). Screenshot of what I'm seeing: https://imgur.com/a/Zr8uFW8


Filed.
[*]#1549915 [Core:Audio/Video: Playback]-Youtube video glitch(block noise) [Win]

Mupasa
 
Posts: 28
Joined: May 22nd, 2017, 12:53 pm

Post Posted May 8th, 2019, 2:40 am

Someone can confirm this bug?

update: thanks Alice0775!

dsmith
 
Posts: 228
Joined: November 5th, 2002, 1:00 pm

Post Posted May 8th, 2019, 5:47 am

Thanks, Alice.

Are You A Wiiizard?
 
Posts: 381
Joined: August 30th, 2012, 4:27 am

Post Posted May 8th, 2019, 10:47 am

Anyone know the bug for the memory leak? After a 2hr session, Firefox is using 1.5GB memory with nothing but about:memory open. Also, things get stupidly laggy the longer the session continues.

Virtual_ManPL

User avatar
 
Posts: 1981
Joined: July 24th, 2008, 5:52 am

Post Posted May 8th, 2019, 12:07 pm

@ Are You A Wiiizard? - If it's related to playing movies, it's probably Bug 1386177 - Very high memory usage after watching many HTML5 movies on Firefox, even after closing them all.
If it's related to scrolling, it's probably Bug 1363170 - Performance of scrolling decreases with browsing time.
Except you're talking about recent regression.

Josa
 
Posts: 3905
Joined: July 28th, 2009, 4:52 pm

Post Posted May 8th, 2019, 12:12 pm


Return to Firefox Builds


Who is online

Users browsing this forum: No registered users and 4 guests