MozillaZine

White flash when opening pages in Firefox 57

Discussion about official Mozilla Firefox builds
flaneurb
 
Posts: 549
Joined: December 10th, 2011, 3:50 am

Post Posted August 28th, 2017, 10:57 pm

I posted viewtopic.php?p=14763345#p14763345 and was pointed by bjherbison to this bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1379587.

In brief, that bug deals with opening new tabs in Private mode. A white flash is seen before the purple background takes over.

I noticed something similar on some pages using the non-Private mode as well because I use a dark style to view web content.

On a chance, I used a solution posted years ago by Bozz: viewtopic.php?p=10416257&sid=29f0bb4642bf4bc41de84fdd149931d5#p10416257
Code: Select all
tabbrowser tabpanels {
background-color: #your choice !important;
}
and that still works for Firefox 57. I don't know for how long this workaround will function.

Editing in the hope of getting the Firefox user agent string to show! Hmm... doesn't work :(

smsmith
Moderator

User avatar
 
Posts: 19236
Joined: December 7th, 2004, 8:51 pm
Location: Illinois

Post Posted August 31st, 2017, 12:54 pm

I'm pretty sure there's a white flash when opening a new tab in a normal window, too. Clicking the new tab button, I see the white flash and then the gray background of about:newtab or whatever it is.

Should've read the bug report, they are already aware that it happens in normal windows.
Give a man a fish, and he eats for a day. Teach a man to fish, and he eats for a lifetime.
I like poetry, long walks on the beach and poking dead things with a stick.
Please do not PM me for personal support. Keep posts here in the Forums instead and we all learn.

Return to Firefox Builds


Who is online

Users browsing this forum: bjherbison, DN123ABC and 2 guests