MozillaZine

OSX 20030503

Discussion about official Mozilla Firefox builds
finchna
 
Posts: 25
Joined: May 4th, 2003, 11:32 am

Post Posted May 4th, 2003, 11:51 am

Hi. Great to see the OSX build of Firebird! A couple things I've noticed, and I'm not sure of the "proper" behavior related to the first one.

1) When going to a site that has a set page size, the browser window can open too small and that cuts off the right side of the content. When I click on the green resize button the window resizes to the entire size of my screen (15" TiBook) instead of just resizing big enough to display the page. This behavior, I think, is more like Windows rather than MacOS (but I may be wrong). I'd prefer the resize be just big enough to see all the page content. If it's necessary to use the whole screen fine, if not, then not.

2) The Prefs don't seem to be under the App menu but are under the Tools->Options. I'd expect to find them under Preferences of the App menu.

3) Could you included the ability to remap keyboard commands so that Command-H can be used for hide?

4) When the number of themes exceeds the height of the Themes list window a scroll bar does not appear (it does in Windows releases) and the window much be manually resized to access the themes below the bottom of the window.

Thanks for bringing this to MacOSX. What does this mean for Camino? Best wishes,

Nathan

WeSaySo
 
Posts: 475
Joined: November 5th, 2002, 8:22 am
Location: Earth

Post Posted May 4th, 2003, 7:13 pm

finchna wrote:2) The Prefs don't seem to be under the App menu but are under the Tools->Options. I'd expect to find them under Preferences of the App menu.

Bug 204416

3) Could you included the ability to remap keyboard commands so that Command-H can be used for hide?

Bug 201105
Ad astra

finchna
 
Posts: 25
Joined: May 4th, 2003, 11:32 am

Post Posted May 4th, 2003, 8:07 pm

Hi. I found the bug reporting area--apologies for reporting what's already known. Related to those bugs, I've had a rather odd thing just happen with the 0504 build that I just downloaded and installed. I'd like to know if I'm seeing things or if this might have really happened. I have two versions of Firebird on my Mac now--just in case the lastest version proved buggy.

When I first installed the 0504 build, I check the Options/Preferences and found the Preferences working under the App menu. I also saw Control-H Hide enabled and Theme selection under the Edit or View menu.

However, after using the browser for a few minutes and returning to the Prefs and where I thought I saw the Themes selector, Prefs was grayed out and the Themes selector was gone. I suppose this is just related to the bugs, but I thought I'd post it.

Please let me know if this kind of thing is better posted in the bug section--really just curious if I imagined the whole thing as I can't get things to show up again.

Otherwise the 0504 build is working well for how I've used it so far.

WeSaySo
 
Posts: 475
Joined: November 5th, 2002, 8:22 am
Location: Earth

Post Posted May 4th, 2003, 9:47 pm

finchna wrote:When I first installed the 0504 build, I check the Options/Preferences and found the Preferences working under the App menu. I also saw Control-H Hide enabled and Theme selection under the Edit or View menu.

However, after using the browser for a few minutes and returning to the Prefs and where I thought I saw the Themes selector, Prefs was grayed out and the Themes selector was gone. I suppose this is just related to the bugs, but I thought I'd post it.


See Comment #2. I'd wait on filing new bugs on this behavior since this is the first OS X build and will probably have many issues and the developers are probably aware of several of them. I played with it a bit this morning, and found at least 10 issues (starting with it non-mac look n feel). Sometime over the week I'll go back and see if they spontaneously fixed themselves.
Ad astra

idomoggie
 
Posts: 15
Joined: January 23rd, 2003, 7:31 pm
Location: AZ

Post Posted May 6th, 2003, 11:37 pm

Having problems with page not refreshing when I post. OK, maybe this will work as I had a probllem posting to the board too. My favorite theme, pinstripe, doesn't work right either.

Return to Firefox Builds


Who is online

Users browsing this forum: No registered users and 2 guests