MozillaZine

TBE support for Phoenix update by Piro

Talk about add-ons and extension development.
Goldzilla

User avatar
 
Posts: 2579
Joined: November 22nd, 2002, 6:52 pm

Post Posted February 27th, 2003, 9:34 am

There's a new TBE 2003 - 02 - 27 that I've downloaded that says it's been fixed for Phoenix. I wonder if this is for better support of the new preferences panel. I plan to install it later in the day as I'm busy at the moment. I'll send him a note to see if he's going to do anything for ContextMenu Extensions.

Meanwhile, has anyone got ContextMenu Extensions working with the new Pref Panel yet?

thenightfly42

User avatar
 
Posts: 983
Joined: November 5th, 2002, 8:03 am

Post Posted February 27th, 2003, 12:31 pm

Actually, I think the Options support was put in about 2 versions ago. I don't see any difference in the TBE preferences. Still works just fine; remember to select TBE, then hit the Settings button.

Goldzilla

User avatar
 
Posts: 2579
Joined: November 22nd, 2002, 6:52 pm

Post Posted February 27th, 2003, 12:48 pm

thenightfly42 wrote:Actually, I think the Options support was put in about 2 versions ago. I don't see any difference in the TBE preferences. Still works just fine; remember to select TBE, then hit the Settings button.


I thought that someone did that on the Phoenix side instead of a change by Piro. I got TBE working with 2/23 but CME didn't work. The settings button wasn't pushable.

jedbro

User avatar
 
Posts: 1899
Joined: November 10th, 2002, 12:35 pm
Location: Mexico / Boulder Co.

Post Posted March 2nd, 2003, 7:11 pm

Does this mean it's working in the latest builds?
I'm on Feb-21st build....
Anyone that can confirm this?

Cheers



-=-=-
... Why is it called COMMON sense when so few people have it?

* -=|TagZilla.mozdev.org|=-

Goldzilla

User avatar
 
Posts: 2579
Joined: November 22nd, 2002, 6:52 pm

Post Posted March 2nd, 2003, 7:29 pm

jedbro wrote:Does this mean it's working in the latest builds?
I'm on Feb-21st build....
Anyone that can confirm this?

Cheers



-=-=-
... Why is it called COMMON sense when so few people have it?

* -=|TagZilla.mozdev.org|=-


Piro changed TBE for the new pref panel. I made the same change in Context Menu Extensions and it worked fine with the new pref panel. Piro sent me email today saying that he would fix Context Menu Extensions soon. You can do it yourself by just coping the contents.rdf stuff he changed in TBE.

Thumper

User avatar
 
Posts: 8037
Joined: November 4th, 2002, 5:42 pm
Location: Linlithgow, Scotland

Post Posted March 2nd, 2003, 8:04 pm

It can be configured, but it doesn't actually *work* just now. At least it simply fails to work rather than breaking the bookmark menu though. The latest nightly is highly flaky with more than two tabs open anyway, so I'm unfussed.

- Chris

Goldzilla

User avatar
 
Posts: 2579
Joined: November 22nd, 2002, 6:52 pm

Post Posted March 2nd, 2003, 9:08 pm

thumperward wrote:It can be configured, but it doesn't actually *work* just now. At least it simply fails to work rather than breaking the bookmark menu though. The latest nightly is highly flaky with more than two tabs open anyway, so I'm unfussed.

- Chris


Not sure what you mean. I'm using 2003-02-21 and everything that was available to me with the old pref panel is available to me with the new pref panel. I can change settings in TBE and CME and they both work as expected. Which version of TBE are you using? The last few versions of TBE work with the new pref panel.

At any rate, Piro will release a working CME soon with the webmail fix in it too. I have it working anyways but will upgrade when he makes it available.

Thumper

User avatar
 
Posts: 8037
Joined: November 4th, 2002, 5:42 pm
Location: Linlithgow, Scotland

Post Posted March 2nd, 2003, 9:16 pm

Latest nightly and latest TBE. TBE hasn't worked well for me since I the post-0.5 nightlies; usually when it works it also completely disables going to a bookmark via the bookmark menu amongst other things.

- Chris

peterthevicar

User avatar
 
Posts: 75
Joined: January 18th, 2003, 7:48 am
Location: Southampton, England

Post Posted March 3rd, 2003, 1:20 am

I can't get TBE to work properly on recent Linux builds. The 2003-03-02 build actually crashes (no XBL binding for browser) if you install TBE. Even with older builds the restore function of TBE, which is what I liked most about it in Windows, works only patchily at best.

Goldzilla

User avatar
 
Posts: 2579
Joined: November 22nd, 2002, 6:52 pm

Post Posted March 3rd, 2003, 9:14 am

peterthevicar wrote:I can't get TBE to work properly on recent Linux builds. The 2003-03-02 build actually crashes (no XBL binding for browser) if you install TBE. Even with older builds the restore function of TBE, which is what I liked most about it in Windows, works only patchily at best.


I don't use the restore function but I'd suggest letting Piro know if you have a problem with it. I've been very selective in the nightlies that I've tried out and am with 2/21 does everything that I need [which is quite a bit]. Based on what I've seen about recent builds, I'm sticking with 2/21 though I might give 2/26 a try when I have some more time.

Goldzilla

User avatar
 
Posts: 2579
Joined: November 22nd, 2002, 6:52 pm

Post Posted March 3rd, 2003, 9:43 am

There's a bit of an intermittent bookmark problem where it displays some messy error message from the sidebar. Next time I see it, I'll send it to Piro. This is with the latest (2/27 I think) TBE and with the 2/21 nightly.

peterthevicar

User avatar
 
Posts: 75
Joined: January 18th, 2003, 7:48 am
Location: Southampton, England

Post Posted March 3rd, 2003, 10:21 am

I got a helping hand from the .jp community and TBE is now fixed for me. It just needed a small adjustment to the tabbrowser.jar file. I've also put the 'fixed' file on the web if anyone wants it. Now working beautifully with 2003-03-02 :D

See http://www.mozillazine.org/forums/viewtopic.php?p=50916#50916 for details

Goldzilla

User avatar
 
Posts: 2579
Joined: November 22nd, 2002, 6:52 pm

Post Posted March 3rd, 2003, 10:33 am

peterthevicar wrote:I got a helping hand from the .jp community and TBE is now fixed for me. It just needed a small adjustment to the tabbrowser.jar file. I've also put the 'fixed' file on the web if anyone wants it. Now working beautifully with 2003-03-02 :D

See http://www.mozillazine.org/forums/viewtopic.php?p=50916#50916 for details


Did that get fed back to Piro for a followup fix? I can live with the bookmark problem, especially as I have an older set of TBE/CME/Phoenix that's my primary browser.

jedbro

User avatar
 
Posts: 1899
Joined: November 10th, 2002, 12:35 pm
Location: Mexico / Boulder Co.

Post Posted March 3rd, 2003, 4:12 pm

I answered my own question, On the Feb 21st Build (Very nice Build), The latest version of TBE (from theoficial page) works fine.

I guess if you are having problems with recent builds, head back to Feb 21st.

Cheers


-=-=-
... "Aw Mom, you act like I'm not even wearing a bungee cord!" - Calvin

* -=|TagZilla.mozdev.org|=-

peterthevicar

User avatar
 
Posts: 75
Joined: January 18th, 2003, 7:48 am
Location: Southampton, England

Post Posted March 3rd, 2003, 4:17 pm

Goldzilla wrote:
peterthevicar wrote:I got a helping hand from the .jp community and TBE is now fixed for me. It just needed a small adjustment to the tabbrowser.jar file. I've also put the 'fixed' file on the web if anyone wants it. Now working beautifully with 2003-03-02 :D

See http://www.mozillazine.org/forums/viewtopic.php?p=50916#50916 for details


Did that get fed back to Piro for a followup fix? I can live with the bookmark problem, especially as I have an older set of TBE/CME/Phoenix that's my primary browser.


No I didn't send it to Piro. The 'conversation' I had with noririty (see the link above) included a link to a Japanese bbs with a superb automatically generated English translation - enough to get the sense of what's going on. Piro takes part in that bbs so I assumed he got the info rather before I did. I'll email him very politely just to make sure though.
(edit) Done.

Return to Extension Development


Who is online

Users browsing this forum: No registered users and 2 guests