MozillaZine

A way to install TBE on recent nightlies

Talk about add-ons and extension development.
denro
 
Posts: 450
Joined: November 4th, 2002, 10:09 pm
Location: SD, USA

Post Posted January 30th, 2003, 8:37 pm

I have had continued difficulty reinstalling tabbed browser extensions when I try to move to a recent nightly. The extensions run and install fine on the 12/28 version of Px. Here is how I finally got the extensions running. I backed up 3 files in the chrome subfolder of Phoenix (not the profiel folder) tabextensions.jar; chrome.rdf; and installed-chrome.txt. Then I installed the latest nightly on top of the 12/28 version, replacing all other files. I did not make a new profile. Copied the 3 files back to the phoenix\chrome. And then started up Phoenix normally. The 1/29 version now running and the tab browser extensions showing and working just fine. I hope eventually that the install will be smoother, but this seems the best to me for now. I'll keep the 12/28 zip file around in case I need to install other extensions.
-- Denro

alanjstr
Moderator

User avatar
 
Posts: 9100
Joined: November 5th, 2002, 4:43 pm
Location: Anywhere but here

Post Posted January 30th, 2003, 9:28 pm

Installing a new Phoenix over an old Phoenix can be very bad for your browser's health. You have been warned.
Former UMO Admin, Former MozillaZine General Mod
I am rarely on mozillaZine, so please do not send me a private message.
My Old Firefox config files

ishopnude_com

User avatar
 
Posts: 174
Joined: November 4th, 2002, 6:10 pm
Location: Palmdale, California

Post Posted January 30th, 2003, 9:55 pm

I had the same problem with installing TBE today.

I normally just install over the previous build and then if I have problems, I rename the folder and re-install.

Today I was having trouble with Phoenix not starting after installing TBE. Using a clean install fixed it.

Your best bet is to NOT install over a previous build. If you must, you should try a clean install at the first sign of problems. And you absolutely _must_ use a clean install before reporting any bugs.

Return to Extension Development


Who is online

Users browsing this forum: No registered users and 3 guests