MozillaZine

moz gestures won't run.

Talk about add-ons and extension development.
agamid
 
Posts: 190
Joined: January 16th, 2003, 9:32 pm

Post Posted January 21st, 2003, 12:27 pm

actually, david james's trick does work for me. make sure you have all the files put back in the zip file and copy all of his changes.

VinceVW
 
Posts: 113
Joined: November 13th, 2002, 4:20 am
Location: Heaven 69

Post Posted January 21st, 2003, 12:33 pm

Yes I did and doublechecked after I got that error. I actually got an older mozgest which works for me now, and I'm not touching the update with a 10ft-pole until Phoenix 0.6 comes out :|

Here is where I got the working version from: http://www.mozilla.org/projects/phoenix/extensions/

David James

User avatar
 
Posts: 1321
Joined: November 4th, 2002, 10:19 pm
Location: Ottawa, Ontario, Canada

Post Posted January 21st, 2003, 1:12 pm

This is driving me insane. Let me explain.

0.3.3 installs but its preferences don't overlay into Phoenix anymore. Nevertheless, it works. That's the one available from http://www.mozilla.org/projects/phoenix/extensions/

0.3.4 isn't ok. I don't know why I thought it was! I must have been looking at my fix for something else at the time. Yeah, I've been driven insane. Really badly. If that weren't bad enough that's the one I told Tenser to point Phoenix Help at.

0.3.5 is basically the same as 0.3.3, except I've posted a hack that should make it work (works for me anyway, which I can verify as I have now tested it). The file is only ~50kB so I might consider posting it somewhere.

Besides all that, mouse gestures departs from the usual practice of employing a .jar file inside a .xpi installer and simply skips the .jar file step.
Pinball-Firefox maintainer.
http://david.jamesnet.ca/
Debian Sid, KDE 3.3

David James

User avatar
 
Posts: 1321
Joined: November 4th, 2002, 10:19 pm
Location: Ottawa, Ontario, Canada

Post Posted January 21st, 2003, 1:31 pm

Ok, to make life easy for everyone I'll post it until it is fixed.

Download Phoenix-enabled Mouse Gestures 0.3.5

This had better work...

Edit: you'll have to download it rather than clicking on it. Or you can go to my extensions page and install it from there.
Last edited by David James on January 21st, 2003, 2:23 pm, edited 1 time in total.
Pinball-Firefox maintainer.
http://david.jamesnet.ca/
Debian Sid, KDE 3.3

VinceVW
 
Posts: 113
Joined: November 13th, 2002, 4:20 am
Location: Heaven 69

Post Posted January 21st, 2003, 1:43 pm

TYVM :D! It worked now :wink:

edit: actually after I checked the screenshots here: http://optimoz.mozdev.org/gestures/screenshots.html I don't think it worked and that it just kept version 0.3.3. In other words, I do not have that in my preferences. Running phoenix build 28-12-02, which I thought was the most recent stable one :roll:

David James

User avatar
 
Posts: 1321
Joined: November 4th, 2002, 10:19 pm
Location: Ottawa, Ontario, Canada

Post Posted January 21st, 2003, 2:05 pm

That doesn't surprise me. They both have the same name once installed and since 0.3.3 was in first, it might take priority. There are two ways out of this: attempt to manually remove 0.3.3 from your Phoenix install (it is possible and there are topics in this forum about it) and then install 0.3.5 or, easier, delete your entire Phoenix install directory and reinstall Phoenix and then all extensions. There's no need to get rid of your profile though, as you aren't upgrading Phoenix or anything like that, so all your preferences will remain intact.
Pinball-Firefox maintainer.
http://david.jamesnet.ca/
Debian Sid, KDE 3.3

myklgrant

User avatar
 
Posts: 8
Joined: December 7th, 2002, 11:19 pm
Location: Edmonton, Canada

Post Posted January 21st, 2003, 5:56 pm

to: VinceVW
Thanx they work again. re: 10ft pole - you and me both

ehume

User avatar
 
Posts: 6743
Joined: November 17th, 2002, 12:33 pm
Location: Princeton, NJ, USA

Post Posted January 21st, 2003, 8:06 pm

Install a Phoenix build 2002-12-28 or earlier.

Go to the old Phoenix extensions page ( http://www.mozilla.org/projects/phoenix/extensions/ ) and install Mouse Gestures. This gets you a mouse gestures extension that works on Phoenix.

Close and restart Phoenix. Now install MozGest 0.3.5 from http://optimoz.mozdev.org/gestures/installation.html# . Close and restart Phoenix.

This gets you the new features of 0.3.5 that will work on Phoenix. Image zooming, for example, does not, because Px does not have that Moz feature; however the mouse rocker features do work.

David James

User avatar
 
Posts: 1321
Joined: November 4th, 2002, 10:19 pm
Location: Ottawa, Ontario, Canada

Post Posted January 21st, 2003, 9:07 pm

That might not work in Linux -- it may be considered writing to existing files and balk doing it...
Pinball-Firefox maintainer.
http://david.jamesnet.ca/
Debian Sid, KDE 3.3

netsonic
 
Posts: 2
Joined: January 16th, 2003, 11:08 pm

Post Posted January 22nd, 2003, 11:43 pm

1.before anyone asks, i installed the mouse gesture extension from :
http://texturizer.net/phoenix/extensions.html

2.restart your broswer

3.close it.

4.go to

chrome\overlayinfo\browser\content

open overlays.rdf
change
chrome://browser/content/pref/preftree.xul
to
chrome://browser/content/pref/pref.xul

It works for me.

Good Luck icon_smile.gif

Return to Extension Development


Who is online

Users browsing this forum: No registered users and 2 guests