MozillaZine

Tabbed Browsing not opening links in new tab

Talk about add-ons and extension development.
mstoer

User avatar
 
Posts: 90
Joined: November 28th, 2002, 11:12 am
Location: Victoria, BC, Canada

Post Posted November 29th, 2002, 9:34 am

I installed the recent tabbed browsing extension and have it set to open tabs for unrequested windows opened by links. I took that to mean a link I click on in my stand-alone email client. I get a new window/browser instance instead. I don't want new windows, I prefer tabbed browsing only. Have I not set something right?

Marcell

Zaphod

User avatar
 
Posts: 175
Joined: November 22nd, 2002, 12:07 am
Location: Munich, DE\Europe

Post Posted November 29th, 2002, 11:04 am

Same here. After installing the original extension this bug seems to be killed ;-)
Try http://white.sakura.ne.jp/~piro/xul/_ta ... ns.html.en

Zaphod

User avatar
 
Posts: 175
Joined: November 22nd, 2002, 12:07 am
Location: Munich, DE\Europe

Post Posted November 29th, 2002, 11:17 am

Zaphod wrote:Same here. After installing the original extension this bug seems to be killed ;-)

"Orginal" means the latest version.

mstoer

User avatar
 
Posts: 90
Joined: November 28th, 2002, 11:12 am
Location: Victoria, BC, Canada

Post Posted November 29th, 2002, 11:36 am

Zaphod wrote:
Zaphod wrote:Same here. After installing the original extension this bug seems to be killed ;-)

"Orginal" means the latest version.


What did you do to get it to work properly? I followed the link, installed the newest/latest version. I checked "Single Window mode" and no new windows are opened, but links from my email are opened in the existing tab instead of new ones. I unchecked "Single Window mode" and it still does that. I have been playing around with the tabbed browsing options, but no joy sofar. I have the nightly build from Nov 28th. Which one are you using?

Marcell

Zaphod

User avatar
 
Posts: 175
Joined: November 22nd, 2002, 12:07 am
Location: Munich, DE\Europe

Post Posted November 29th, 2002, 11:46 am

I'm using the nightly from 28.11.

Try this tweak (taken from 'Phoenix Help'; http://texturizer.net/phoenix/tips.html#beh_reuse)

Stop reusing active windows

If another program wants to display a web page in the default browser, Phoenix will reuse an existing window by default, which means that it will navigate from a page you might be reading. To stop this, add the following code to your user.js file:

* // Stop reusing active windows:
user_pref("advanced.system.supportDDEExec", false);

HTH

mstoer

User avatar
 
Posts: 90
Joined: November 28th, 2002, 11:12 am
Location: Victoria, BC, Canada

Post Posted November 29th, 2002, 12:41 pm

Thanks, got it to work. I put it in my prefs.js (under Windows/Application Data/Phoenix/...).

cheers,
Marcell

notonymous

User avatar
 
Posts: 151
Joined: November 6th, 2002, 6:57 pm
Location: Beyond the fringe

Post Posted November 30th, 2002, 12:10 pm

I think you are supposed to put user-specific customisations in user.js; prefs.js is auto generated ... as the first/second line in the file warns you.

Cheers ...

alanjstr
Moderator

User avatar
 
Posts: 9100
Joined: November 5th, 2002, 4:43 pm
Location: Anywhere but here

Post Posted November 30th, 2002, 8:00 pm

mstoer wrote:Thanks, got it to work. I put it in my prefs.js (under Windows/Application Data/Phoenix/...).

cheers,
Marcell


As notonymous said, you should use user.js. One big benefit of a seperate file is that you can back it up for when you upgrade Phoenix.

Zaphod

User avatar
 
Posts: 175
Joined: November 22nd, 2002, 12:07 am
Location: Munich, DE\Europe

Post Posted December 1st, 2002, 4:21 pm

alanjstr wrote:As notonymous said, you should use user.js. One big benefit of a seperate file is that you can back it up for when you upgrade Phoenix.

But it won't be backed up automaticly, right? When i must copy this file manually, wheres the difference to back up prefs.js?

alanjstr
Moderator

User avatar
 
Posts: 9100
Joined: November 5th, 2002, 4:43 pm
Location: Anywhere but here

Post Posted December 1st, 2002, 4:47 pm

Zaphod wrote:
alanjstr wrote:As notonymous said, you should use user.js. One big benefit of a seperate file is that you can back it up for when you upgrade Phoenix.

But it won't be backed up automaticly, right? When i must copy this file manually, wheres the difference to back up prefs.js?


prefs.js is generated by Phoenix and should not be directly modified. That's why it says it at the top. Besides, any changes made by the developers could cause a problem.

mstoer

User avatar
 
Posts: 90
Joined: November 28th, 2002, 11:12 am
Location: Victoria, BC, Canada

Post Posted December 1st, 2002, 10:35 pm

alanjstr wrote:prefs.js is generated by Phoenix and should not be directly modified. That's why it says it at the top. Besides, any changes made by the developers could cause a problem.


I searched my drive and I cannot find a user.js file anywhere. Where is it suppose to be under Win98SE? pres.js is easy to find.

Marcell

laszlo

User avatar
 
Posts: 5198
Joined: November 4th, 2002, 6:13 pm
Location: .de

Post Posted December 2nd, 2002, 2:58 am

There is no user.js by default. Create it in the directory where you found prefs.js.

djst
Moderator

User avatar
 
Posts: 2826
Joined: November 5th, 2002, 1:34 am
Location: Sweden

Post Posted December 2nd, 2002, 4:44 am

mstoer wrote:
alanjstr wrote:prefs.js is generated by Phoenix and should not be directly modified. That's why it says it at the top. Besides, any changes made by the developers could cause a problem.


I searched my drive and I cannot find a user.js file anywhere. Where is it suppose to be under Win98SE? pres.js is easy to find.

Marcell


From Phoenix Help:
user.js

This is the main preferences file for Phoenix and is located in your profiles folder. The file does not exist by default, so you need to create it before you can start adding your preferences.

Windows users: If you know how to create a file, just skip this section. Before you can create the file, you must make sure that you can see the file type extensions in Windows. Start Explorer (just click on the My Computer icon on your desktop) and select File > Tools > Folder Options.... Click the View tab and uncheck the Hide extensions for known file types option. Now, go to your profile folder and select File > New > Text Document. The default name New Text Document.txt should be displayed. Change the name to user.js (click Yes on the file type warning that appears).

mstoer

User avatar
 
Posts: 90
Joined: November 28th, 2002, 11:12 am
Location: Victoria, BC, Canada

Post Posted December 2nd, 2002, 9:56 am

From Phoenix Help:
user.js

This is the main preferences file for Phoenix and is located in your profiles folder. The file does not exist by default, so you need to create it before you can start adding your preferences.

Windows users: If you know how to create a file, just skip this section. Before you can create the file, you must make sure that you can see the file type extensions in Windows. Start Explorer (just click on the My Computer icon on your desktop) and select File > Tools > Folder Options.... Click the View tab and uncheck the Hide extensions for known file types option. Now, go to your profile folder and select File > New > Text Document. The default name New Text Document.txt should be displayed. Change the name to user.js (click Yes on the file type warning that appears).


Go figure, I read the help for all sorts of things, but I never looked for that. Thanks!

MArcell

Zaphod

User avatar
 
Posts: 175
Joined: November 22nd, 2002, 12:07 am
Location: Munich, DE\Europe

Post Posted December 2nd, 2002, 10:42 am

alanjstr wrote:prefs.js is generated by Phoenix and should not be directly modified. That's why it says it at the top. Besides, any changes made by the developers could cause a problem.

Okay thanks :-)

Return to Extension Development


Who is online

Users browsing this forum: No registered users and 4 guests