MozillaZine

Need Help With Theme!

Discuss application theming and theme development.
autobio
 
Posts: 9
Joined: July 19th, 2007, 11:26 am

Post Posted July 19th, 2007, 11:29 am

I need help with putting my theme actually on FireFox. When I drag my theme (which is a .jar file) into the themes window, it installs it. But when it is done installing, it doesn't show up. Does anyone know why?

~Thanks

frcan

User avatar
 
Posts: 3305
Joined: January 23rd, 2007, 11:15 am

Post Posted July 19th, 2007, 11:34 am

You need to choose it if you want to use it.
Tools > Add-ons > Theme tab > Select the right one

steviex
Moderator

User avatar
 
Posts: 28902
Joined: August 12th, 2006, 8:27 am
Location: Middle England

Post Posted July 19th, 2007, 11:39 am

Also may be of use... http://kb.mozillazine.org/Unable_to_ins ... _-_Firefox

Moving to Firefox Support....
Only two things are infinite, the universe and human stupidity, and I'm not sure about the former. -Albert Einstein

Please DO NOT PM me for support... Lets keep it on the board, so we can all learn.

autobio
 
Posts: 9
Joined: July 19th, 2007, 11:26 am

Post Posted July 19th, 2007, 12:05 pm

When I install it and go to select it it is not there. Does anyone know why?

Thanks

frcan

User avatar
 
Posts: 3305
Joined: January 23rd, 2007, 11:15 am

Post Posted July 19th, 2007, 12:09 pm

Did you read the link Steviex posted?

autobio
 
Posts: 9
Joined: July 19th, 2007, 11:26 am

Post Posted July 19th, 2007, 12:10 pm

ya...and by the way i have firefox 2.0.0.5

autobio
 
Posts: 9
Joined: July 19th, 2007, 11:26 am

Post Posted July 19th, 2007, 12:20 pm

and by the way....i am just testing if it works...i installed a theme....right clicked it and chose Browse Install Directory......cut all of that out......pasted it inside a new folder.....modified the install.rdf.

autobio
 
Posts: 9
Joined: July 19th, 2007, 11:26 am

Post Posted July 19th, 2007, 12:25 pm

and uninstalled the theme....then zipped up my theme folder...changed it to .jar...and dragged it in there. then it asks me:

would u like to remove the extension installation delay? This feature is in place of a security safeguard, only disable if u no wat ur doing.

Yes No

I have tried clikin both and both of the times the software installation window pops up and it says install now. I click the install now button and it takes me to the installation tab,installs very quickly and it just disappears. Then i look for it in the themes tab and it is not there

autobio
 
Posts: 9
Joined: July 19th, 2007, 11:26 am

Post Posted July 23rd, 2007, 2:44 pm

well...

steviex
Moderator

User avatar
 
Posts: 28902
Joined: August 12th, 2006, 8:27 am
Location: Middle England

Post Posted July 23rd, 2007, 3:06 pm

Installing themes the easy way...

Try this one Metal Lion Vista.... https://addons.mozilla.org/en-US/firefox/addon/4626 (I know this works)

Navigate to the page above.
Do you see the green button ?
There are two methods to install the theme...

Method 1. Left click on the green button . When the countdown reaches zero, click Install then restart Firefox when installation is complete..

Method 2 Right click on the Green button. Select Save Link As Choose somewhere to save the .jar file to.
Then Open the Addons Window (Tools > Addons) and Drag the .jar file to that window. When the countdown reaches zero, click Install then Restart Firefox when installation is complete..

To select the theme for use, go to Tools > Addons > Themes and highlight the Metal Lion entry. Click on the Use Theme button. Restart Firefox.

You do NOT need to unpack the .jar file It is good to go, as it is.
Only two things are infinite, the universe and human stupidity, and I'm not sure about the former. -Albert Einstein

Please DO NOT PM me for support... Lets keep it on the board, so we can all learn.

autobio
 
Posts: 9
Joined: July 19th, 2007, 11:26 am

Post Posted July 23rd, 2007, 3:15 pm

Ya it works!

when i try to modify someones theme (yes i got permission) and i click use theme...when it restarts firefox its just the firefox default theme....HELP!

autobio
 
Posts: 9
Joined: July 19th, 2007, 11:26 am

Post Posted July 23rd, 2007, 3:15 pm

BTW thanks steviex

steviex
Moderator

User avatar
 
Posts: 28902
Joined: August 12th, 2006, 8:27 am
Location: Middle England

Post Posted July 23rd, 2007, 3:26 pm

No worries...

Chances are you've messed something up...
Have a read of ehume's 'Your own theme workshop - for beginners' http://forums.mozillazine.org/viewtopic.php?t=345753

I'm going to move this to Theme development, as you are developing themes (or just tinkering)
Only two things are infinite, the universe and human stupidity, and I'm not sure about the former. -Albert Einstein

Please DO NOT PM me for support... Lets keep it on the board, so we can all learn.

autobio
 
Posts: 9
Joined: July 19th, 2007, 11:26 am

Post Posted July 23rd, 2007, 8:30 pm

all i did was replace an image of something with the SAME file name

Return to Theme Development


Who is online

Users browsing this forum: No registered users and 1 guest