MozillaZine

Google is hiding my email due to conflict with ad-blocking

Talk about the native Mac OS X browser.

Moderator: Camino Developers

Caelum75
 
Posts: 6
Joined: October 23rd, 2009, 7:38 pm

Post Posted November 11th, 2011, 8:07 am

As of yesterday, November 10, 2011, when I go to my Gmail account and click on a new message, it takes me to the message but the content is not there. It is as though the message is rolled up into a bar at the top of the message screen and there is no opening it.
When I go to Firefox or Safari I can access my mail just fine. What is going on? Any help out there? I prefer using Camino.
Thanks.

cflawson

User avatar
 
Posts: 4721
Joined: December 26th, 2004, 2:54 pm
Location: Flying over your house in a red, white, and blue jet

Post Posted November 11th, 2011, 5:58 pm

Have you tried 2.1rc2 yet? Google seems to be slowly but surely breaking all their properties for browsers older than Gecko 1.9.2 (Firefox 3.6/Camino 2.1).

cl

Caelum75
 
Posts: 6
Joined: October 23rd, 2009, 7:38 pm

Post Posted November 11th, 2011, 6:06 pm

Thanks for posting back,

Yeah, I've upgraded to Firefox 8 and get my mail just fine. The weird thing is i have two gmail accoutns----one, no longer shows my messages and the other, right now is fine.

What do you mean by: 2.1rc2 ?

cflawson

User avatar
 
Posts: 4721
Joined: December 26th, 2004, 2:54 pm
Location: Flying over your house in a red, white, and blue jet

Post Posted November 11th, 2011, 6:55 pm

The latest pre-release version of Camino.

cl

phiw13
 
Posts: 2777
Joined: November 7th, 2002, 1:00 am
Location: Japan

Post Posted November 11th, 2011, 9:26 pm

You can get Camino 2.1rc2 from this post.

Gmail works perfectly fine with those builds.

ivankreipe
 
Posts: 18
Joined: November 12th, 2011, 2:21 am

Post Posted November 12th, 2011, 4:04 am

phiw13 wrote:You can get Camino 2.1rc2 from this post.

Gmail works perfectly fine with those builds.

As of 11-11-11 in the pm I have the same problem, In Camino, login to gmail just fine but when you try to open an email it displays a blank page with with only the title showing, no content. pages display fine Firefox,Chrome and Safari but I prefer Camino especailly for mail because it's the only one where autofill really works properly. I just did install 2.1rc2 restarted Camino and it did not fix the problem. See screenshots in the link below.
https://www.dropbox.com/gallery/1589445 ... s?h=bd40b0
my specs are;
https://mail.google.com/mail/?ui=2&shva=1#inbox
Camino
Version 2.0.9 (1.9.0.19 2011091218)
Mac os x version 10.5.8
build 9l30
help please
ivan

Yanson
 
Posts: 2
Joined: November 12th, 2011, 6:39 am

Post Posted November 12th, 2011, 6:41 am

I am experiencing this problem with Version 2.1 (1.9.2.24 20111103201058).

Caelum75
 
Posts: 6
Joined: October 23rd, 2009, 7:38 pm

Post Posted November 12th, 2011, 1:40 pm

Yanson wrote:I am experiencing this problem with Version 2.1 (1.9.2.24 20111103201058).


Glad/sad to hear others are experiencing this problem. I did the upgrade as suggested and even upgraded Flash but to no avail. I cannot read my messages unless I click "Reply" or "Forward" and then the messages are displayed as part of a reply or forward. NOT good.
Love Camino but this latest bug. Hope you get it fixed sometime. In the meantime I'll be using Firefox.

phiw13
 
Posts: 2777
Joined: November 7th, 2002, 1:00 am
Location: Japan

Post Posted November 12th, 2011, 5:18 pm

@ivankreipe
based on you screenshots, it appears that you had the pref 'Always use my page and link colors' checked in Camino Preferences > Appearance > Colors and links. That pref has been removed from the Camino preference window, but apparently still has some effect.
To reset the pref, type 'about:config' (without the quotes) in the location bar, click the big button ('I understand…') and then filter for 'browser.display.use_document_colors', reset to 'true' (double click the line).
That will at least fix part of the problem.

To others with a gmail problem: try deleting all google related cookies:
Camino Preferences > Privacy, click the 'show cookies…' button
'google.com', 'accounts.google.com', 'mail.google.com', …

Uncle Asad
Camino Developer

User avatar
 
Posts: 3957
Joined: July 24th, 2004, 1:38 pm
Location: بين العالمين

Post Posted November 12th, 2011, 5:41 pm

What happens if you use Troubleshoot Camino (http://www.ardisson.org/smokey/moz/Trou ... Camino.zip) to launch Camino using a temporary profile? Does Gmail work then?
Mac OS X 10.3.9 • PowerBook G4 17" 1.33 GHz | Mac OS X 10.5.x • MacBook Pro 15" 2.2 GHz
Snow7's Camino Forum FAQSearch the Forum  Camino. HelpTroubleshoot Camino

phiw13
 
Posts: 2777
Joined: November 7th, 2002, 1:00 am
Location: Japan

Post Posted November 12th, 2011, 8:02 pm

So, it appears that gmail is progressively pushing some changes to the underlying markup. As a result, turning on adblocking in Camino prevents seeing the individual messages / message thread.

Users of Camino 2.1 rc can fix it as follows:
1. open the file ~/Application Support/Camino/Chrome/user_ad_blocking.css in a plain text editor
2. add the following snippet at the bottom of the file and save:
Code: Select all
@-moz-document domain(mail.google.com) {
div[class~="ads"] { display: block !important;}
}

3. in Camino Preferences > Web Features, uncheck and check on again 'block web advertising'.

You should now be able to see your messages.

Caelum75
 
Posts: 6
Joined: October 23rd, 2009, 7:38 pm

Post Posted November 12th, 2011, 8:16 pm

After dinking around again, I clicked "Empty Cache", signed outand then signed in again and NOW I see my mail. Hope it holds.


That was without doing the things suggested by phiw13.

But thanks anyway.

davedit

User avatar
 
Posts: 390
Joined: October 18th, 2007, 7:56 pm
Location: San Diego, CA

Post Posted November 12th, 2011, 8:17 pm

phiw13 wrote:So, it appears that gmail is progressively pushing some changes to the underlying markup. As a result, turning on adblocking in Camino prevents seeing the individual messages / message thread.

Users of Camino 2.1 rc can fix it as follows:
1. open the file ~/Application Support/Camino/Chrome/user_ad_blocking.css in a plain text editor
2. add the following snippet at the bottom of the file and save:
Code: Select all
@-moz-document domain(mail.google.com) {
div[class~="ads"] { display: block !important;}
}

3. in Camino Preferences > Web Features, uncheck and check on again 'block web advertising'.

You should now be able to see your messages.

Thank you! This worked for me. I was wondering what was going on as well!
Camino Themes and Stuff (If that doesn't work, try the mirror)
Pimp My Camino

Caelum75
 
Posts: 6
Joined: October 23rd, 2009, 7:38 pm

Post Posted November 12th, 2011, 8:18 pm

ooops doesn't hold.

Uncle Asad
Camino Developer

User avatar
 
Posts: 3957
Joined: July 24th, 2004, 1:38 pm
Location: بين العالمين

Post Posted November 12th, 2011, 10:21 pm

phiw13 and I spent more time looking into this tonight, and his suggestion above is going cause (random!) problems collapsing messages in conversations. :-(

So we're going to fix it by removing the rule in question (div[id~="ads"] in ad_blocking.css inside Camino). I hate to recommend hacking files inside Camino.app, but that's the "best" way to fix this until we have a new build (especially for folks still using 2.0.9) :-(

If you've made phiw13's change to user_ad_blocking.css in your profile's chrome folder, you'll want to remove it to prevent problems collapsing messages in the future… :-(
Mac OS X 10.3.9 • PowerBook G4 17" 1.33 GHz | Mac OS X 10.5.x • MacBook Pro 15" 2.2 GHz
Snow7's Camino Forum FAQSearch the Forum  Camino. HelpTroubleshoot Camino

Return to Camino


Who is online

Users browsing this forum: No registered users and 1 guest