MozillaZine


Viewing my posts gives a SQL error

Talk about stuff specific to the site -- bugs, suggestions, and of course praise welcome.
James
Moderator

User avatar
 
Posts: 27833
Joined: June 18th, 2003, 3:07 pm
Location: Made in Canada

Post Posted September 22nd, 2021, 2:02 am

zlloyd1 wrote:Also, for the life of me I cannot figure to how to add an image into a post here. I click img in the toolbar above, but all it does is put two little boxes that are the letters img inside of brackets, and no means of retrieving an actual image file?? :?: :?:
I tried dragging the screenshot into the brackets, but that did nothing, and I have seen other posts here that do have links / images in them, so what am I doing wrong here Please, because I almost feel like I have to be a Rocket Scientist / Nuclear Physicist to figure out this website?? ](*,) :-X ](*,)

Should have asked this as a new thread as it is off-topic for this thread.

http://kb.mozillazine.org/Posting_a_screenshot_on_the_forum if it loads.

Since you have the image all you need to do is use a image host site like the ones suggested in the article in Uploading for general use section. There are a number of sites around like https://imgbb.com/ , https://imgur.com/upload , https://imgshare.io/ , https://imgbox.com/ , http://imageshack.us/ as example options.

If the image is large then just link to it or use the thumbnail link if the image host provides that as a link option as a large image with [img] tags in post can break the forum layout when viewing thread.

This forum like many does not allow attachments due to database load and especially due to large amount of Spam attempts this forum can get each day .

tanstaafl
Moderator

User avatar
 
Posts: 48195
Joined: July 30th, 2003, 5:06 pm

Post Posted September 22nd, 2021, 9:39 am

See http://webcache.googleusercontent.com/s ... =1&vwsrc=0 for a cached version of the KB article about how to post a screen shot.

I will try to make the explanation about the SQL error clearer.

Their attempted fix failed. I think they gave up trying to fix it because the problem is due to our server not having an updated version of phbb software and its not their job to update that software. That's what our admin is supposed to do. Since Frank found a workaround I'm not going to pester them. They said they will work on a long term plan to keep the site up and running and I don't want to risk jeopardizing that.

Our problems are due to

(1) Our admin (Jason Kerz) disappearing about 2 years ago, leaving us running on auto-pilot.

(2) We found a potential replacement admin (Ian) but he can't do anything. If Kerz was reachable we would have asked him to make Ian his successor. OSL (Open Source Lab at Oregon State University) made it clear they didn't want to get involved.

(3) With no admin there is nobody to keep the software up to date. This means some features will break over time as the environment changes. Upgrading the MySQL cluster to version 5.7 is an example of that. It depended upon a newer version of phpbb software than we have installed. This incompatibility caused ego search to fail (caused the SQL errors).

(4) We are using old dying dedicated hardware. The machine the wiki was running on already died and OSL moved it to a different host. They didn't have to do that. Kerz was supposed to move us to a OSL centrally managed virtual machine but abandoned the effort as it would take more time than he had available. That appears to be why he decided to shut down the site. He started shutting down the site (froze the wiki used by the knowledge base), and then suddenly disappeared. We have no clue why.

Frank Lion

User avatar
 
Posts: 21097
Joined: April 23rd, 2004, 6:59 pm
Location: ... The Exorcist....United Kingdom

Post Posted September 22nd, 2021, 10:56 am

tanstaafl wrote:See http://webcache.googleusercontent.com/s ... =1&vwsrc=0 for a cached version of the KB article about how to post a screen shot.

You might prefer to use the Wayback Machine Archives for our KB links

https://web.archive.org/web/20210216154 ... um#Windows

Apart from anything else, the internal links will work and images all show, i.e. -

https://web.archive.org/web/20210630073 ... on_Windows

The Wayback Machine just needs the proper KB link, not the padded link with all the Google stuff either side of the link.



zlloyd1 wrote:I am sorry, but not being a computer programmer, this is all gibberish to me honestly..

Try then not to skim read threads and especially try to read posts on that thread containing words like 'SOLUTION'.

No computer programming or Mozilla products knowledge is required or assumed on these forums, just the ability to read and, if required, to follow simple instructions.
Metal Lion SeaMonkey Themes - Sea Monkey and Silver Sea Monkey
"The only thing necessary for the triumph of evil, is for good men to do nothing." - Edmund Burke (attrib.)

ep2012
 
Posts: 824
Joined: October 20th, 2007, 11:16 pm
Location: Trying to get out of where I am. I won't say. I'm a prisoner in here now

Post Posted September 22nd, 2021, 5:01 pm

tanstaafl wrote:See http://webcache.googleusercontent.com/s ... =1&vwsrc=0 for a cached version of the KB article about how to post a screen shot.

I will try to make the explanation about the SQL error clearer.

Their attempted fix failed. I think they gave up trying to fix it because the problem is due to our server not having an updated version of phbb software and its not their job to update that software. That's what our admin is supposed to do. Since Frank found a workaround I'm not going to pester them. They said they will work on a long term plan to keep the site up and running and I don't want to risk jeopardizing that.

Our problems are due to

(1) Our admin (Jason Kerz) disappearing about 2 years ago, leaving us running on auto-pilot.

(2) We found a potential replacement admin (Ian) but he can't do anything. If Kerz was reachable we would have asked him to make Ian his successor. OSL (Open Source Lab at Oregon State University) made it clear they didn't want to get involved.

(3) With no admin there is nobody to keep the software up to date. This means some features will break over time as the environment changes. Upgrading the MySQL cluster to version 5.7 is an example of that. It depended upon a newer version of phpbb software than we have installed. This incompatibility caused ego search to fail (caused the SQL errors).

(4) We are using old dying dedicated hardware. The machine the wiki was running on already died and OSL moved it to a different host. They didn't have to do that. Kerz was supposed to move us to a OSL centrally managed virtual machine but abandoned the effort as it would take more time than he had available. That appears to be why he decided to shut down the site. He started shutting down the site (froze the wiki used by the knowledge base), and then suddenly disappeared. We have no clue why.


Oh noooo, this is terrible. I rely on this forum whenever there's something wrong. ](*,)

Are you actively looking around?

Was this a volunteer or paid position?

Thanks

tanstaafl
Moderator

User avatar
 
Posts: 48195
Joined: July 30th, 2003, 5:06 pm

Post Posted September 22nd, 2021, 7:41 pm

ep2012:

You drew the wrong conclusion from what I wrote. We're not going to go away. We just have to continue to live with some limitations/annoyances for a while. The OSL Director said "We'll try and come up with a short term solution for this site and then consider what we can do longer term. The user base is still pretty active it seems so it seems important that we try and keep things going."

ep2012
 
Posts: 824
Joined: October 20th, 2007, 11:16 pm
Location: Trying to get out of where I am. I won't say. I'm a prisoner in here now

Post Posted September 23rd, 2021, 3:22 pm

tanstaafl wrote:ep2012:

You drew the wrong conclusion from what I wrote. We're not going to go away. We just have to continue to live with some limitations/annoyances for a while. The OSL Director said "We'll try and come up with a short term solution for this site and then consider what we can do longer term. The user base is still pretty active it seems so it seems important that we try and keep things going."


Ok, great.

Behemot
 
Posts: 8
Joined: September 21st, 2021, 2:36 am

Post Posted October 11th, 2021, 2:24 pm

Is it at least like, you can get admin access? They able to get the keys for ya? Should be possible to do that if somebody has database access.

DN123ABC
 
Posts: 643
Joined: January 9th, 2017, 10:10 am

Post Posted November 10th, 2021, 9:41 am

Any word on this? Still seeing this problem. Has anybody tried restarting the server?

tanstaafl
Moderator

User avatar
 
Posts: 48195
Joined: July 30th, 2003, 5:06 pm

Post Posted November 10th, 2021, 10:27 am

I'm not going to pester them about this. Its annoying, but not important as we have a workaround. The long term solution is to get a replacement admin, who can update the software. Please re-read viewtopic.php?p=14904127#p14904127 .

morat
 
Posts: 4855
Joined: February 3rd, 2009, 6:29 pm

Post Posted November 10th, 2021, 10:46 am

Here is a userscript if anyone is interested. It uses the workaround. It doesn't fix the issue.

Code: Select all
// ==UserScript==
// @name         MozillaZine Forums
// @match        http://forums.mozillazine.org/*
// @grant        none
// ==/UserScript==

(function () {

  "use strict";

  // fix the "View your posts" link
  var link = document.querySelector('a[href^="./search.php?search_id=egosearch"]'); // may include sid parameter
  if (link) {
    var username = "morat";
    link.setAttribute("href", "./search.php?keywords=*&terms=any&author=" + escape(username) + "&start=0");
  }

  // fix the "Show your posts" and "Search user's posts" links
  var link = document.querySelector('a[href^="./search.php?author_id="][href$="&sr=posts"]');
  if (link) {
    var href = link.getAttribute("href");
    var userid = href.match(/\d+/)[0];
    link.setAttribute("href", "./search.php?keywords=*&terms=any&author_id=" + userid + "&start=0");
  }

  if (window.location.pathname == "/search.php" &&
      window.location.search.startsWith("?keywords=*&terms=any")) {

    // fix the search page links
    var links = document.querySelectorAll('a[href^="./search.php?st=0&sk=t&sd=d&sr=posts&terms=any"]');
    for (var i = 0; i < links.length; i++) {
      var href = links[i].getAttribute("href");
      href = href.replace("st=0&sk=t&sd=d&sr=posts", "keywords=*");
      links[i].setAttribute("href", href);
    }

    // add the oldie classes
    var as = document.querySelectorAll("div.postbody > h3 > a[href]");
    var count = {};
    for (var i = 0; i < as.length; i++) {
      var name = as[i].textContent;
      count[name] = count[name] ? count[name] + 1 : 1;
      if (count[name] > 1) {
        var div = as[i].parentElement.parentElement.parentElement.parentElement;
        if (div.classList.contains("bg1")) {
          div.classList.add("oldie1");
        }
        if (div.classList.contains("bg2")) {
          div.classList.add("oldie2");
        }
      }
    }

    // add the oldie styles
    var style = document.createElement("style");
    var css = ".oldie1 { background-color: #f1f1f1; }" +
              ".oldie2 { background-color: #e9e9e9; }";
    style.setAttribute("type", "text/css");
    style.appendChild(document.createTextNode(css));
    document.head.appendChild(style);

  }

})();

Remember to change the username.

Tampermonkey
http://addons.mozilla.org/firefox/addon/683490

DN123ABC
 
Posts: 643
Joined: January 9th, 2017, 10:10 am

Post Posted November 12th, 2021, 7:24 am

Nice suggestions Frank. Wish there was a way to "like" a post. Will try this some time, if they don't fix it first.

Return to MozillaZine Site Discussion


Who is online

Users browsing this forum: No registered users and 3 guests